#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:05:52 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:06:14)
    1. carbon sr2 still has blocker bugs. (jamoluhrsen, 16:06:31)
    2. the cluster issue in carbon sr2 that sam and robert are working on is not in the blocker list (jamoluhrsen, 16:08:39)
    3. only two blockers left for SR2 and maybe another week delay for that. (jamoluhrsen, 16:11:38)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=9038 (jamoluhrsen, 16:11:51)
    5. ACTION: LuisGomez to check on bug 9038 as it's an SR2 blocker (jamoluhrsen, 16:13:29)
    6. dfarrell07 suggests we could make vorburger's OOM bug (is there one) a blocker on SR2? (jamoluhrsen, 16:14:19)
    7. ACTION: jamoluhrsen to follow up with sam on why the cluster issue is not a blocker bug? (jamoluhrsen, 16:15:29)
    8. nitrogen finally has a good autorelease two days ago and it's RC1 (skipping RC0) (jamoluhrsen, 16:16:30)
    9. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=129813418 - nitrogen RC1 CSIT status (klou, 16:17:06)
    10. LuisGomez has merged a patch that will remove several projects from the distribution-test (jamoluhrsen, 16:18:01)
    11. need projects to update the tracking spreadsheet (jamoluhrsen, 16:18:21)
    12. 5 blocker bugs, 2 with progress (jamoluhrsen, 16:18:35)
    13. vorburger's OOM bug? can it be a blocker in nitro too? maybe it is already. (jamoluhrsen, 16:19:01)

  2. distribution (jamoluhrsen, 16:19:22)
    1. M5 report is in progress, wiki page updates (jamoluhrsen, 16:20:00)
    2. we need this patch merged https://git.opendaylight.org/gerrit/#/c/62207/ (jamoluhrsen, 16:20:15)
    3. new bugs coming from distro side for nitrogen. they will be blocker bugs (jamoluhrsen, 16:21:02)
    4. need bug 9028's fix merged to nitrogen (jamoluhrsen, 16:21:32)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=9034 OOM in Carbon (at least) that, if not a blocker, is a big deal (dfarrell07, 16:22:11)
    6. bug 9044 is a blocker (jamoluhrsen, 16:22:22)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=9034 If this applies to Nitrogen it should be a blocker (dfarrell07, 16:22:32)
    8. ACTION: jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker (jamoluhrsen, 16:24:15)
    9. vrpolak enjoying PTO all next week (jamoluhrsen, 16:24:41)
    10. https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-nitrogen/129/ nitrogen csit 10 hrs run time (zxiiro, 16:25:00)
    11. zxiiro wondering if we can just run -all- or -only- and not both? (jamoluhrsen, 16:26:13)
    12. jamoluhrsen suggests that we all sit around a table at DDF to find ways to clean up how much/often we do distribution-test (jamoluhrsen, 16:29:12)
    13. actually it might pretty easy "right now" to start getting rid of -only- jobs that also have -all- (jamoluhrsen, 16:32:21)
    14. ACTION: jamoluhrsen to put a patch for this now, and we can merge if there is agreement. (jamoluhrsen, 16:32:39)
    15. ACTION: LuisGomez to add this topic to DDF on the wiki (jamoluhrsen, 16:34:05)
    16. VOTE: Voted on "Are you going to DDF?" Results are, 0: 1, +1: 6 (jamoluhrsen, 16:37:38)

  3. packaging (jamoluhrsen, 16:38:40)
    1. actual packaging stuff happening in the packaging project (refactor, cleanup, fixes, improvements) (jamoluhrsen, 16:39:13)
    2. still need to get k4 vs k3 packaging to work. (jamoluhrsen, 16:39:50)
    3. opnfv seems to want to skip from carbon to oxygen and not use nitrogen (jamoluhrsen, 16:40:12)
    4. more clustering puppet tricks coming in. (jamoluhrsen, 16:40:23)

  4. builder (jamoluhrsen, 16:42:46)
    1. https://lists.opendaylight.org/pipermail/dev/2017-August/004038.html global-jjb v0.7.0 available (zxiiro, 16:42:56)
    2. Maven Verify job now available (zxiiro, 16:42:56)
    3. dfarrell07 would love reviews for https://git.opendaylight.org/gerrit/#/c/61879/ and https://git.opendaylight.org/gerrit/#/c/62158/ if his wonderful packaging committers have some cycles ;) (dfarrell07, 16:43:39)

  5. clustering (jamoluhrsen, 16:43:51)
    1. carbon has netconf clustering job failures every ~6 karaf restarts, but this never happens in the sandbox. (jamoluhrsen, 16:45:30)
    2. bug 8858 now has a fix for carbon, but sandbox job failed and maybe some memory issues, so still investigating (jamoluhrsen, 16:47:21)

  6. S3P (jamoluhrsen, 16:48:35)
    1. https://git.opendaylight.org/gerrit/#/c/62012/ Ansible role to setup hosts for scale testing (mattw4, 16:48:42)
    2. ansible role to setup hosts for scale setups has a patch. needs reviewers (jamoluhrsen, 16:49:02)
    3. next layer is getting this running on CSIT systems. (jamoluhrsen, 16:49:23)
    4. mattw4 is now officially our ansible expert (jamoluhrsen, 16:50:28)

  7. misc (jamoluhrsen, 16:51:22)
    1. gvrangan updated pike jjb patch to help get us closer to making that work. (jamoluhrsen, 16:52:05)
    2. https://wiki.opendaylight.org/view/Dynamically_Adding_Nodes_to_an_Existing_Cluster <-- adding nodes to an existing cluster (jamoluhrsen, 16:52:27)
    3. vrpolak knows that certain aspects of clustering will not work on new nodes that are added to an existing cluster (jamoluhrsen, 16:53:05)
    4. we need cluster experts to review gvrangan's wiki (jamoluhrsen, 16:53:42)


Meeting ended at 16:55:20 UTC (full logs).

Action items

  1. LuisGomez to check on bug 9038 as it's an SR2 blocker
  2. jamoluhrsen to follow up with sam on why the cluster issue is not a blocker bug?
  3. jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker
  4. jamoluhrsen to put a patch for this now, and we can merge if there is agreement.
  5. LuisGomez to add this topic to DDF on the wiki


Action items, by person

  1. dfarrell07
    1. jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker
  2. jamoluhrsen
    1. jamoluhrsen to follow up with sam on why the cluster issue is not a blocker bug?
    2. jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker
    3. jamoluhrsen to put a patch for this now, and we can merge if there is agreement.
  3. LuisGomez
    1. LuisGomez to check on bug 9038 as it's an SR2 blocker
    2. LuisGomez to add this topic to DDF on the wiki
  4. vorburger
    1. jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker


People present (lines said)

  1. jamoluhrsen (51)
  2. dfarrell07 (11)
  3. odl_meetbot (9)
  4. vorburger (6)
  5. zxiiro (6)
  6. vrpolak (3)
  7. gvrangan (2)
  8. klou (2)
  9. LuisGomez (2)
  10. mattw4 (2)


Generated by MeetBot 0.1.4.