#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:05:10 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:05:40)
    1. carbon SR2 still has 6 blocker bugs. more delays there. (jamoluhrsen, 16:06:35)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 (jamoluhrsen, 16:06:57)
    3. ACTION: jamoluhrsen to check if 9063 and 9064 are really blockers (jamoluhrsen, 16:07:37)
    4. nitro has rc2 build and we need projects to update csit results (jamoluhrsen, 16:08:26)
    5. nitro also has 6 blocker bugs (jamoluhrsen, 16:08:45)
    6. nitro will be delayed some number of weeks as well. (jamoluhrsen, 16:09:24)
    7. https://git.opendaylight.org/gerrit/#/c/62489/ (dfarrell07, 16:10:48)

  2. packaging (jamoluhrsen, 16:11:11)
    1. still working (based on pressure from opnfv) on all the different rpm logic (jamoluhrsen, 16:11:48)
    2. releng builder now able to use tarballs and zips (jamoluhrsen, 16:12:48)
    3. packaging UT is increasing as well (jamoluhrsen, 16:13:15)
    4. nitro rpms are pushing to right repo now. (jamoluhrsen, 16:13:46)
    5. opnfv folks helping with our ansible stuff (e.g. sfc changes) (jamoluhrsen, 16:14:35)
    6. https://git.opendaylight.org/gerrit/#/c/61879/ (dfarrell07, 16:15:30)
    7. dfarrell07 asks when we will enable oxy autorelease, but we can't handle all the jobs so we have to wait until we release carbon and/or nitro and/or the -only- jobs are removed (jamoluhrsen, 16:17:04)
    8. ACTION: zxiiro to merge the patch to remove -only- jobs on Tuesday 9/5 (jamoluhrsen, 16:17:46)

  3. builder (jamoluhrsen, 16:17:56)
    1. https://git.opendaylight.org/gerrit/61991 Group IDs added to Heat Orchestration Templates (zxiiro, 16:18:07)
    2. groupid is now there in our VM names, which ensures all CSIT VMs have unique hostnames (jamoluhrsen, 16:18:41)
    3. https://jira.linuxfoundation.org/browse/RELENG-243 sonar job migrated to global jjb (zxiiro, 16:18:59)
    4. mvn sonar job now migrated to global-jjb, which means all the standard mvn jobs are now migrated. But, only two projects are using global-jjb currently. in coming months we'll migrate more projects over (jamoluhrsen, 16:19:49)
    5. https://gerrit.linuxfoundation.org/infra/6245 WIP: Job to lock/unlock branches for a project (zxiiro, 16:20:58)
    6. global-jjb has a job that will lock or unlock branches. type lockbranch or unlockbranch in a gerrit patch and it will create a new patch to lock/unlock accordingly. the patch still needs to be merged (jamoluhrsen, 16:22:35)
    7. https://git.opendaylight.org/gerrit/62454 Generate csit job list automatically for distribution-test job (zxiiro, 16:22:47)
    8. https://jenkins.opendaylight.org/releng/job/integration-distribution-test-carbon/244/ (zxiiro, 16:23:12)
    9. https://github.com/zxiiro/license-header-checker golang based license checker (zxiiro, 16:25:03)

  4. distribution (jamoluhrsen, 16:26:28)
    1. LuisGomez and Vratko are not here today, so no info. (jamoluhrsen, 16:26:42)

  5. S3P (jamoluhrsen, 16:27:22)
    1. no updates really, just more ansible work. (jamoluhrsen, 16:28:21)

  6. misc (jamoluhrsen, 16:28:25)
    1. https://jenkins.opendaylight.org/releng/job/ansible-verify-tox-master/24/console\ (dfarrell07, 16:28:57)
    2. https://docs.google.com/presentation/d/1NOZYpnfsk1IgvZysHRwfPgz130LviumRCpGBw1X14NY/edit?usp=sharing Jenkins Job Builder presentation (zxiiro, 16:29:39)
    3. https://github.com/lfit/releng-global-jjb/blob/master/jjb/lf-macros.yaml#L6-L14 inject variables into a shell script (zxiiro, 16:31:48)


Meeting ended at 16:41:56 UTC (full logs).

Action items

  1. jamoluhrsen to check if 9063 and 9064 are really blockers
  2. zxiiro to merge the patch to remove -only- jobs on Tuesday 9/5


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to check if 9063 and 9064 are really blockers
  2. zxiiro
    1. zxiiro to merge the patch to remove -only- jobs on Tuesday 9/5


People present (lines said)

  1. jamoluhrsen (27)
  2. zxiiro (8)
  3. dfarrell07 (4)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.