#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:58 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:03:45)
    1. nitro has RC3 ready today, but tracking 11 blocker bugs still. (jamoluhrsen, 16:04:12)
    2. 51 CSIT jobs with failures, but 26 still need reviewed. (jamoluhrsen, 16:04:41)
    3. looks like all but 3 of the blockers have some sort of progress (jamoluhrsen, 16:05:48)
    4. anipbu suggests we need to do release reviews as soon as possible (jamoluhrsen, 16:07:52)
    5. we should start deleting CSIT jobs if those jobs are marked IGNORE two releases in a row (jamoluhrsen, 16:18:21)
    6. carbon SR2 is postponed, per TSC discussion, and will revisit SR2 once nitro is released. carbon is unlocked and patches are going in (jamoluhrsen, 16:19:25)
    7. anipbu points out that we need an OXY release plan, and suggests that we can do it at the DDF (jamoluhrsen, 16:21:18)
    8. hopefully it can only be updates to what we used for nitrogen (using lessons learned, etc) (jamoluhrsen, 16:21:50)
    9. ACTION: klou to bring up the oxy release plan on the TSC call. (jamoluhrsen, 16:24:41)
    10. https://github.com/opendaylight/releng-autorelease/tree/master/scripts/release-calendar release calendar python script (zxiiro, 16:25:33)

  2. distribution (jamoluhrsen, 16:26:20)
    1. karaf4 is no longer built in carbon, to avoid confusion (carbon is k3 based) (jamoluhrsen, 16:26:46)
    2. nitro now includes the aaa-cli standalone tool (jamoluhrsen, 16:27:02)
    3. nitro version functionality was broken in nitrogen, but now it's fixed. (jamoluhrsen, 16:27:28)
    4. still no M5 email from int/dist project, but most other updates should be there. (jamoluhrsen, 16:28:17)
    5. anipbu notes that M5 is important because we need to know CLM issues before the release (jamoluhrsen, 16:28:42)

  3. builder (jamoluhrsen, 16:32:10)
    1. -only- jobs are gone now, and it looks like we have cut down our distribution-test job in half (from 10h to 5h) (jamoluhrsen, 16:33:05)
    2. global-jjb new release, with some readthedocs and sonar job updates (jamoluhrsen, 16:33:25)
    3. looking to get a nexus3 instance from LF so we can mirror the pip packages to make those installs faster (jamoluhrsen, 16:34:33)
    4. zxiiro is travelling for work the next 2 weeks, so slow to respond... (jamoluhrsen, 16:35:14)

  4. clustering (jamoluhrsen, 16:35:29)
    1. things are improving (e.g. 8858 is fixed), but still some infrequent bugs happening. (jamoluhrsen, 16:36:08)
    2. so only 3 cluster specific bugs being tracked, but only affecting new functionality. (jamoluhrsen, 16:37:36)
    3. bug 9027 w/ ODL not restarting properly is still under investigation (jamoluhrsen, 16:39:41)
    4. ACTION: jamoluhrsen to DUP 9075 to 9044 (can't connect to karaf ssh in Cluster CSIT after restarting nodes) (jamoluhrsen, 16:41:25)

  5. misc (jamoluhrsen, 16:42:28)


Meeting ended at 16:43:10 UTC (full logs).

Action items

  1. klou to bring up the oxy release plan on the TSC call.
  2. jamoluhrsen to DUP 9075 to 9044 (can't connect to karaf ssh in Cluster CSIT after restarting nodes)


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to DUP 9075 to 9044 (can't connect to karaf ssh in Cluster CSIT after restarting nodes)
  2. klou
    1. klou to bring up the oxy release plan on the TSC call.


People present (lines said)

  1. jamoluhrsen (33)
  2. odl_meetbot (4)
  3. skitt (2)
  4. LuisGomez (2)
  5. zxiiro (2)
  6. klou (1)
  7. odp-gerritbot (1)


Generated by MeetBot 0.1.4.