#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:53 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:03:46)
    1. nitrogen is released this week, so now focus is carbon SR2 and nitro SR1 (jamoluhrsen, 16:04:21)
    2. carbon autorelease finally worked now that we pulled out next project (jamoluhrsen, 16:04:53)
    3. ACTION: seems the problem with next is npm (i.e., node) related. but it seems that next is not responding yet and we've reached out to dlux to see if they can help. (jamoluhrsen, 16:06:55)
    4. since next is it's own separate download we could continue to release carbon SR2 and let others download the previous version (jamoluhrsen, 16:07:52)
    5. also it should be noted that next is not going to be in nitrogen as well. (jamoluhrsen, 16:08:25)
    6. ACTION: zxiiro to draft email to TSC with options for dealing with next (jamoluhrsen, 16:09:31)
    7. two blocker bugs for carbon sr2 (jamoluhrsen, 16:09:40)
    8. there may be more than just two bugs... need to update spreadsheet (jamoluhrsen, 16:10:10)
    9. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 - carbon blocker bugs (klou, 16:10:11)
    10. ACTION: jamoluhrsen to do a blocker bug query and update spreadsheet (jamoluhrsen, 16:10:23)
    11. oxygen still has 5 projects that haven't sent their feedback to be in the release (mdsal, snmp, cardinal, eman, ttp) (jamoluhrsen, 16:12:49)
    12. ACTION: vrpolak to remind rovarga to send official email about mdsal being in release (jamoluhrsen, 16:13:48)
    13. ACTION: jamoluhrsen to track down snmp folks to see if they want to be in oxy (jamoluhrsen, 16:13:59)
    14. ACTION: LuisGomez to double check with colin about ttp (jamoluhrsen, 16:14:31)
    15. the oxy participation deadline was 3 weeks ago. (jamoluhrsen, 16:15:41)
    16. the oxygen release plan needs official approval from TSC (jamoluhrsen, 16:16:52)
    17. https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan <--- oxy release plan (jamoluhrsen, 16:17:08)
    18. it's probably too late to require projects to untangle their bundle/feature dependencies in oxygen, but maybe we can get a non-voting job working in the oxy timeframe and then make it a requirement in Flourine (jamoluhrsen, 16:19:35)
    19. we need to get back to vetting projects csit and giving feedback from int/test. (jamoluhrsen, 16:21:54)
    20. ACTION: jamoluhrsen to send the email to tell projects that if they have gone two releases marking their CSIT jobs as IGNORE, we will remove their jobs (jamoluhrsen, 16:24:38)

  2. distribution (jamoluhrsen, 16:25:30)
    1. no movement in the distribution code base. (jamoluhrsen, 16:25:49)
    2. int/dist needs to create a release plan for oxy and the plan wont advertise that we will NOT have a stable distribution (jamoluhrsen, 16:26:29)

  3. clustering (jamoluhrsen, 16:27:55)
    1. bug 9145 has a patch in place for oxy and seems to make the OFP scenario much more stable, but there is still one other corner case that probably needs fixing. (jamoluhrsen, 16:28:27)
    2. bug 9145 fix is only on oxy for now, but we have that bug as a blocker in carbon (jamoluhrsen, 16:30:21)

  4. builder (jamoluhrsen, 16:34:00)
    1. https://gerrit.linuxfoundation.org/infra/6419 Deploy Sandbox job directly in Gerrit Comment (zxiiro, 16:34:09)
    2. the idea is you push a releng/builder patch to gerrit and then you can use a gerrit keyword to push jobs to the sandbox meaning people don't have to have JJB installed locally (jamoluhrsen, 16:36:14)
    3. jjb-deploy JOB_NAME (zxiiro, 16:36:30)
    4. we need a quick how-to/docs on how to use this (jamoluhrsen, 16:37:48)
    5. there is hope that we can get a global-docs project so we can post these kinds of cross-project info to one place (jamoluhrsen, 16:38:15)
    6. new java doc deployment job strategy coming. (jamoluhrsen, 16:39:19)
    7. goal is to have a single location for all java docs (jamoluhrsen, 16:39:35)

  5. S3P (jamoluhrsen, 16:39:58)
    1. s3p sandbox jobs starting to happen. (jamoluhrsen, 16:40:34)

  6. misc (jamoluhrsen, 16:41:43)
    1. mdsal is waiting for oxy release plan to be fully approved before sending their intent to participate (jamoluhrsen, 16:42:34)
    2. ACTION: jamoluhrsen to reply on that release plan thread to see if we want to vote via email or wait until next TSC. (jamoluhrsen, 16:44:31)
    3. we still need to figure out the -all- vs -only- csit jobs, but maybe it's a good topic to figure out at the DDF in two weeks. (jamoluhrsen, 16:45:46)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=9165 <-- Log when SCC is ready. (vrpolak, 16:47:46)
    5. SCC -> CSS == Config SubSystem (vrpolak, 16:58:38)
    6. https://docs.google.com/spreadsheets/d/1Mk7TxCj2ZqBGG0EK6Cg153j8Ors2eQck3OOuaKprfm0 (mattw4, 20:32:24)


Meeting ended at 22:41:35 UTC (full logs).

Action items

  1. seems the problem with next is npm (i.e., node) related. but it seems that next is not responding yet and we've reached out to dlux to see if they can help.
  2. zxiiro to draft email to TSC with options for dealing with next
  3. jamoluhrsen to do a blocker bug query and update spreadsheet
  4. vrpolak to remind rovarga to send official email about mdsal being in release
  5. jamoluhrsen to track down snmp folks to see if they want to be in oxy
  6. LuisGomez to double check with colin about ttp
  7. jamoluhrsen to send the email to tell projects that if they have gone two releases marking their CSIT jobs as IGNORE, we will remove their jobs
  8. jamoluhrsen to reply on that release plan thread to see if we want to vote via email or wait until next TSC.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to do a blocker bug query and update spreadsheet
    2. jamoluhrsen to track down snmp folks to see if they want to be in oxy
    3. jamoluhrsen to send the email to tell projects that if they have gone two releases marking their CSIT jobs as IGNORE, we will remove their jobs
    4. jamoluhrsen to reply on that release plan thread to see if we want to vote via email or wait until next TSC.
  2. vrpolak
    1. vrpolak to remind rovarga to send official email about mdsal being in release
  3. zxiiro
    1. zxiiro to draft email to TSC with options for dealing with next
  4. UNASSIGNED
    1. seems the problem with next is npm (i.e., node) related. but it seems that next is not responding yet and we've reached out to dlux to see if they can help.
    2. LuisGomez to double check with colin about ttp


People present (lines said)

  1. jamoluhrsen (40)
  2. odp-gerritbot (6)
  3. vrpolak (3)
  4. odl_meetbot (3)
  5. mattw4 (3)
  6. zxiiro (2)
  7. klou (1)


Generated by MeetBot 0.1.4.