#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:15 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 16:04:17)
    1. the sandbox deploy job is ready with just adding a gerrit comment to a releng/builder patch (jamoluhrsen, 16:05:01)
    2. https://lists.opendaylight.org/pipermail/integration-dev/2017-October/010317.html JJB Sandbox Deployment job (zxiiro, 16:05:40)
    3. the gerrit keyword would be "jjb-deploy <job name>" and wildcards can be used to deploy multiple jobs (jamoluhrsen, 16:05:46)

  2. packaging (jamoluhrsen, 16:06:06)
    1. testing work happening in packaging... (jamoluhrsen, 16:06:50)
    2. work to get our packaging process building in a mock environment (jamoluhrsen, 16:07:24)
    3. deb logic still broken, but making slow progress towards a fix (jamoluhrsen, 16:07:46)
    4. the opnfv folks do want to use the .deb package (jamoluhrsen, 16:08:16)

  3. distribution (jamoluhrsen, 16:08:37)
    1. autorel builds are failing on nitro and oxy, but fix is in mdsal and needs to be fixed. (jamoluhrsen, 16:09:23)
    2. odlparent 2.0.5 with karaf 4.0.10 behaves better with heap space usage, but still some problems with OOM (e.g., gbp hits this) (jamoluhrsen, 16:12:00)
    3. patch in progress so we can archive a compressed heap dump to store in nexus for devs to debug with (jamoluhrsen, 16:12:21)
    4. we need a better process (maybe weather report) when version bumps are expected to be done (jamoluhrsen, 16:14:09)
    5. boron jobs are gone, but with it we lost our csit-1node-library job since it was still using boron (jamoluhrsen, 16:14:46)
    6. https://git.opendaylight.org/gerrit/#/c/63939/ <<--- small refactor happening in int/dist which is moving certain projects (jamoluhrsen, 16:17:38)

  4. release (jamoluhrsen, 16:17:47)
    1. carbon SR2 still waiting on 9145 to be cherry picked to carbon (jamoluhrsen, 16:18:41)
    2. LuisGomez thinks the patch is ok. (jamoluhrsen, 16:19:39)
    3. ACTION: LuisGomez to update the bug with his thoughts on the patch (jamoluhrsen, 16:19:58)
    4. LuisGomez knows of a regression in carbon related to the cbench CSIT and has a fix in nitrogen but it needs a patch in carbon (jamoluhrsen, 16:21:25)
    5. carbon autorelease is only running weekly now so we need to manually trigger it when we are close to an SR (jamoluhrsen, 16:26:03)
    6. nitrogen SR1 is supposed to be in 2 days, but that is so soon due to the nitrogen delay. when should we release? we'll ask the TSC. (jamoluhrsen, 16:27:57)
    7. version bump patches still needed as we are still failing autorelease (jamoluhrsen, 16:28:54)
    8. oxygen release plan should be approved today, but still waiting for mdsal M0 status (jamoluhrsen, 16:29:30)
    9. cardinal and ttp are the only other projects that haven't responded and we expect them to drop out of oxygen (jamoluhrsen, 16:30:01)

  5. misc (jamoluhrsen, 16:32:24)
    1. the -all- jobs were not actually installing all features for karaf4. that was fixed only this past week. keep your eyes open for anything odd (jamoluhrsen, 16:32:26)
    2. jamoluhrsen notes that all of our project test requirements as they are stated on the wiki are really not adhered to. (jamoluhrsen, 16:32:56)
    3. we need to revisit what we expect from projects so we can reasonably hold them to it. (jamoluhrsen, 16:33:31)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#Nitrogen_Project_Integration_and_Test_Requirements (vrpolak, 16:35:10)
    5. we can sit for an hour or so at the DDF next week to discuss this more in depth (jamoluhrsen, 16:35:38)
    6. decanter is not working in karaf4 distributions (jamoluhrsen, 16:36:29)
    7. ACTION: jamoluhrsen to file a bug against int/dist that decanter does not work in our karaf4 distros (so nitrogen and beyond) (jamoluhrsen, 16:37:27)
    8. https://imgur.com/a/KqZIM <--- project dependencies graph (jamoluhrsen, 16:40:12)
    9. the claim was that offset1 projects were depending on offset2 but we don't really see it. (jamoluhrsen, 16:41:42)
    10. https://logs.opendaylight.org/releng/jenkins092/autorelease-release-nitrogen/221/dependencies.log.gz <--- autorel dependency log (jamoluhrsen, 16:43:10)
    11. ACTION: jamoluhrsen to look in to removing federation from the netvirt pom files (jamoluhrsen, 16:43:52)


Meeting ended at 16:46:01 UTC (full logs).

Action items

  1. LuisGomez to update the bug with his thoughts on the patch
  2. jamoluhrsen to file a bug against int/dist that decanter does not work in our karaf4 distros (so nitrogen and beyond)
  3. jamoluhrsen to look in to removing federation from the netvirt pom files


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to file a bug against int/dist that decanter does not work in our karaf4 distros (so nitrogen and beyond)
    2. jamoluhrsen to look in to removing federation from the netvirt pom files


People present (lines said)

  1. jamoluhrsen (40)
  2. odl_meetbot (4)
  3. vrpolak (1)
  4. zxiiro (1)


Generated by MeetBot 0.1.4.