#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:00:15 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:03:42)
    1. infrautils-ready feature now part of dist and compatible-with-all (jamoluhrsen, 16:04:05)
    2. integration failed autorelease job and seems to be related to two incompatible netconf features. (jamoluhrsen, 16:04:23)
    3. work in progress to make new feature buckets 3node-compatible and 1node-compatible : https://git.opendaylight.org/gerrit/#/c/64410/ (jamoluhrsen, 16:05:13)
    4. with the new features split, there are now some failures with the integration-all jobs so maybe this is adding even more bundles to resolve which is probably running us in to heap space issues again (jamoluhrsen, 16:07:09)
    5. vratko points out that some projects (e.g. int/dist) that are still using config subsystem (jamoluhrsen, 16:14:22)
    6. ACTION: LuisGomez to reply to following email about a custom distribution : https://lists.opendaylight.org/pipermail/integration-dev/2017-October/010399.html (jamoluhrsen, 16:18:15)

  2. packaging (jamoluhrsen, 16:20:01)
    1. working on patches to get new release packaging polished up as well as new test jobs (jamoluhrsen, 16:20:55)
    2. https://git.opendaylight.org/gerrit/#/c/63360/ (dfarrell07, 16:21:19)
    3. https://git.opendaylight.org/gerrit/#/c/63360/ : someone needs to review (jamoluhrsen, 16:21:52)

  3. release (jamoluhrsen, 16:21:59)
    1. carbon sr2 is released (jamoluhrsen, 16:22:13)
    2. nitro sr1 finally has a good autorelease (two in a row) but there are two blocker bugs (9163 9007) (jamoluhrsen, 16:22:32)
    3. target sr1 release for 10/26 (jamoluhrsen, 16:22:51)
    4. 9007 is being worked by vishnoianil and he will fix by EOD (jamoluhrsen, 16:24:27)
    5. ACTION: jamoluhrsen to put a comment on jira controller-1770 to ask for a patch for that blocker bug, they claim to have one (jamoluhrsen, 16:25:03)
    6. oxygen autorelease is good now too, m1 status is being collected (jamoluhrsen, 16:25:29)
    7. there is a TWS this coming monday (10/23) to talk about the new release ideas (e.g. core distribution and removing offset-2 projects, etc) (jamoluhrsen, 16:27:42)

  4. builder (jamoluhrsen, 16:31:40)
    1. there is a new job to verify a patch that has dependent patches (jamoluhrsen, 16:32:17)
    2. https://lists.opendaylight.org/pipermail/dev/2017-October/004164.html <--- email describing new job to verify a patch w/ dependent patches (jamoluhrsen, 16:33:05)

  5. misc (jamoluhrsen, 16:34:14)
    1. we can start migrating our trello cards to jira (jamoluhrsen, 16:35:12)
    2. ACTION: jamoluhrsen to create a "migrated to jira" column in trello and as we migrate we can move cards to that new column. (jamoluhrsen, 16:36:04)
    3. we need to wait for trello migration until we get the new 3 jira projects INT/TEST, INT/PAK, INT/DIST (jamoluhrsen, 16:36:37)

  6. clustering (jamoluhrsen, 16:36:46)
    1. netconf-454 issue being looked at and the key issue seems to be EOS is creating two owners for the same entity when you isolate one node (jamoluhrsen, 16:37:38)


Meeting ended at 16:46:49 UTC (full logs).

Action items

  1. LuisGomez to reply to following email about a custom distribution : https://lists.opendaylight.org/pipermail/integration-dev/2017-October/010399.html
  2. jamoluhrsen to put a comment on jira controller-1770 to ask for a patch for that blocker bug, they claim to have one
  3. jamoluhrsen to create a "migrated to jira" column in trello and as we migrate we can move cards to that new column.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to put a comment on jira controller-1770 to ask for a patch for that blocker bug, they claim to have one
    2. jamoluhrsen to create a "migrated to jira" column in trello and as we migrate we can move cards to that new column.


People present (lines said)

  1. jamoluhrsen (29)
  2. odl_meetbot (3)
  3. dfarrell07 (2)
  4. odp-gerritbot (1)


Generated by MeetBot 0.1.4.