#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:00 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:04:31)
    1. autorel problem is solved by rolling back the builder vm image (jamoluhrsen, 16:04:56)
    2. one blocking bug left (openflow 930) and should be done this week. (jamoluhrsen, 16:07:32)
    3. nitro sr1 candidate should be out shortly after fix for openflow 930 (jamoluhrsen, 16:07:52)
    4. likely we can vote next thursday for nitro sr1 release. (jamoluhrsen, 16:08:11)
    5. controller bug 9163 (BZ) (from tencent) was downgraded from blocker (jamoluhrsen, 16:09:27)
    6. carbon sr3 is coming in 2 weeks (jamoluhrsen, 16:17:31)
    7. but, since sr2 only came out 10 days ago, maybe it's worth postponing or skipping (jamoluhrsen, 16:17:54)
    8. oxygen is collecting m1 milestone readouts from projects (half are in) (jamoluhrsen, 16:18:51)
    9. m1 milestone readouts http://docs.opendaylight.org/en/latest/release-process/milestone-readouts.html#m1-final-release-plan (zxiiro, 16:19:07)
    10. https://docs.google.com/spreadsheets/d/1eZUHn6iCDUiwvYpqnH3vnaOTWPlYwh4l1wRF-DUqM3M/edit#gid=2147345344 (anipbu, 16:19:45)
    11. anipbu brings up idea that we might not want to keep update the tracking spreadsheet (jamoluhrsen, 16:20:59)
    12. http://docs.opendaylight.org/en/latest/release-process/milestone-readouts.html <- milestone readout (klou, 16:22:47)
    13. klou argues that we are requiring the data that would populate the tracking spreadsheet via .rst gerrits for milestone repors (jamoluhrsen, 16:24:02)
    14. vrpolak points out that if we have a required structure/format for the .rst reports we can add automation to generate the matrix we would get from the spreadsheet (jamoluhrsen, 16:24:40)

  2. packaging (jamoluhrsen, 16:31:08)
    1. downstream asking for an enhancement to make packaging more generic. (jamoluhrsen, 16:31:37)

  3. distribution (jamoluhrsen, 16:33:44)
    1. distro-check has been unstable this week (OOM problem and two incompatible netconf features) (jamoluhrsen, 16:35:32)
    2. vratko's patch with 1node vs 3node compatible feature lists may be a good fix (jamoluhrsen, 16:36:54)
    3. https://git.opendaylight.org/gerrit/#/c/64410/ <-- master branch for 1node vs 3node compatible features (jamoluhrsen, 16:38:02)
    4. LuisGomez does not think we need to do all these workarounds for 1node vs 3node incompatible features, but vrpolak points out that this could happen with other features down the road so adding more features later will be easier (jamoluhrsen, 16:39:18)
    5. bug 9189 (features pulling bundles when they shouldn't) is being worked on, and vrpolak has some changes 63331 63348 that are ready (jamoluhrsen, 16:48:51)
    6. ACTION: jamoluhrsen to look at 63331 and 63348 (jamoluhrsen, 16:49:03)

  4. clustering (jamoluhrsen, 16:49:16)
    1. bug 8999 (netconf-454) has a workaround, but it's not good enough yet. Possibly the bug won't get fixed, and might need some changes from upstream. (jamoluhrsen, 16:50:46)
    2. prefix base shard registration still not working in isolation scenario (jamoluhrsen, 16:53:09)

  5. builder (jamoluhrsen, 16:54:51)
    1. our rackspace stack timeout is now 15m, with 2 retries (30m total). was 10m with 3 retries (jamoluhrsen, 16:55:27)
    2. rackspace has not gotten back to us on why things are slower, but we are moving to a new provider in Jan. (jamoluhrsen, 16:56:34)

  6. misc (jamoluhrsen, 16:57:52)
    1. vrpolak on pto all next week (jamoluhrsen, 16:58:04)
    2. zxiiro is gone 11/10 - 11/26 (jamoluhrsen, 16:58:23)


Meeting ended at 16:58:46 UTC (full logs).

Action items

  1. jamoluhrsen to look at 63331 and 63348


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to look at 63331 and 63348


People present (lines said)

  1. jamoluhrsen (33)
  2. zxiiro (5)
  3. klou (3)
  4. odl_meetbot (3)
  5. anipbu (2)
  6. odp-gerritbot (1)


Generated by MeetBot 0.1.4.