#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:06:32 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:07:20)
    1. the patches that divided features in to 3node compatible vs 1node compatible had some troubles, so LuisGomez had to revert them. Will wait for Vratko to return from PTO to figure it out. (jamoluhrsen, 16:08:32)
    2. monday's TWS about how to deliver the distribution going forward. please attend if interested (jamoluhrsen, 16:13:04)
    3. https://docs.google.com/presentation/d/18BF5I4WIGgYXr1-oPAyxgtPKFtkKnDz77c05cYLBllY/edit?usp=sharing <-- slide deck to use to drive conversation at the TWS for how we are going to change how we do a distribution (jamoluhrsen, 16:13:29)

  2. packaging (jamoluhrsen, 16:14:05)
    1. just minor things happening. (jamoluhrsen, 16:14:22)
    2. moving to jira is a big issue right now. workflow has changed for int/pak. (jamoluhrsen, 16:14:53)
    3. Docs Kanban https://jira.opendaylight.org/secure/RapidBoard.jspa?rapidView=43&view=detail (zxiiro, 16:16:46)
    4. kanban filter: (resolution = EMPTY OR resolution != EMPTY AND resolutiondate < 30) AND project = DOCS ORDER BY Rank ASC (zxiiro, 16:17:59)
    5. ACTION: dfarrell07 to bring the jira issues to TSC today and maybe we can talk about it on a TWS upcoming (jamoluhrsen, 16:29:02)

  3. builder (jamoluhrsen, 16:34:16)
    1. javadocs recently had some issues, but fix came in just today. (jamoluhrsen, 16:34:50)
    2. https://nexus.opendaylight.org/content/repositories/javadoc/ <--- Link to where to find produced javadocs (anipbu, 16:36:13)
    3. javadocs should be implemented on more projects. (jamoluhrsen, 16:36:15)
    4. javadoc repo https://nexus.opendaylight.org/content/repositories/javadoc/ (zxiiro, 16:36:25)
    5. Remove maven site config https://git.opendaylight.org/gerrit/#/q/topic:remove-maven-site (zxiiro, 16:37:27)
    6. Migrating Maven jobs to global-jjb https://git.opendaylight.org/gerrit/#/q/topic:migrate-maven-jobs (zxiiro, 16:38:47)
    7. close to closing out the maven-merge job migration to global-jjb, found a way to upload to Nexus post build using cURL (zxiiro, 16:39:27)
    8. Work being logged in https://jira.linuxfoundation.org/browse/RELENG-61 (zxiiro, 16:40:40)
    9. still no real updates from RackSpace... (jamoluhrsen, 16:43:00)
    10. our cloud migration means we are off of RackSpace by end of December and we are moving to vexxhost (jamoluhrsen, 16:44:15)
    11. autorel vm issues are now fixed with a newer updated image and we'll make that live after nitrogen SR1 is released (jamoluhrsen, 16:45:36)

  4. release (jamoluhrsen, 16:45:54)
    1. carbon sr3 discussion in TSC, supposed to be 11/9 which is only a week from now (jamoluhrsen, 16:46:21)
    2. nitrogen sr1 candidate is out and we need teams to review CSIT issues. (jamoluhrsen, 16:46:39)
    3. nitrogen SR1: https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=546991363 (klou, 16:46:40)
    4. https://jenkins.opendaylight.org/releng/view/CSIT-3node/job/controller-csit-3node-clustering-all-nitrogen/ (LuisGomez, 16:47:44)
    5. ACTION: LuisGomez to file a bug for the controller issue and mark it blocking (jamoluhrsen, 16:49:00)
    6. https://logs.opendaylight.org/sandbox/jenkins091/netvirt-csit-1node-openstack-pike-jamo-upstream-stateful-snat-conntrack-oxygen/18/odl_1/dmesg.log.gz (jamoluhrsen, 16:51:37)
    7. ACTION: jamoluhrsen to file blocker bug on netvirt side (jamoluhrsen, 16:54:24)
    8. oxy m2 milestone coming up (jamoluhrsen, 16:54:30)
    9. Summary table of m0 info: http://docs.opendaylight.org/en/latest/release-process/milestone-readouts/status/m0.html (klou, 16:55:19)
    10. props to zxiiro for giving us a working example of automating the tracking matrix ideas. (jamoluhrsen, 16:57:29)
    11. https://github.com/opendaylight/docs/blob/master/docs/generate-milestone-status.sh (zxiiro, 16:57:37)


Meeting ended at 16:59:13 UTC (full logs).

Action items

  1. dfarrell07 to bring the jira issues to TSC today and maybe we can talk about it on a TWS upcoming
  2. LuisGomez to file a bug for the controller issue and mark it blocking
  3. jamoluhrsen to file blocker bug on netvirt side


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to file blocker bug on netvirt side
  2. LuisGomez
    1. LuisGomez to file a bug for the controller issue and mark it blocking


People present (lines said)

  1. jamoluhrsen (26)
  2. zxiiro (9)
  3. odl_meetbot (3)
  4. klou (2)
  5. LuisGomez (1)
  6. anipbu (1)


Generated by MeetBot 0.1.4.