#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:24 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 17:04:55)
    1. migrated packer to common-packer + ansible (zxiiro, 17:05:02)
    2. need to migrate the remaining packer jobs to ansible (zxiiro, 17:05:03)
    3. Packer Ansible provisioner https://jenkins.opendaylight.org/releng/view/packer/job/builder-packer-merge-centos-builder/5/console (zxiiro, 17:05:03)
    4. all LF projects should be using this new packer ansible work, so all CI systems should be the same. (jamoluhrsen, 17:06:00)
    5. seems the quagga build stuff is taking the longest (jamoluhrsen, 17:07:32)
    6. we still need to figure out which packer images we still need to keep and which to remove. We've already removed the generic mininet image, but do we need to keep mininet2.x and 2.y? can we just use 2.8? (jamoluhrsen, 17:09:31)
    7. we have a lot of devstack images. which do we need? (jamoluhrsen, 17:09:44)
    8. ACTION: venkat to get rid of the newton devstack image (jamoluhrsen, 17:10:41)
    9. ACTION: jamoluhrsen to get rid of the generic devstack image (jamoluhrsen, 17:10:50)
    10. there are new system flavors that should match more like what we had in RS. (jamoluhrsen, 17:14:51)
    11. the flavor v2-standard-# is the same as the performance nodes. (jamoluhrsen, 17:16:20)
    12. the flavor v2-highcpu-# is probably what we want to use going forward, but jamoluhrsen found troubles using them in the netvirt CSIT jobs (jamoluhrsen, 17:16:51)
    13. jamoluhrsen sees that netvirt devtstack is failing with network issues using the new highcpu flavors (jamoluhrsen, 17:21:18)

  2. release (jamoluhrsen, 17:23:51)
    1. carbon SR3 still waiting on blocker bug in netvirt (jamoluhrsen, 17:24:37)
    2. nitrogen next release SR2 is in Feb (jamoluhrsen, 17:24:56)
    3. oxygen in M4 now, but still need m2 and m3 status from a lot of different projects. (jamoluhrsen, 17:25:20)

  3. distribution (jamoluhrsen, 17:25:54)
    1. yangtools and odlparent migration happening, so we might have to remove projects from distribution to make this work. (jamoluhrsen, 17:26:38)

  4. packaging (jamoluhrsen, 17:31:07)
    1. still fixing things that broke over the holiday break. (jamoluhrsen, 17:31:27)
    2. lots more puppet work coming in. (jamoluhrsen, 17:31:37)
    3. dfarrell07 still seeing some *maybe* network issue in a packaging job related to some ssl/container/etc (jamoluhrsen, 17:33:05)
    4. zxiiro wonders if this packaging problem might be related to an SFC CSIT issue that we see (jamoluhrsen, 17:33:28)
    5. hopefully we can get some better support for .deb packaging work this year, but dfarrell07 can't honestly spend enough good time on it. If we can't get help, we might want to stop *trying* to support it. (jamoluhrsen, 17:34:29)


Meeting ended at 17:38:35 UTC (full logs).

Action items

  1. venkat to get rid of the newton devstack image
  2. jamoluhrsen to get rid of the generic devstack image


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to get rid of the generic devstack image


People present (lines said)

  1. jamoluhrsen (26)
  2. odl_meetbot (3)
  3. zxiiro (3)
  4. odp-gerritbot (2)


Generated by MeetBot 0.1.4.