#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:04:18 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 17:04:46)
    1. waiting on netvirt to report status of carbon SR3 to see if we can release (jamoluhrsen, 17:05:02)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/523/ <- Latest Carbon Build (klou_, 17:06:31)
    3. idea is to make sure netvirt csit is ok with the SR3 candidate and if so, we can go vet the rest of csit (jamoluhrsen, 17:07:04)
    4. CSIT triggered by 523: https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-carbon/ (klou_, 17:07:55)
    5. http://cbs.centos.org/repos/nfv7-opendaylight-6-testing/x86_64/os/Packages/opendaylight-6.3.0-0.1.20180117rel2079.el7.noarch.rpm RPM of Carbon SR3 RC (dfarrell07, 17:08:09)
    6. https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-carbon/314/ <--- distribution-test job from this SR3 candidate (jamoluhrsen, 17:09:11)
    7. oxygen still chasing down m3/m4 status. m2 still pending the dlux folks. hoping robert can jostle them (jamoluhrsen, 17:10:21)
    8. still working through version bumps of yangtools and odlparent (jamoluhrsen, 17:10:49)
    9. we now have to re-patch all the projects of yangtools 2.0.1 now. (jamoluhrsen, 17:12:37)
    10. the version bump for yangtools will fix the topology api that was broken (jamoluhrsen, 17:13:34)
    11. LuisGomez advocates that we use some super privileges to have all projects bumped and merged asap. otherwise this could take us another week. (jamoluhrsen, 17:15:23)
    12. oxygen code freeze is now-ish (offset 2 is this week). probably we should ask for an extension (jamoluhrsen, 17:20:36)
    13. RC0 is 2/7, and maybe we can meet that. (jamoluhrsen, 17:20:48)
    14. nitrogen SR is planned for 2/7 (jamoluhrsen, 17:21:32)
    15. autorelease is failing since the 9th. we are going to need people to look at that somehow, if we want to meet the SR2 date (jamoluhrsen, 17:22:24)

  2. distribution (jamoluhrsen, 17:23:31)
    1. LuisGomez has fixed the multipatch job. It was working for some things, but was not working when version bump patches were involved. (jamoluhrsen, 17:24:12)
    2. the fix for multipatch was done by building projects in order (jamoluhrsen, 17:27:09)
    3. https://git.opendaylight.org/gerrit/c/67275 <-- multipatch job fix patch (jamoluhrsen, 17:27:25)
    4. oxygen distribution was finally building with previous yangtools bump, but now that we have to bump again we might start breaking again (jamoluhrsen, 17:31:37)
    5. no news for distribution on carbon or nitrogen (jamoluhrsen, 17:32:40)

  3. packaging (jamoluhrsen, 17:33:31)
    1. major test improvements this week, and some ansible stuff (jamoluhrsen, 17:33:53)
    2. https://jira.opendaylight.org/browse/INTPAK-104 (dfarrell07, 17:35:58)

  4. builder (jamoluhrsen, 17:36:30)
    1. Andy finished CLM migration to vexxhost, and we are not essentially fully out of rackspace (jamoluhrsen, 17:37:05)
    2. new vm/flavors are now available, and LuisGomez saw the tests working with them (jamoluhrsen, 17:37:45)
    3. main idea is that these new flavors are going to save us money (jamoluhrsen, 17:38:54)
    4. lots of moving stuff in packer ansible world, maybe will move to ansible galaxy (jamoluhrsen, 17:42:35)
    5. there is a test for ansible roles called molecule that should be very useful for verify jobs (jamoluhrsen, 17:44:53)
    6. for projects that need new software and don't know ansible, they can give us a shell script and one of us support folks can create a patch in ansible. This is just to be helpful and get them working faster, but eventually we need to ask projects to give ansible patches (jamoluhrsen, 17:46:50)
    7. rough POC of managing clouds configuration in Jenkins https://gerrit.linuxfoundation.org/infra/8429 (zxiiro, 17:47:07)

  5. misc (jamoluhrsen, 17:49:51)
    1. ACTION: dfarrell07 to send email to the integration group about how to subscribe to stack exchange opendaylight questions (jamoluhrsen, 17:51:30)


Meeting ended at 17:54:37 UTC (full logs).

Action items

  1. dfarrell07 to send email to the integration group about how to subscribe to stack exchange opendaylight questions


Action items, by person

  1. dfarrell07
    1. dfarrell07 to send email to the integration group about how to subscribe to stack exchange opendaylight questions


People present (lines said)

  1. jamoluhrsen (35)
  2. odl_meetbot (4)
  3. dfarrell07 (2)
  4. zxiiro (2)
  5. klou_ (2)
  6. odp-gerritbot (1)


Generated by MeetBot 0.1.4.