#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:05:06 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 17:05:21)
    1. inbound work to give a {prefix} option for CSIT jobs, which will make it a little easier to create unique jobs in the sandbox (jamoluhrsen, 17:06:07)
    2. https://git.opendaylight.org/gerrit/#/q/topic:prefix (zxiiro, 17:06:47)
    3. https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-defaults.yaml#L6 (zxiiro, 17:07:34)
    4. there is a unit test in releng/builder verify jobs that will catch anyone accidentally pushing a non empty prefix (jamoluhrsen, 17:08:29)
    5. new paradigm for docs coming, where each project will keep and publish their own docs (jamoluhrsen, 17:10:10)
    6. docs.opendaylight.org will still be able to link to these sub project docs (jamoluhrsen, 17:10:49)
    7. Example subproject https://lf-releng-docs.readthedocs.io/projects/lftools/en/latest/ (zxiiro, 17:11:12)
    8. we still need to figure out if we can use the highcpu VMs for CSIT jobs (jamoluhrsen, 17:13:01)

  2. release (jamoluhrsen, 17:17:26)
    1. carbon SR3 still blocked on netvirt (jamoluhrsen, 17:17:41)
    2. ACTION: jamoluhrsen to make sure there is a jira issue for the carbon sr3 blocker (jamoluhrsen, 17:19:10)
    3. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007942.html <-- email thread about carbon SR3 blocker issue(s) (jamoluhrsen, 17:20:44)
    4. ACTION: LuisGomez to show jamoluhrsen the patch to change idle timeout (jamoluhrsen, 17:23:28)
    5. nitrogen does not have a good autorelease since jan 9th. we need to figure it out in aprox 2 weeks. (jamoluhrsen, 17:28:20)
    6. ACTION: zxiiro abelur klou_ to send some message(s) about nitrogen autorelease (jamoluhrsen, 17:28:46)
    7. seems nitrogen is failing in random places for nitrogen (jamoluhrsen, 17:29:23)
    8. zxiiro thinks we can build twice a day and try to track each failure by type/project/etc (jamoluhrsen, 17:29:53)
    9. Oxygen is still unstable, and the AAA gson patch was merged so we need to check other projects to see where anything might be broken. (jamoluhrsen, 17:31:35)
    10. ACTION: LuisGomez to check that the distribution job is ok or not after the AAA gson patch came in (jamoluhrsen, 17:33:54)
    11. still chasing m2/m3 status for Oxygen (jamoluhrsen, 17:34:41)
    12. seems that we are still missing quite a few projects to finish their odlparent/yangtools version bump migration (jamoluhrsen, 17:35:38)

  3. packaging (jamoluhrsen, 17:36:50)
    1. just test improvements (jamoluhrsen, 17:37:04)
    2. eventually we can start adding phased testing for packages (jamoluhrsen, 17:37:56)

  4. misc (jamoluhrsen, 17:39:27)
    1. ACTION: LuisGomez to look at this OFP email: https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007923.html (jamoluhrsen, 17:39:35)
    2. we should consider another integration specific meetup some time this year. (jamoluhrsen, 17:42:53)


Meeting ended at 17:43:51 UTC (full logs).

Action items

  1. jamoluhrsen to make sure there is a jira issue for the carbon sr3 blocker
  2. LuisGomez to show jamoluhrsen the patch to change idle timeout
  3. zxiiro abelur klou_ to send some message(s) about nitrogen autorelease
  4. LuisGomez to check that the distribution job is ok or not after the AAA gson patch came in
  5. LuisGomez to look at this OFP email: https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007923.html


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to make sure there is a jira issue for the carbon sr3 blocker
    2. LuisGomez to show jamoluhrsen the patch to change idle timeout
  2. LuisGomez
    1. LuisGomez to show jamoluhrsen the patch to change idle timeout
    2. LuisGomez to check that the distribution job is ok or not after the AAA gson patch came in
    3. LuisGomez to look at this OFP email: https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007923.html
  3. zxiiro
    1. zxiiro abelur klou_ to send some message(s) about nitrogen autorelease


People present (lines said)

  1. jamoluhrsen (29)
  2. odl_meetbot (4)
  3. odp-gerritbot (3)
  4. zxiiro (3)
  5. LuisGomez (1)


Generated by MeetBot 0.1.4.