#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:01:58 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 17:02:44)
    1. deb packaging job is successful (jamoluhrsen, 17:03:26)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/packaging-build-deb-nitrogen/ (mardim, 17:04:48)
    3. ACTION: dfarrell07_pto to figure out/explain when/why the deb packaging jobs are triggered (jamoluhrsen, 17:04:59)
    4. jamoluhrsen has manually triggered both carbon and oxygen deb jobs now (jamoluhrsen, 17:05:11)
    5. zxiiro explains that our packaging jobs are triggered by autorelease (jamoluhrsen, 17:06:22)
    6. https://git.opendaylight.org/gerrit/#/c/68201/ (mbuil, 17:07:11)
    7. look for conditional-step here https://docs.openstack.org/infra/jenkins-job-builder/builders.html (zxiiro, 17:11:17)

  2. release (jamoluhrsen, 17:16:43)
    1. carbon sr3 and nitro sr2 csit results only with a few jobs left to check (jamoluhrsen, 17:24:07)
    2. gvrangan asking if we can get VTN back in to oxygen, but this is now a decision for the TSC (jamoluhrsen, 17:24:23)
    3. oxygen still not getting a good build in autorelease (jamoluhrsen, 17:25:04)
    4. nic, vtn and unimgr are all now out of autorelease after they were removed from int/dist (jamoluhrsen, 17:25:23)
    5. LuisGomez thinks there is a leak in nitrogen, but maybe it's not a regression or blocker (jamoluhrsen, 17:26:21)
    6. ACTION: LuisGomez to dig up or create the jira for this openflowplugin leak (dealing with groups) and point out the patch that fixed this in carbon. This is still not fixed in nitrogen and probably could be there in oxygen (jamoluhrsen, 17:29:15)
    7. even if we get a good oxygen autorelease, we may want to wait until next week to do the branch cutting and locking since we hope to release carbon and nitrogen in the next few days (jamoluhrsen, 17:32:38)

  3. distribution (jamoluhrsen, 17:33:50)
    1. new patch to update karaf maven plugin which reduces the time to build (jamoluhrsen, 17:34:13)
    2. https://git.opendaylight.org/gerrit/c/68100/ <--- Use karaf-maven-plugin 4.1.5 (jamoluhrsen, 17:35:02)
    3. when we upgrade to the new odlparent version, we will revert the int/dist patch because it will come from odlparent itself (jamoluhrsen, 17:35:27)

  4. builder (jamoluhrsen, 17:35:44)
    1. questions around whether we should upgrade our controller VM from 2x8 to 4x4, since LuisGomez thinks we are fine with only 4GB RAM but less cores might be one bottleneck we are hitting from time to time (jamoluhrsen, 17:37:44)
    2. we can test with the new controller size and monitor the controller netconf and bgp jobs to see if there is any improvement (jamoluhrsen, 17:38:28)
    3. zxiiro says the cost difference between 2x8 and 4x4 systems is minimal (jamoluhrsen, 17:39:58)
    4. https://git.opendaylight.org/gerrit/c/68483/ <--- new controller size patch is now merged (jamoluhrsen, 17:41:16)
    5. Moving Packer Ansible roles into Ansible Galaxy and retiring lf-ansible repo (zxiiro, 17:41:35)
    6. lf-ansible migration https://jira.linuxfoundation.org/browse/RELENG-809 (zxiiro, 17:41:35)

  5. misc (jamoluhrsen, 17:43:47)
    1. ACTION: gvrangan to put his image shell script as a patch so that zxiiro can look at it and help break it out in to smaller ansible steps for that role (jamoluhrsen, 17:45:44)
    2. ACTION: LuisGomez to email the TSC about the new committers that have been voted on for int/dist (to align autorelease and int/dist committers) (jamoluhrsen, 17:47:34)


Meeting ended at 17:49:20 UTC (full logs).

Action items

  1. dfarrell07_pto to figure out/explain when/why the deb packaging jobs are triggered
  2. LuisGomez to dig up or create the jira for this openflowplugin leak (dealing with groups) and point out the patch that fixed this in carbon. This is still not fixed in nitrogen and probably could be there in oxygen
  3. gvrangan to put his image shell script as a patch so that zxiiro can look at it and help break it out in to smaller ansible steps for that role
  4. LuisGomez to email the TSC about the new committers that have been voted on for int/dist (to align autorelease and int/dist committers)


Action items, by person

  1. zxiiro
    1. gvrangan to put his image shell script as a patch so that zxiiro can look at it and help break it out in to smaller ansible steps for that role
  2. UNASSIGNED
    1. dfarrell07_pto to figure out/explain when/why the deb packaging jobs are triggered
    2. LuisGomez to dig up or create the jira for this openflowplugin leak (dealing with groups) and point out the patch that fixed this in carbon. This is still not fixed in nitrogen and probably could be there in oxygen
    3. LuisGomez to email the TSC about the new committers that have been voted on for int/dist (to align autorelease and int/dist committers)


People present (lines said)

  1. jamoluhrsen (27)
  2. zxiiro (4)
  3. odp-gerritbot (3)
  4. odl_meetbot (3)
  5. mbuil (2)
  6. mardim (1)


Generated by MeetBot 0.1.4.