#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:30 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 17:04:24)
    1. debian jobs seem to be ok. (jamoluhrsen, 17:05:05)
    2. https://nexus.opendaylight.org/content/repositories/opendaylight-oxygen-ubuntu-1604-x86_64-devel/ (dfarrell07, 17:06:18)
    3. https://nexus.opendaylight.org/content/repositories/opendaylight-oxygen-ubuntu-1604-x86_64-devel/org/opendaylight/integration-packaging/opendaylight/ (dfarrell07, 17:06:39)
    4. https://nexus.opendaylight.org/content/repositories/opendaylight-oxygen-ubuntu-1604-x86_64-devel/org/opendaylight/integration-packaging/opendaylight/8.0.0-0.1.20180301rel2103/ <-- finally pushing .deb packages to nexus (jamoluhrsen, 17:07:09)
    5. WOOHOO! (jamoluhrsen, 17:07:13)
    6. next step for .deb packaging would be to add the steps to run the tests. (jamoluhrsen, 17:09:09)
    7. https://jira.opendaylight.org/browse/INTPAK-138 (dfarrell07, 17:11:54)
    8. https://jira.opendaylight.org/browse/INTPAK-138 (jamoluhrsen, 17:12:21)
    9. ACTION: dfarrell07 to add jira to for adding tests to the deb packaging pipeline (jamoluhrsen, 17:12:39)
    10. new idea is to move all build processes to use docker (jamoluhrsen, 17:13:46)
    11. https://git.opendaylight.org/gerrit/#/c/68861/ (mbuil, 17:14:13)
    12. https://jira.opendaylight.org/browse/INTPAK-144 jira to add tests to deb build job (dfarrell07, 17:14:27)
    13. carbon sr3 and nitro sr2 working their way through the pipeline, but not there yet (jamoluhrsen, 17:17:17)

  2. builder (jamoluhrsen, 17:18:07)
    1. cloud definitions coming https://git.opendaylight.org/gerrit/68907 (zxiiro, 17:18:16)
    2. COE is requesting docker images to be built in infra (jamoluhrsen, 17:21:08)
    3. we want to better understand COE and all it's moving parts. Maybe fkautz can give a talk/explanation on TWS or at DDF. seems really interesting (jamoluhrsen, 17:44:27)

  3. release (jamoluhrsen, 17:49:26)
    1. oxygen needs four projects from CSIT nic, ocpplugin topoprocessing unimgr (jamoluhrsen, 17:49:58)
    2. ACTION: jamoluhrsen to remove unnecessary csit from oxygen (jamoluhrsen, 17:50:29)
    3. when should we do RC2 for oxygen? still have 10+ blockers to get fixed (jamoluhrsen, 17:53:01)
    4. https://jira.opendaylight.org/issues/?filter=10206 <- Oxygen Release Blockers (klou, 17:53:19)
    5. carbon SR4 is supposed to be in two weeks. we need to push it out, but once we do release SR4, we can be done with Carbon for good !!!! (jamoluhrsen, 17:58:58)
    6. ACTION: jamoluhrsen to make nitrogen CSIT run weekly, since we are now dealing with four releases at once (carbon, nitrogen, oxygen, flourine) (jamoluhrsen, 18:00:55)


Meeting ended at 18:01:21 UTC (full logs).

Action items

  1. dfarrell07 to add jira to for adding tests to the deb packaging pipeline
  2. jamoluhrsen to remove unnecessary csit from oxygen
  3. jamoluhrsen to make nitrogen CSIT run weekly, since we are now dealing with four releases at once (carbon, nitrogen, oxygen, flourine)


Action items, by person

  1. dfarrell07
    1. dfarrell07 to add jira to for adding tests to the deb packaging pipeline
  2. jamoluhrsen
    1. jamoluhrsen to remove unnecessary csit from oxygen
    2. jamoluhrsen to make nitrogen CSIT run weekly, since we are now dealing with four releases at once (carbon, nitrogen, oxygen, flourine)


People present (lines said)

  1. jamoluhrsen (22)
  2. dfarrell07 (4)
  3. faseela (4)
  4. zxiiro (4)
  5. odl_meetbot (3)
  6. klou (1)
  7. mbuil (1)


Generated by MeetBot 0.1.4.