#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:51 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:03:40)
    1. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=978062368 <- oxygen tracking sheet (klou, 16:03:59)
    2. hoping to get a few more projects to submit there final release notes jira (aaa, odlparent, controller, jsonrpc, l2switch). (jamoluhrsen, 16:08:51)
    3. ACTION: LuisGomez to reach out to evan (jamoluhrsen, 16:09:06)
    4. ACTION: jamoluhrsen to reach out to ryan tom anton and skitt (jamoluhrsen, 16:09:25)
    5. https://git.opendaylight.org/gerrit/gitweb?p=docs.git;a=tree;f=docs/release-process/milestone-readouts/mf;h=d9a8354026d9684a420975090e0faf20135b344f;hb=refs/heads/master MF submissions (dfarrell07, 16:09:58)
    6. https://git.opendaylight.org/gerrit/#/c/69515/ <- sample MF status (klou, 16:10:28)
    7. https://wiki.opendaylight.org/view/Release_Dashboard (klou, 16:12:25)
    8. some projects (only ALTO for now) are submitting their Fluorine initial checkpoint jira (jamoluhrsen, 16:14:25)
    9. NETVIRT-1062 is last oxy blocker and patches are close to done. (jamoluhrsen, 16:20:02)
    10. we need to push to get final milestone reports, release notes, etc. from oxy projects, but consensus seems to be that we should not block the release on these things not coming in. (jamoluhrsen, 16:22:00)
    11. the other major issue currently blocking oxygen is autorelease failures (jamoluhrsen, 16:22:18)
    12. https://git.opendaylight.org/gerrit/#/c/69529/ <-- patch merged to give more logs for the sft failures. (jamoluhrsen, 16:23:51)
    13. ACTION: dfarrell07 to start another oxygen autorelease (jamoluhrsen, 16:24:05)
    14. ACTION: dfarrell07 to start a new autorelease oxygen once logging patch is done with merge job (jamoluhrsen, 16:32:26)
    15. to start Fluorine, we need to know how to start... (jamoluhrsen, 16:33:28)
    16. we need to get all the leaf projects that we expect to be in the managed release to submit their jira's to declare their intention. (jamoluhrsen, 16:35:54)
    17. projects (leaf) that want to be in the managed release need to fill in one of these: https://jira.opendaylight.org/browse/TSC-2 (jamoluhrsen, 16:37:28)
    18. https://docs.google.com/presentation/d/1wAG_zQ0IkFdh9kZgjKtMbTP-x7jJOvnOgFO5iehebpE slides from MR (dfarrell07, 16:40:28)
    19. projects like netvirt, genius, openflowplugin, ovsdb, bgpcep, lispflowmapping, neutron, sfc, usc, coe need to get this jira to belong in managed release (jamoluhrsen, 16:42:14)
    20. ACTION: dfarrell07 to make it more clear in our documentation that our Initial Checkpoint is the place for projects to also submit their JIRA to move to managed status (jamoluhrsen, 16:46:42)
    21. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/docs-rtd-verify-fluorine/53/html/release-process/managed-release.html#initial-checkpoint initial checkpoint mr (dfarrell07, 16:46:51)

  2. packaging (jamoluhrsen, 16:51:48)
    1. lots of patches to be reviewed. (jamoluhrsen, 16:52:05)

  3. distribution (jamoluhrsen, 16:52:37)
    1. new script running in autorelease to check if there is a mismatch between distribution and autorelease. mismatch in terms of some projects are added in the distribution or autorelease but not in the other. (jamoluhrsen, 16:53:30)
    2. the mismatch script happens up front in validate-autorelease so we can catch these things fast. big thanks to abelur (jamoluhrsen, 16:54:09)

  4. builder (jamoluhrsen, 16:54:25)
    1. Hide tag comments https://git.opendaylight.org/gerrit/#/c/69415/ (zxiiro, 16:54:40)
    2. https://bugs.chromium.org/p/gerrit/issues/detail?id=8537 (zxiiro, 16:55:37)
    3. https://github.com/chaoss/grimoirelab-bestiary (zxiiro, 16:57:49)
    4. https://github.com/chaoss/grimoirelab-hatstall (zxiiro, 16:57:54)
    5. https://git.opendaylight.org/gerrit/#/c/69281/ (mardim_home, 17:00:44)
    6. https://git.opendaylight.org/gerrit/#/c/69376/ (mardim_home, 17:00:45)
    7. https://git.opendaylight.org/gerrit/#/c/69378/ (mardim_home, 17:00:45)
    8. https://git.opendaylight.org/gerrit/#/c/69494/ (mardim_home, 17:00:45)
    9. https://git.opendaylight.org/gerrit/#/c/69531/ (mardim_home, 17:00:45)
    10. ACTION: jamoluhrsen to remind the integration-dev list about DST time change (jamoluhrsen, 17:01:20)


Meeting ended at 17:01:39 UTC (full logs).

Action items

  1. LuisGomez to reach out to evan
  2. jamoluhrsen to reach out to ryan tom anton and skitt
  3. dfarrell07 to start another oxygen autorelease
  4. dfarrell07 to start a new autorelease oxygen once logging patch is done with merge job
  5. dfarrell07 to make it more clear in our documentation that our Initial Checkpoint is the place for projects to also submit their JIRA to move to managed status
  6. jamoluhrsen to remind the integration-dev list about DST time change


Action items, by person

  1. dfarrell07
    1. dfarrell07 to start another oxygen autorelease
    2. dfarrell07 to start a new autorelease oxygen once logging patch is done with merge job
    3. dfarrell07 to make it more clear in our documentation that our Initial Checkpoint is the place for projects to also submit their JIRA to move to managed status
  2. jamoluhrsen
    1. jamoluhrsen to reach out to ryan tom anton and skitt
    2. jamoluhrsen to remind the integration-dev list about DST time change


People present (lines said)

  1. jamoluhrsen (28)
  2. mardim_home (11)
  3. zxiiro (5)
  4. dfarrell07 (4)
  5. odl_meetbot (4)
  6. klou (3)
  7. odp-gerritbot (3)
  8. sathwik (1)


Generated by MeetBot 0.1.4.