#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:23 UTC (full logs).

Meeting summary

    1. https://zoom.us/j/770709266 (jamoluhrsen, 16:05:02)

  1. packaging (jamoluhrsen, 16:08:11)
    1. some debian test job work in progress (jamoluhrsen, 16:08:41)
    2. https://git.opendaylight.org/gerrit/#/c/69424/ large puppet-odl feature about to go in, need review from tim (dfarrell07, 16:10:00)
    3. puppet not setup for fluorine yet. (jamoluhrsen, 16:10:55)
    4. fluorine support for opensuse there, so hopefully XCI testing can happen now (jamoluhrsen, 16:12:25)
    5. found race condition in nitrogen, but the problem is not there in oxygen because we are using genius auto-tunnels. jaime has a fix coming for nitrogren (jamoluhrsen, 16:14:04)

  2. release (jamoluhrsen, 16:15:21)
    1. carbon SR4 is coming in like a week. (jamoluhrsen, 16:16:11)
    2. carbon autorelease has a problem with huge disk issues. but we don't understand why this happened all of a sudden. (jamoluhrsen, 16:17:35)
    3. we need to figure out the root cause of this sudden increase in disk usage, but one easy thing to do is make a profile per-project to let us disable creating the local project karaf distributions (jamoluhrsen, 16:20:13)
    4. ACTION: zxiiro to give an example of how to disable karaf distros and we can load balance that work across all projects (jamoluhrsen, 16:22:40)
    5. Fluorine still has a few projects that need initial checkpoints. (jamoluhrsen, 16:23:23)
    6. Fluorine needs 2-3 more projects to be reviewed for managed release (jamoluhrsen, 16:24:21)
    7. TSDR still wants tobe a managed project, although we did take a TSC vote last week to not allow that. (jamoluhrsen, 16:25:01)
    8. we need to version bump odlparent and yangtools. drop dead timeline is 4/8, which is this weekend so maybe we can do it now. (jamoluhrsen, 16:32:55)
    9. https://zoom.us/j/770709266 (jamoluhrsen, 16:35:03)
    10. ACTION: jamoluhrsen to resurrect the friday release management call to figure out what bits of work still need to be done for this managed release (jamoluhrsen, 16:36:30)
    11. abelur should probably be at this meeting (jamoluhrsen, 16:37:35)
    12. ACTION: jamoluhrsen to figure out how to get abelur at this meeting (jamoluhrsen, 16:37:51)
    13. skitt thinks even though we dont have a good autorelease we should just merge our version bumps (jamoluhrsen, 16:46:14)
    14. oxygen needs their yangtools and odlparent versions bumped (jamoluhrsen, 16:48:13)
    15. ACTION: zxiiro and releng team to merge these patches. (jamoluhrsen, 16:50:24)
    16. https://git.opendaylight.org/gerrit/69996 (skitt, 16:51:09)
    17. good build in the first version bump in the chain: https://git.opendaylight.org/gerrit/69996 (skitt, 16:51:22)
    18. Oxygen patches: https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0-oxygen+(status:open+OR+status:merged) (skitt, 16:51:46)
    19. actually oxygen is first on the 14th, then carbon on the 26th (of April) and then nitrogen on 5/7 (jamoluhrsen, 16:53:39)
    20. Ariel is getting ramped up on the release manager stuff (jamoluhrsen, 16:54:36)

  3. distribution (jamoluhrsen, 16:55:27)
    1. version feature is now removed in Fluorine (jamoluhrsen, 16:55:42)
    2. int/dist in Fluorine is now only using managed projects (jamoluhrsen, 16:55:56)
    3. work in progress to make unmanaged projects part of the distribution by "hidden" <scope>test<scope> (jamoluhrsen, 16:56:22)
    4. https://git.opendaylight.org/gerrit/#/c/70314/ <--- new way to make distro (jamoluhrsen, 16:58:05)

  4. builder (jamoluhrsen, 16:58:16)
    1. JJB update needed now .2.0.3 or highger, and rebase local releng/builder repo. emergency issue came from an upstream tox change (jamoluhrsen, 16:58:56)
    2. zxiiro looking in to automating the integration jobs running after the merge jobs. (jamoluhrsen, 17:00:10)


Meeting ended at 19:01:02 UTC (full logs).

Action items

  1. zxiiro to give an example of how to disable karaf distros and we can load balance that work across all projects
  2. jamoluhrsen to resurrect the friday release management call to figure out what bits of work still need to be done for this managed release
  3. jamoluhrsen to figure out how to get abelur at this meeting
  4. zxiiro and releng team to merge these patches.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to resurrect the friday release management call to figure out what bits of work still need to be done for this managed release
    2. jamoluhrsen to figure out how to get abelur at this meeting
  2. zxiiro
    1. zxiiro to give an example of how to disable karaf distros and we can load balance that work across all projects
    2. zxiiro and releng team to merge these patches.


People present (lines said)

  1. jamoluhrsen (39)
  2. skitt (6)
  3. odl_meetbot (3)
  4. jaicaa (3)
  5. LuisGomez (1)
  6. dfarrell07 (1)
  7. odp-gerritbot (1)
  8. zxiiro (1)
  9. mbuil (1)


Generated by MeetBot 0.1.4.