#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:42 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 16:05:14)
    1. there are still some infra aborts happening because of some openstack troubles where over time some compute nodes are getting disabled and after enough of them get disabled we will fail to bring up our CSIT stacks. (jamoluhrsen, 16:08:40)
    2. tox was downgraded last week, because of a new major release that broke all of our CI. We have to use the older versions for now to keep our tests passing (jamoluhrsen, 16:10:18)
    3. Provide way for projects to self release https://jira.linuxfoundation.org/browse/RELENG-425 (zxiiro, 16:10:37)

  2. release (jamoluhrsen, 16:11:45)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-oxygen/264/console (zxiiro, 16:12:11)

  3. oxygen likely to be delayed (jamoluhrsen, 16:12:13)
    1. jsonrpc was most recent problem in oxy autorelease, but that is fixed. version bumping is done. hoping next autorelease job will pass (jamoluhrsen, 16:13:23)
    2. there is a major problem in oxygen (believed that stops REST from coming up) and the belief is that it's coming from latest odlparent version bump (jamoluhrsen, 16:15:16)
    3. ACTION: LuisGomez to open a block bug for this new problem with REST not coming up (jamoluhrsen, 16:15:36)
    4. Carbon is failing because we removed VTN and NIC depends on VTN (jamoluhrsen, 16:19:58)
    5. VTN really wanted to be out of the releases, but two options are to remove the VTN dependency or add VTN back to Carbon (jamoluhrsen, 16:20:31)
    6. ACTION: LuisGomez to ask NIC PTL to remove VTN dependency (jamoluhrsen, 16:20:51)
    7. this problem of VTN <- NIC is there in nitrogen (jamoluhrsen, 16:21:09)
    8. zxiiro expects that carbon should be ok once we get this vtn/nic thing figured out (jamoluhrsen, 16:21:59)
    9. nitrogen coming soon too, but last failure was in an ovsdb failure (jamoluhrsen, 16:22:54)
    10. LuisGomez found out that nitrogen doesn't have the vtn<-nic dependency (jamoluhrsen, 16:23:22)
    11. Fluorine version bumping still not happening yet. We are behind by a week on this now (jamoluhrsen, 16:23:49)

  4. packaging (jamoluhrsen, 16:24:50)
    1. https://git.opendaylight.org/gerrit/#/c/69378/ #link https://git.opendaylight.org/gerrit/#/c/69494/ #link https://git.opendaylight.org/gerrit/#/c/70823/ #link https://jenkins.opendaylight.org/sandbox/view/packaging/job/packaging-build-deb-nitrogen/11/ (mardim___, 16:25:34)
    2. debian packages in the nexus repository are bad. they are not able to start. seems a missing file (jamoluhrsen, 16:26:23)

  5. distribution (jamoluhrsen, 16:27:40)
    1. lots of cleanup removing unmanaged projects from int/dist (jamoluhrsen, 16:28:03)
    2. new job coming that will build distribution with all the unmanaged projects in a very thin manner. hoping to add some sort of very basic test (jamoluhrsen, 16:28:52)
    3. LuisGomez has the idea that umanaged projects should consume the managed release artifacts from the *previous* release (jamoluhrsen, 16:30:35)
    4. ACTION: LuisGomez to email his proposal for unmanaged projects to consume the previous release from managed projects (jamoluhrsen, 16:31:05)
    5. the version feature is now fully removed from Fluorine. Infrautils has a JIRA feature request to implement the same thing (jamoluhrsen, 16:31:47)

  6. misc (jamoluhrsen, 16:32:11)
    1. ACTION: jamoluhrsen to reduce transaction rate value in controller clustering csit so we can hopefully narrow our focus on the more concrete (non performance) failures in the controller 3node jobs (jamoluhrsen, 16:42:47)
    2. tomasmarkovic notes that bgpcep 3node jobs are also failing a lot and nobody really looks because nobody really is there to fix (jamoluhrsen, 16:50:29)
    3. ACTION: jamoluhrsen to file one JIRA on the hard 500 Exception in controller 3node job and hopefully someone can look at it. (jamoluhrsen, 16:54:46)


Meeting ended at 16:55:19 UTC (full logs).

Action items

  1. LuisGomez to open a block bug for this new problem with REST not coming up
  2. LuisGomez to ask NIC PTL to remove VTN dependency
  3. LuisGomez to email his proposal for unmanaged projects to consume the previous release from managed projects
  4. jamoluhrsen to reduce transaction rate value in controller clustering csit so we can hopefully narrow our focus on the more concrete (non performance) failures in the controller 3node jobs
  5. jamoluhrsen to file one JIRA on the hard 500 Exception in controller 3node job and hopefully someone can look at it.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to reduce transaction rate value in controller clustering csit so we can hopefully narrow our focus on the more concrete (non performance) failures in the controller 3node jobs
    2. jamoluhrsen to file one JIRA on the hard 500 Exception in controller 3node job and hopefully someone can look at it.
  2. LuisGomez
    1. LuisGomez to open a block bug for this new problem with REST not coming up
    2. LuisGomez to ask NIC PTL to remove VTN dependency
    3. LuisGomez to email his proposal for unmanaged projects to consume the previous release from managed projects


People present (lines said)

  1. jamoluhrsen (36)
  2. skitt (6)
  3. zxiiro (5)
  4. odl_meetbot (3)
  5. mardim___ (1)
  6. LuisGomez (1)
  7. odp-gerritbot (1)


Generated by MeetBot 0.1.4.