#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:10 UTC (full logs).

Meeting summary

    1. CaseyLF reporting that vexxhost is down currently, has been for a few hours and zxiiro currently attending to it. (jamoluhrsen, 16:03:15)

  1. release (jamoluhrsen, 16:08:47)
    1. we had an ad-hoc release status meeting yesterday. notes are here: https://meetings.opendaylight.org/opendaylight-meeting/2018/release/opendaylight-meeting-release.2018-04-18-18.02.html (jamoluhrsen, 16:09:03)
    2. jamoluhrsen may have found a blocker in netvirt sfc csit, but with infra issues he cannot debug further (jamoluhrsen, 16:10:52)
    3. distribution test job that we can watch for oxygen RC build: https://jenkins.opendaylight.org/releng/job/integration-distribution-test-oxygen/250/ (jamoluhrsen, 16:12:07)
    4. we should send out a email to get folks testing at least though with the new build. I was going to do that this morning but got tied up with infra issues. I can send it out after if no one gets to it first. (jamoluhrsen, 16:12:25)
    5. wondering if we could also use autorelease job 274 as the RC? (jamoluhrsen, 16:14:22)
    6. build 274 is missing some patches from netvirt/genius (jamoluhrsen, 16:15:16)
    7. carbon has 3 autorelease success in a row (jamoluhrsen, 16:16:00)
    8. two autorelease success in a row for nitrogen (jamoluhrsen, 16:16:29)
    9. fluorine still has no successful autorelease (jamoluhrsen, 16:16:40)
    10. ACTION: abelur to check in with bgpcep about latest fluorine autorelease failure https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine/54/console (jamoluhrsen, 16:19:54)

  2. distribution (jamoluhrsen, 16:22:16)
    1. full distribution is being built, and in nexus already (jamoluhrsen, 16:22:28)
    2. we no longer need the offline distribution job, since we no longer need/use anything external. (jamoluhrsen, 16:23:21)
    3. distribution-deploy will turn in to distribution-sanity and will run daily. For Fluorine and above, it will try to deploy the full distribution. (jamoluhrsen, 16:24:57)
    4. ACTION: LuisGomez will demo this new job next week. (jamoluhrsen, 16:26:12)
    5. https://jenkins.opendaylight.org/releng/view/distribution/job/distribution-merge-fluorine/691/ <-- job that builds Managed and Full (Managed + UnManaged) distributions (jamoluhrsen, 16:28:43)
    6. https://jenkins.opendaylight.org/releng/view/distribution/job/distribution-merge-fluorine/691/org.opendaylight.integration$karaf/ <-- to get Managed distribution (jamoluhrsen, 16:29:00)
    7. https://jenkins.opendaylight.org/releng/view/distribution/job/distribution-merge-fluorine/691/org.opendaylight.integration$opendaylight/ <-- full distribution which will contain unmanaged projects (currently only USC) (jamoluhrsen, 16:29:33)

  3. packaging (jamoluhrsen, 16:30:00)
    1. small improvements this week, and jobs are in decent shape (jamoluhrsen, 16:30:13)

  4. builder (jamoluhrsen, 16:30:24)
    1. https://git.opendaylight.org/gerrit/#/c/71111/4/docs/jenkins.rst (zxiiro, 16:30:37)
    2. https://git.opendaylight.org/gerrit/#/c/71111/4/docs/jenkins.rst <-- odl specific flavors (jamoluhrsen, 16:31:02)
    3. now our instances will get ephemeral volumes instead of cinder volumes. Hoping this resolves our quota issues (jamoluhrsen, 16:31:44)
    4. vexxhost's outage this morning went unnoticed for a while, but it's back up and running. No APIs were returning, so our jenkins was stuck. Jenkins then needed to be cleared out. Things should be back to normal now. (jamoluhrsen, 16:33:13)

  5. misc (jamoluhrsen, 16:40:21)
    1. CaseyLF wants more TWS (jamoluhrsen, 16:40:49)
    2. LuisGomez notes we need to have a TWS to show Unmanaged projects what they need to do. (jamoluhrsen, 16:41:16)


Meeting ended at 16:51:54 UTC (full logs).

Action items

  1. abelur to check in with bgpcep about latest fluorine autorelease failure https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine/54/console
  2. LuisGomez will demo this new job next week.


People present (lines said)

  1. jamoluhrsen (32)
  2. zxiiro (5)
  3. odl_meetbot (3)
  4. odp-gerritbot (3)


Generated by MeetBot 0.1.4.