#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:17 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 16:03:28)
    1. all jobs are blue :) (jamoluhrsen, 16:03:41)
    2. some puppet stuff going on.... (jamoluhrsen, 16:04:13)
    3. puppet stuff/fixing coming from internal Red Hat testing (jamoluhrsen, 16:05:01)
    4. ansible consumption in XCI turning up some bugs and fixes. (jamoluhrsen, 16:05:18)
    5. oxygen SR1 needs to hit the release pipelines (jamoluhrsen, 16:06:01)

  2. release (jamoluhrsen, 16:06:18)
    1. zxiiro and dfarrell07 think we need to have more sync calls with Ariel (jamoluhrsen, 16:07:02)
    2. oxygen SR1 is out. w00t! (jamoluhrsen, 16:07:54)
    3. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117 (zxiiro, 16:08:44)
    4. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117 (zxiiro, 16:08:49)
    5. carbon SR4 was supposed to go out today, so we need all the CSIT results to be vetted (jamoluhrsen, 16:08:54)
    6. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117 <--- Carbon SR4 Pending Sign off from sfc, openflowplugin, ocpplugin, nic, l2switch, controller (anipbu, 16:09:37)
    7. ACTION: dfarrell07 to ask TSC to pre-approve carbon SR4 pending CSIT is vetted (jamoluhrsen, 16:10:35)
    8. ACTION: dfarrell07 to figure out if we need to maintain carbon for security fixes (jamoluhrsen, 16:11:01)
    9. LuisGomez saw a problem with openflowplugin in the latest carbon and only happens in autorelease, not the snapshot distributions. *only* in carbon SR4. Suggests that if nobody complains, we ignore it. maybe we can get a low sev bug. (jamoluhrsen, 16:13:22)
    10. ACTION: LuisGomez to open a low sev bug for the ofp problem (jamoluhrsen, 16:13:56)
    11. https://wiki.opendaylight.org/view/Security:Vulnerability_Management#Security_supported_versions ODL security maintaince docs (dfarrell07, 16:14:42)
    12. jaicaa points out that sfc features has problems installing in carbon sr4 candidate. seems the problem is in genius. (jamoluhrsen, 16:15:04)
    13. ACTION: jaicaa to file a blocker on carbon sr4 and double check carbon sr3 to see if it's also there. (jamoluhrsen, 16:15:58)
    14. "Backporting is only required for previous releases that are still maintained, according to the release engineering current maintenance strategy." so seems like last SR means no more security support (dfarrell07, 16:16:24)
    15. all standalone users of sfc will be affected, but not when consumers are using sfc integrated with openstack (jamoluhrsen, 16:16:26)
    16. nitrogen will be locked in three days (4/29) and there is some successful runs in a row of autorelease. (jamoluhrsen, 16:19:02)
    17. hoping to get nitro out the door next week (jamoluhrsen, 16:19:10)
    18. http://docs.opendaylight.org/en/stable-oxygen/release-process/release-schedule.html (dfarrell07, 16:20:14)
    19. http://docs.opendaylight.org/en/latest/release-process/release-schedule.html <-- release schedule (jamoluhrsen, 16:21:33)
    20. next fluorine date to consider is the date for CSIT to yell about rolling back odlparent and yangtools and we probably don't have a reason to do that. (jamoluhrsen, 16:22:05)
    21. ACTION: jamoluhrsen to go glance at MR projects CSIT for Fluorine to look for anything glaringly wrong (jamoluhrsen, 16:22:40)
    22. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400 <--- Fluorine Tracking Dashboard (anipbu, 16:23:06)

  3. distribution (jamoluhrsen, 16:24:15)
    1. patch is prepared for distro-check for Self Managed projects (jamoluhrsen, 16:24:29)
    2. LuisGomez has had to remove projects from the self managed distribution that are depending on dlux (jamoluhrsen, 16:25:25)

  4. builder (jamoluhrsen, 16:26:08)
    1. volume issues seem to be resolved and CI has been quite stable since the storage change last week. (jamoluhrsen, 16:26:57)
    2. we are very appreciative to have Vexxhost and mnaser as our cloud provider. (jamoluhrsen, 16:28:22)
    3. distro-test job now has it's own jenkins builder so now it has it's own queue with queuesize of 1. (jamoluhrsen, 16:29:19)
    4. distro-test runs a TON of CSIT children jobs so it was really taxing on the jenkins environment when they were running in parallel. (jamoluhrsen, 16:29:45)
    5. robot slaves are now bumped up to 30 from 25 so we have more bandwidth. (jamoluhrsen, 16:30:34)

  5. misc (jamoluhrsen, 16:30:55)
    1. jaicaa reports that the sfc problem is also there in SR3, so it's not a regression. maybe it's been there all along? (jamoluhrsen, 16:31:57)
    2. we are wondering how we can get a job that will give us confidence that many different projects' patches can be passed in such that we can gain confidence that they will all work together and not break autorelease (jamoluhrsen, 16:35:14)
    3. it seems like we really just need a new job that is based off of autorelease. so, for each project with a patch, download that repo, apply the patch, then run autorelease on that. Maybe run first with -Pq and if that passes, run it again. (jamoluhrsen, 16:46:00)
    4. as far as it goes with the upcoming weather items, the plan is to use multipatch job to manually verify the project patches for each weather item. We can run it once and then point out where the first failures are and then ask for the patches from other projects (jamoluhrsen, 16:50:29)
    5. ideally, when all the new jobs and fanciness is done we just have a single topic branch for projects to use and a fully automated autorelease-based job that will run in the background giving status. (jamoluhrsen, 16:52:00)
    6. jaicaa reports that the sfc issue is actually not there in carbon sr2, so it's a regression between sr2 and sr3. (jamoluhrsen, 16:56:09)
    7. bug registered for SFC issue: GENIUS-127 (jaicaa, 16:56:42)


Meeting ended at 16:57:22 UTC (full logs).

Action items

  1. dfarrell07 to ask TSC to pre-approve carbon SR4 pending CSIT is vetted
  2. dfarrell07 to figure out if we need to maintain carbon for security fixes
  3. LuisGomez to open a low sev bug for the ofp problem
  4. jaicaa to file a blocker on carbon sr4 and double check carbon sr3 to see if it's also there.
  5. jamoluhrsen to go glance at MR projects CSIT for Fluorine to look for anything glaringly wrong


Action items, by person

  1. dfarrell07
    1. dfarrell07 to ask TSC to pre-approve carbon SR4 pending CSIT is vetted
    2. dfarrell07 to figure out if we need to maintain carbon for security fixes
  2. jaicaa
    1. jaicaa to file a blocker on carbon sr4 and double check carbon sr3 to see if it's also there.
  3. jamoluhrsen
    1. jamoluhrsen to go glance at MR projects CSIT for Fluorine to look for anything glaringly wrong


People present (lines said)

  1. jamoluhrsen (43)
  2. dfarrell07 (3)
  3. odl_meetbot (3)
  4. zxiiro (2)
  5. odp-gerritbot (2)
  6. anipbu (2)
  7. jaicaa (1)


Generated by MeetBot 0.1.4.