#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:05:53 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 16:05:57)
    1. dfarrell07 gave a keynote at the opendev conference (jamoluhrsen, 16:06:14)
    2. learned a lot of lessons from the openstack folks (jamoluhrsen, 16:06:45)
    3. nothing much happening in the odl packaging world right now. (jamoluhrsen, 16:09:10)

  2. release (jamoluhrsen, 16:09:17)
    1. good progress on the release stats (checkpoints) automation (jamoluhrsen, 16:09:52)
    2. https://git.opendaylight.org/gerrit/#/c/72060/ <-- automation for checkpoints patch (jamoluhrsen, 16:10:32)
    3. we should be ok to do a good midpoint review of managed release projects even if a few steps manually (jamoluhrsen, 16:11:56)
    4. there is some chatter about trying to remove SFT from autorelease (jamoluhrsen, 16:12:23)
    5. LuisGomez is not against removing SFT from autorelease, since we are still running it per project (jamoluhrsen, 16:12:53)
    6. there are a lot of benefits to removing SFT from autorelease (time to build, storage, etc) (jamoluhrsen, 16:15:36)
    7. LuisGomez notes that lispflowmapping might have a stronger dependency on SFT since they have extra tests going on there (jamoluhrsen, 16:16:06)
    8. LuisGomez proposes that we keep the SFT for just the int/dist project (jamoluhrsen, 16:18:17)
    9. https://jira.opendaylight.org/secure/Dashboard.jspa (jamoluhrsen, 16:18:56)
    10. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403# (jamoluhrsen, 16:20:16)
    11. TSC-99 should be done now. (jamoluhrsen, 16:22:15)
    12. TSC-101 starting now (jamoluhrsen, 16:22:23)
    13. the new process we used to do TSC-99 where projects were not broken did work, but it did seem to take longer than if we just broken everyone and got things done asap. Probably a lot of process improvement will happen as we learn to use the new process if projects like that method (jamoluhrsen, 16:24:02)
    14. we didn't really explicitly write in to our new release model that the release team can do patch merges for things like the recent weather item. We can step in if a project is not being responsive. (jamoluhrsen, 16:30:38)

  3. builder (jamoluhrsen, 16:35:54)
    1. we had the idea of creating automation to notify LF admins when infrastructure broke, but maybe it's not worth it: https://jira.opendaylight.org/browse/RELENG-114 (jamoluhrsen, 16:37:50)
    2. ACTION: jamoluhrsen to close the bat signal (jamoluhrsen, 16:40:30)

  4. misc (jamoluhrsen, 16:40:46)
    1. ACTION: jamoluhrsen to email robert to comment on https://git.opendaylight.org/gerrit/#/c/72136/ (jamoluhrsen, 16:41:37)
    2. LuisGomez thinks we may have some stability now that we got the akka upgrade recently (jamoluhrsen, 16:43:45)


Meeting ended at 16:58:40 UTC (full logs).

Action items

  1. jamoluhrsen to close the bat signal
  2. jamoluhrsen to email robert to comment on https://git.opendaylight.org/gerrit/#/c/72136/


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to close the bat signal
    2. jamoluhrsen to email robert to comment on https://git.opendaylight.org/gerrit/#/c/72136/


People present (lines said)

  1. jamoluhrsen (29)
  2. odl_meetbot (3)
  3. dfarrell07 (2)
  4. odp-gerritbot (1)


Generated by MeetBot 0.1.4.