#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:59 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 17:04:39)
    1. ACTION: jamoluhrsen to make sure to close the bat signal jira (jamoluhrsen, 17:05:32)

  2. packaging (jamoluhrsen, 17:06:05)
    1. https://github.com/shague/odltools <-- odltools repo on github (soon to be ODL project) (jamoluhrsen, 17:07:02)
    2. not sure if odltools wants .rpm kind of packaging or pypi (jamoluhrsen, 17:08:06)
    3. puppet opendaylight logging changing happening (jamoluhrsen, 17:08:36)
    4. original idea was to bump the ODL logs to 10G in size with a rollover of 2 (jamoluhrsen, 17:09:50)
    5. zxiiro has seen some defaults in the 250-500MB range. (jamoluhrsen, 17:11:59)
    6. hoping some work soon around building .rpm distros on gerrit patches, which can then be shipped off to 3rd party CI (e.g. opnfv) (jamoluhrsen, 17:13:08)

  3. distribution (jamoluhrsen, 17:15:55)
    1. odlparent pushing version bump patches because of a security issue in guava (jamoluhrsen, 17:16:14)
    2. odlparent 3.1.2 will be merged by releng so should be invisible to projects. 3.1.2 will be run on multipatch to check that it doesn't break other projects (jamoluhrsen, 17:18:04)
    3. we *may* have to bump to 3.2 in odlparent for the guava fix, but maybe not. likely 4.0 in neon (jamoluhrsen, 17:18:33)

  4. release (jamoluhrsen, 17:18:53)
    1. we want to disable SFT in oxy and fluorine except for int/dist (jamoluhrsen, 17:19:17)
    2. https://lists.opendaylight.org/pipermail/integration-dev/2018-May/012033.html <-- email for disabling SFT (jamoluhrsen, 17:20:04)
    3. https://git.opendaylight.org/gerrit/#/c/72168 <-- vorburger's initial (probably not complete) attempt to disable SFT in autorel. (jamoluhrsen, 17:24:09)
    4. vorburger's patch is not skipping ALL of SFT, just the sft.diag. (jamoluhrsen, 17:26:07)
    5. the patch needs -Dskip.karaf.featureTest=true (skitt, 17:26:29)
    6. not quite sure how to keep SFT running just for int/dist yet. one idea is to add an additional builder step to re-run the build on just int/dist without that SFT skip set to true (jamoluhrsen, 17:30:09)
    7. ACTION: LuisGomez to reply via email how we can add the extra tests in int/dist so that when it's built with SFT disabled, we will still get the expected coverage (jamoluhrsen, 17:32:34)
    8. ACTION: jamoluhrsen to update vorburger's patch to fully disable SFT (jamoluhrsen, 17:33:43)
    9. skitt notes that we had a recent breakage in other projects from an mdsal patch, and maybe our multipatch job (fast version) can be added as a verify job to all projects. (jamoluhrsen, 17:37:10)

  5. misc (jamoluhrsen, 17:43:51)
    1. anipbu wonders if self-managed projects can give a .zip for their release delivery (jamoluhrsen, 17:44:23)
    2. anipbu is worried that it is too complicated for self-managed projects to be included in the final distribution release, but LuisGomez is wondering what is missing that makes it so hard. (jamoluhrsen, 17:45:49)
    3. project standalone release process http://docs.opendaylight.org/en/stable-oxygen/release-process/project-release.html (zxiiro, 17:46:20)
    4. https://github.com/opendaylight/releng-builder/blob/master/jjb/odlparent/odlparent.yaml (zxiiro, 17:47:42)
    5. http://docs.opendaylight.org/en/latest/release-process/managed-release.html#added-to-final-distribution-pom <-- our deadline for selfmanaged projects to get in to the final distribution (jamoluhrsen, 17:58:01)
    6. https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=978062368 (anipbu, 17:58:52)
    7. https://jira.opendaylight.org/issues/?filter=10303 (anipbu, 18:00:00)
    8. interesting to learn that we *only* have 3 self-managed projects that are in the fluorine tracking sheet (https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=978062368), but that is only based on jiras here (https://jira.opendaylight.org/browse/TSC-91?filter=10303), however we don't require selfmanaged projects to have given those jiras (jamoluhrsen, 18:01:07)
    9. we will need to revisit this self-managed release process after we do Fluorine and understand the reality of things (jamoluhrsen, 18:02:41)


Meeting ended at 18:09:24 UTC (full logs).

Action items

  1. jamoluhrsen to make sure to close the bat signal jira
  2. LuisGomez to reply via email how we can add the extra tests in int/dist so that when it's built with SFT disabled, we will still get the expected coverage
  3. jamoluhrsen to update vorburger's patch to fully disable SFT


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to make sure to close the bat signal jira
    2. jamoluhrsen to update vorburger's patch to fully disable SFT


People present (lines said)

  1. jamoluhrsen (30)
  2. odl_meetbot (3)
  3. anipbu (2)
  4. zxiiro (2)
  5. skitt (1)


Generated by MeetBot 0.1.4.