#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:08:13 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:11:47)
    1. release plan has been updated for distribution (jamoluhrsen, 17:12:09)
    2. neon distribution will give better verification for project versioning, and maybe automatically update versions (jamoluhrsen, 17:12:36)
    3. seems there is really no work with how we keep or remove managed projects from distribution (jamoluhrsen, 17:16:09)
    4. multipatch is not working for us in Neon for MRI projects because of how some projects are consuming mdsal. (jamoluhrsen, 17:17:12)

  2. builder (jamoluhrsen, 17:18:35)
    1. Sphinx 1.8.0 breaks docs builds, blacklist it from requirements files if you have one. `Sphinx!=1.8.0` (zxiiro, 17:18:37)
    2. If you want to use lftools or openstack in a job, call lf-infra-pre-build as the first item in the job builders and make sure your shell scripts start with `#!/bin/bash -l` (zxiiro, 17:19:29)
    3. If you want to upgrade pip and setuptools this is now handled by lf-infra-pre-build. Make sure your scripts start with `#!/bin/bash -l` and call `python -m pip install` (zxiiro, 17:21:20)
    4. we are still waiting for the source code for the dcgw packages so we can host those rpms in nexus, but we are waiting for phillipe to finish. (jamoluhrsen, 17:24:53)
    5. in order to get things moving, we can tarball the packages to keep on nexus. Then we can pull those tarballs and build each time on the systems under test (jamoluhrsen, 17:25:33)
    6. there is going to be some job that will pull these tar balls, build the rpms and host them in nexus. then our csit jobs will just rpm install in the csit jobs (jamoluhrsen, 17:35:38)
    7. topic docs (jamoluhrsen, 17:36:32)

  3. docs (jamoluhrsen, 17:36:53)
    1. anipbu asking Prateek to focus on project proposal migration. (jamoluhrsen, 17:37:09)
    2. anipbu has a bunch of docs patches he wants abandoned, but does not have permission (jamoluhrsen, 17:37:26)
    3. https://git.opendaylight.org/gerrit/#/c/73202/ (anipbu, 17:39:35)
    4. ACTION: jamoluhrsen to take a look at this again: https://git.opendaylight.org/gerrit/#/c/73202/ (jamoluhrsen, 17:39:55)
    5. we still have projects that are dead and we need to delete their docs (jamoluhrsen, 17:41:12)

  4. demos (jamoluhrsen, 17:45:03)
    1. JJB Config https://docs.releng.linuxfoundation.org/en/latest/jenkins-sandbox.html#push-jobs-via-jjb-cli (zxiiro, 17:45:53)
    2. Reno notes example https://docs.releng.linuxfoundation.org/projects/lftools/en/latest/release-notes.html (zxiiro, 17:50:06)
    3. Reno docs https://docs.openstack.org/reno/latest/ (zxiiro, 17:57:33)
    4. ACTION: jamoluhrsen to setup a doodle to find a better time for this meeting. (jamoluhrsen, 18:03:35)


Meeting ended at 18:03:54 UTC (full logs).

Action items

  1. jamoluhrsen to take a look at this again: https://git.opendaylight.org/gerrit/#/c/73202/
  2. jamoluhrsen to setup a doodle to find a better time for this meeting.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to take a look at this again: https://git.opendaylight.org/gerrit/#/c/73202/
    2. jamoluhrsen to setup a doodle to find a better time for this meeting.


People present (lines said)

  1. jamoluhrsen (23)
  2. zxiiro (10)
  3. odl_meetbot (3)
  4. odp-gerritbot (1)
  5. anipbu (1)


Generated by MeetBot 0.1.4.