#opendaylight-integration: new release model

Meeting started by jamoluhrsen at 17:07:20 UTC (full logs).

Meeting summary

    1. new participation requirement idea that projects must attend some (maybe new) meeting 50% of the time in the last X (maybe 8) weeks of the release (jamoluhrsen, 17:09:30)
    2. meeting attendance requirement is to address the problem where projects completely disappear for an entire release (jamoluhrsen, 17:10:10)
    3. attendance is by a committer (or a proxy) (jamoluhrsen, 17:10:24)
    4. probably it's better to require a committer (no proxy allowed) (jamoluhrsen, 17:11:55)
    5. the problem is still there that a project can still ignore this participation requirement (jamoluhrsen, 17:12:43)
    6. committer assignment can be a solution to projects ignoring the participation requirement. (jamoluhrsen, 17:13:44)
    7. suggestion is that TSC can (with a majority vote) assign a committer to a project that it deems not fulfilling the requiremts (jamoluhrsen, 17:14:20)
    8. if a dependent project were to decide that it did not want to follow these rules/requirements, the suggestion would be that we could fork said project and assign new committers (jamoluhrsen, 17:17:02)
    9. this idea to fork projects would only apply to projects that decide they don't want to be in the SR/Core projects (jamoluhrsen, 17:19:58)
    10. ACTION: anipbu vishnoianil to add new slides with this proposal of tsc assignment of committers and how to trigger a tsc review process (jamoluhrsen, 17:32:59)
    11. ACTION: jamoluhrsen to start email thread to nail down requirements (jamoluhrsen, 18:02:35)


Meeting ended at 18:02:40 UTC (full logs).

Action items

  1. anipbu vishnoianil to add new slides with this proposal of tsc assignment of committers and how to trigger a tsc review process
  2. jamoluhrsen to start email thread to nail down requirements


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to start email thread to nail down requirements


People present (lines said)

  1. jamoluhrsen (17)
  2. odl_meetbot (3)
  3. klou (1)
  4. zxiiro (1)


Generated by MeetBot 0.1.4.