#opendaylight-integration: integration

Meeting started by jamoluhrsen at 03:02:12 UTC (full logs).

Meeting summary

    1. jamoluhrsen is back and able contribute more actively to opendaylight :) (jamoluhrsen, 03:04:10)

  1. builder (jamoluhrsen, 03:05:41)
    1. migrating all images to ansible provisioners, and all mininet and devstack images should be converted (jamoluhrsen, 03:06:33)
    2. we need some testing with our CSIT jobs for the netvirt images before we can use them in production (jamoluhrsen, 03:07:01)
    3. https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013204.html (abelur, 03:08:32)
    4. surefire reports are not being collected. abelur is looking in to those. possibly an update to lftools broke this. (jamoluhrsen, 03:09:09)
    5. https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013209.html (abelur, 03:09:41)

  2. packaging (jamoluhrsen, 03:10:54)
    1. abelur is looking at some packaging issues, but dfarrell07 is still helping out when he can (jamoluhrsen, 03:11:29)
    2. abelur is pushing new releases to CBS repos (jamoluhrsen, 03:12:03)
    3. puppet and ansible repos are in packaging and wondering if we have any downstream users and if we can deprecate and remove the jobs if nobody is using it. (jamoluhrsen, 03:13:02)

  3. distribution (jamoluhrsen, 03:13:35)
    1. distribution is good. no problems lateluy (jamoluhrsen, 03:14:00)
    2. the process for bringing in self-managed projects to the self-managed release has become smooth now. thanks Luis (jamoluhrsen, 03:15:00)

  4. release (jamoluhrsen, 03:15:20)
    1. neon SR1 hoping to be released soon. we have a blue autorelease https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-neon-mvn35-openjdk8/108/ that we can potentially use for this (jamoluhrsen, 03:16:44)
    2. https://jira.opendaylight.org/browse/OPNFLWPLUG-1065 <-- blocker bug without a version (jamoluhrsen, 03:18:59)
    3. ACTION: jamoluhrsen to ask on TSC call tomorrow if we can lock Neon and look to work on SR1 release (jamoluhrsen, 03:20:19)
    4. fluorine SR3 is planned to release soon, but we may try to push it back. discussion on TSC call tomorrow. (jamoluhrsen, 03:21:56)

  5. docs (jamoluhrsen, 03:22:33)
    1. PTL coming from Lumina soon hopefully (jamoluhrsen, 03:23:41)
    2. LF may be hiring someone (maybe part time) to help with docs. (jamoluhrsen, 03:23:58)
    3. we have an intern interest on the mailing list that might help (jamoluhrsen, 03:24:12)
    4. otherwise docs is just in maintenance mode and only real activity is waiting on neon release notes (jamoluhrsen, 03:25:15)

  6. test (jamoluhrsen, 03:25:44)
    1. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon-mvn35-openjdk8/108/dependencies.log.gz (jamoluhrsen, 03:25:57)
    2. https://wiki.opendaylight.org/view/Project_list (LuisGomez, 03:27:01)
    3. https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-neon/240/ (LuisGomez, 03:29:08)
    4. jaya can be an owner for netvirt csit, karthika can own genius (jamoluhrsen, 03:30:51)
    5. jamo can own aaa, netconf, ovsdb (jamoluhrsen, 03:31:19)
    6. LuisGomez can take bgpcep (if not venkat), openflow (jamoluhrsen, 03:31:36)
    7. karthika can try to keep an eye on COE or find someone else (jamoluhrsen, 03:32:35)
    8. LuisGomez and jamoluhrsen can handle the controller project (jamoluhrsen, 03:33:05)
    9. LuisGomez can watch distribution (jamoluhrsen, 03:33:20)
    10. we don't have anyone that can watch/own lisp, but it is stable. (jamoluhrsen, 03:33:48)
    11. jaya can passively watch odltools csit (jamoluhrsen, 03:36:06)
    12. need to know if sfc still matters to anyone (jamoluhrsen, 03:36:41)
    13. LuisGomez can see about getting yangtools to pass. it's failing for the same well known bug for a long time (jamoluhrsen, 03:37:58)
    14. zxiiro suggests we put these owners on a wiki (jamoluhrsen, 03:38:48)
    15. ACTION: jamoluhrsen to convert these ownerships to a wiki page (jamoluhrsen, 03:39:05)
    16. jaya having trouble with the rocky upgrade. (jamoluhrsen, 03:40:10)
    17. abelur has a new devstack image made for rocky that she can test (jamoluhrsen, 03:40:33)
    18. https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013204.html (abelur, 03:40:42)
    19. https://jenkins.opendaylight.org/sandbox/job/Jaya-netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-rocky-upstream-stateful-sodium/4/ <-- failing rocky job (jamoluhrsen, 03:40:49)
    20. looks like the robot vm does not have the openstack cli in this failing rocky job (jamoluhrsen, 03:43:08)
    21. 00:39:42 which: no openstack in (/tmp/v/robot/bin:/usr/local/bin:/usr/bin:/opt/puppetlabs/bin) (jamoluhrsen, 03:43:12)
    22. ZZCI - CentOS 7 - robot - 20190430-080312.962 (abelur, 03:44:25)
    23. https://www.irccloud.com/pastebin/bR1BkyAo/ (abelur, 03:56:08)
    24. https://git.opendaylight.org/gerrit/#/c/81522/ (zxiiro, 03:57:31)


Meeting ended at 04:01:33 UTC (full logs).

Action items

  1. jamoluhrsen to ask on TSC call tomorrow if we can lock Neon and look to work on SR1 release
  2. jamoluhrsen to convert these ownerships to a wiki page


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to ask on TSC call tomorrow if we can lock Neon and look to work on SR1 release
    2. jamoluhrsen to convert these ownerships to a wiki page


People present (lines said)

  1. jamoluhrsen (45)
  2. abelur (9)
  3. odl_meetbot (3)
  4. LuisGomez (3)
  5. zxiiro (1)


Generated by MeetBot 0.1.4.