#opendaylight-integration: integration

Meeting started by jamoluhrsen at 03:02:08 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 03:02:32)
    1. fluorine autorelease was passing for 5 builds in a row since it's trouble last week, but we just saw two of the last three fail: (jamoluhrsen, 03:03:35)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine-mvn35-openjdk8/ (jamoluhrsen, 03:03:35)
    3. we are considering locking fluorine now and only allowing blocking bugs to merge patches (jamoluhrsen, 03:06:10)
    4. https://jira.opendaylight.org/browse/BGPCEP-873 (LuisGomez, 03:06:17)
    5. lock stable/fluorine branch for upcoming Fluorine SR3 release on 31/May (abelur, 03:06:17)
    6. fluorine SR3 has two blocker bugs. CONTROLLER-1879 and BGPCEP-873 (jamoluhrsen, 03:07:18)
    7. the bgpcep bug is a regression and we know the patch that reintroduced it. (jamoluhrsen, 03:08:23)
    8. https://git.opendaylight.org/gerrit/#/c/81929/ <-- bgpcep regression (jamoluhrsen, 03:08:46)
    9. ACTION: LuisGomez to make a revert patch in fluorine (jamoluhrsen, 03:09:18)
    10. ACTION: abelur will lock fluorine soon (jamoluhrsen, 03:10:49)
    11. https://git.opendaylight.org/gerrit/#/c/82178/ (LuisGomez, 03:12:14)
    12. LuisGomez still needs a patch merged in order release neon SR1 for SM projects (jamoluhrsen, 03:12:22)

  2. infra (jamoluhrsen, 03:14:50)
    1. no news on builder/infra side this week. (jamoluhrsen, 03:15:05)
    2. actually we do have a problem with stale stacks consuming ip addresses (in delete failed state) and we were unable to hand out new ip addresses (jamoluhrsen, 03:16:48)
    3. faseelak (faseelak, 03:17:49)
    4. ACTION: abelur to update the integration list when the stale stacks are deleted and we can double check if we have the same problems with missing ips (jamoluhrsen, 03:18:40)
    5. our cleanup openstack job is failing and probably the root cause for our other failures, like failure to get ips (jamoluhrsen, 03:23:13)
    6. https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-callhome-only-sodium/148/console <--- example job failing to get ips (jamoluhrsen, 03:24:18)
    7. https://jenkins.opendaylight.org/releng/view/builder/job/builder-openstack-cron/18686/console failing openstack cleanup job (jamoluhrsen, 03:24:31)

  3. packaging (jamoluhrsen, 03:24:54)
    1. waiting on neon sr1 for SM before we can do the packaging work. (jamoluhrsen, 03:25:07)

  4. test (jamoluhrsen, 03:25:21)
    1. just for historical record, Jaya is also noticing how painful it is to debug hard problems in infra without live access. (jamoluhrsen, 03:28:25)

  5. docs (jamoluhrsen, 03:29:38)
    1. david is looking for direction on the docs side and plans to meet with LuisGomez and/or danieldelarosa (jamoluhrsen, 03:30:37)
    2. we should have a docs intern joining sooner or later. (jamoluhrsen, 03:31:05)

  6. misc (jamoluhrsen, 03:32:52)


Meeting ended at 03:33:34 UTC (full logs).

Action items

  1. LuisGomez to make a revert patch in fluorine
  2. abelur will lock fluorine soon
  3. abelur to update the integration list when the stale stacks are deleted and we can double check if we have the same problems with missing ips


Action items, by person

  1. abelur
    1. abelur will lock fluorine soon
    2. abelur to update the integration list when the stale stacks are deleted and we can double check if we have the same problems with missing ips
  2. LuisGomez
    1. LuisGomez to make a revert patch in fluorine


People present (lines said)

  1. jamoluhrsen (27)
  2. LuisGomez (5)
  3. odl_meetbot (3)
  4. abelur (2)
  5. faseelak (1)


Generated by MeetBot 0.1.4.