#opendaylight-integration: integration

Meeting started by jamoluhrsen at 03:02:17 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 03:02:29)
    1. Fluorine SR3 still has some details to figure out like a perf regression in controller cluster job (jamoluhrsen, 03:02:58)
    2. the regression happened after the most recent kernel project updates (jamoluhrsen, 03:03:57)
    3. we need to wait for the discussion on the TSC (jamoluhrsen, 03:04:32)
    4. seems the regression is only on Fluorine, and not the other branches (jamoluhrsen, 03:04:58)
    5. seems this regression is the last thing to resolve for SR3 (jamoluhrsen, 03:07:51)

  2. infra (jamoluhrsen, 03:08:10)
    1. no major updates on infra (jamoluhrsen, 03:08:28)
    2. lftools fix coming to compress all logs, but still allow browsers to see those files without having to manually uncompress (jamoluhrsen, 03:09:07)
    3. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/lf-infra-lftools-tox-verify-any/818/console.log.gz (abelur, 03:09:20)
    4. the stale ports were all cleaned out on infra so we should not see the problems with jobs failing because instances can't get IP addresses (jamoluhrsen, 03:12:26)
    5. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/builder-openstack-cron/19025/console.log.gz (abelur, 03:13:04)
    6. "ZZCI - Ubuntu 16.04 - mininet-ovs-26 - 20190507-011844.608" (abelur, 03:14:26)
    7. ACTION: abelur to investigate the openstack-cron job failure. that job is what helps clean up stale entites which can build up over time and cause job failures (jamoluhrsen, 03:14:27)
    8. https://www.irccloud.com/pastebin/ByiO6YEw/ (abelur, 03:15:00)
    9. openstack cron job deletes by name and not UUID. (abelur, 03:15:21)
    10. https://www.irccloud.com/pastebin/xtZRpCA5/ (abelur, 03:18:59)

  3. docs (jamoluhrsen, 03:24:00)
    1. no news for docs yet. (jamoluhrsen, 03:24:18)

  4. test (jamoluhrsen, 03:24:29)
    1. https://www.irccloud.com/pastebin/P1JwtMXK/ (abelur, 03:26:19)
    2. bgpcep is not active so there is nobody looking at the tests or fixing bugs so we can't expect a performance regression to be fixed (jamoluhrsen, 03:26:24)
    3. ACTION: jamoluhrsen to look in to why jobs are not getting auto updated in to the csit list that runs every autorelease or at least nightly (jamoluhrsen, 03:29:07)
    4. we need to upgrade robot, but we need a plan because it's not backwards compatible (jamoluhrsen, 03:30:23)
    5. ACTION: LuisGomez to send a community wide email that explains the robot framework upgrades that need to happen (jamoluhrsen, 03:33:32)
    6. the problem is that upstream ODL will upgrade to RF 3.2 and modify test code to work with it. If downstream consumers of our robot code do not upgrade their test infra will be broken (jamoluhrsen, 03:34:30)
    7. zxiiro has a trick with pre-commit that will correct all of the files to be we need. (jamoluhrsen, 03:36:49)
    8. karthika is having trouble with the comparestream library. jamoluhrsen will review (jamoluhrsen, 03:39:18)

  5. misc (jamoluhrsen, 03:39:41)
    1. https://jenkins.opendaylight.org/releng/job/builder-openstack-cron/19026/console (jamoluhrsen, 03:42:36)


Meeting ended at 03:46:00 UTC (full logs).

Action items

  1. abelur to investigate the openstack-cron job failure. that job is what helps clean up stale entites which can build up over time and cause job failures
  2. jamoluhrsen to look in to why jobs are not getting auto updated in to the csit list that runs every autorelease or at least nightly
  3. LuisGomez to send a community wide email that explains the robot framework upgrades that need to happen


Action items, by person

  1. abelur
    1. abelur to investigate the openstack-cron job failure. that job is what helps clean up stale entites which can build up over time and cause job failures
  2. jamoluhrsen
    1. jamoluhrsen to look in to why jobs are not getting auto updated in to the csit list that runs every autorelease or at least nightly


People present (lines said)

  1. jamoluhrsen (31)
  2. abelur (10)
  3. odl_meetbot (3)


Generated by MeetBot 0.1.4.