#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:03:12 UTC (full logs).

Meeting summary

  1. status update (colindixon, 20:03:18)
    1. we’ve moved to the new data broker interfaces (colindixon, 20:04:17)
    2. ACTION: evanz_ or djx to rename betterhosttracker to mdhostracker (at somet point) (colindixon, 20:13:08)
    3. https://github.com/nilok/betterhosttracker/ the current code just for posterity (colindixon, 20:13:36)

  2. next steps (colindixon, 20:14:07)
    1. the next steps are basically to wire this up with something that will generate Addresses objects in the MD-SAL to cause our data change events (colindixon, 20:16:13)
    2. the l2switch project claims to have the address tracker working, I was just able to build the addresst tracker part at least (colindixon, 20:17:26)
    3. if we import the l2switch, we get errors in betterhosttracker, I think this is because their pom file sucks and doesn’t list the yang generated source directories correclty (colindixon, 20:28:05)
    4. the l2switch project has a distribution, which should work for us, we’ll just need to copy in the two addresstracker jar files and the betterhosttracker jar files (colindixon, 20:29:00)
    5. just as a heads up, when runnign run.sh, you probably want to add -Xmx2048m -XX:MaxPermSize=512m so “./run.sh -Xmx2048m -XX:MaxPermSize=512m” so that it doesn’t run out of memory (colindixon, 20:36:58)
    6. https://gist.github.com/nilok/0005658677c71bb3a788 (colindixon, 20:43:14)
    7. we’re running into problems building and/or running the l2switch project (colindixon, 21:04:26)
    8. colindixon e-mailed the l2swtich team to ask for help with the fact that things aren’t compiling (colindixon, 21:09:09)

  3. fallback plans (colindixon, 21:10:10)
    1. so, while we wait for them to fix the l2switch stuff, we could take the base distribution from openflowplugin and use it (colindixon, 21:10:40)
    2. we’ll then need to copy in the address tracker jars, their dependencies and the host tracker jars (colindixon, 21:10:59)
    3. and see if we can get that to work and generate data change events (colindixon, 21:11:30)
    4. I recommend using log.error() or system.out.println() messages to figure out if you’re code is hitting because the logging is often configured to only print error messages and above (colindixon, 21:12:14)


Meeting ended at 21:13:27 UTC (full logs).

Action items

  1. evanz_ or djx to rename betterhosttracker to mdhostracker (at somet point)


Action items, by person

  1. djx
    1. evanz_ or djx to rename betterhosttracker to mdhostracker (at somet point)
  2. evanz_
    1. evanz_ or djx to rename betterhosttracker to mdhostracker (at somet point)


People present (lines said)

  1. colindixon (146)
  2. djx (81)
  3. evanz_ (70)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.