#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 19:05:43 UTC (full logs).

Meeting summary

  1. status update (colindixon, 19:05:49)
    1. evanz_ posted a change to deal with the new, better typed read operations (colindixon, 19:06:23)
    2. https://wiki.opendaylight.org/view/MdHostTracker evanz_ started on a wiki page to show how to get up and play with the MDHostTracker (colindixon, 19:07:29)

  2. participating in helium (colindixon, 19:08:56)
    1. to participate in helium we probably need to: (1) finish our model by 8/4, (2) provide some rudimentary documentation, (3) provide a description of ourselves as a karaf feature, (4) provide a “component” that we can export from l2switch, (5) provide a sanitized list of hosts, e.g., no hosts in the middle of the network (colindixon, 19:11:16)
    2. evanz_ and djx want to go for it :-) (colindixon, 19:11:47)
    3. https://lists.opendaylight.org/pipermail/l2switch-dev/2014-July/000012.html this is the mail (colindixon, 19:15:35)
    4. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html I think edwarnicke wants to provide this functionality from the MD-SAL in Helium (both via this interface for compatibility and via the MD-SAL directly) (colindixon, 19:17:23)
    5. https://plus.google.com/hangouts/_/g2xain4atypgbhpka326z6tncua (colindixon, 19:20:37)
    6. https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations (colindixon, 19:27:37)
    7. the other thing I left from helium release is picking which java interfaces, e.g., IfIptoHost, we want to export and getting that done (colindixon, 19:37:00)
    8. we might be able to foist that off onto the l2switch team (colindixon, 19:37:10)
    9. AGREED: we will participate in helium as part of the l2switch project, but as our own component (colindixon, 19:37:29)

  3. next steps (colindixon, 19:37:34)
    1. ACTION: evanz_ will refactor the mdhosttracker project appropriately and get it into l2switch (colindixon, 19:38:08)
    2. evanz_ make sure to have the l2swtich guys hit merge, not us (colindixon, 19:38:37)
    3. https://gist.github.com/evanzeller/b39c7603fc6d0d91e7fd (evanz_, 19:38:51)
    4. https://github.com/nilok/betterhosttracker/blob/master/mdhosttracker/mdhosttracker/model/src/main/yang/host-tracker-service.yang the model (colindixon, 19:43:13)
    5. https://gist.github.com/anonymous/5a59f031d19ad3c734ba (colindixon, 19:44:13)
    6. we need a node connector ref in the host (colindixon, 19:44:56)
    7. or a list of them (colindixon, 19:45:03)
    8. https://gist.github.com/anonymous/7ee9c9029653bf361d64 (colindixon, 19:46:06)
    9. colin mades some edits to our model to add node connectors (colindixon, 19:52:07)

  4. finishing up (colindixon, 19:55:19)
    1. ACTION: colindixon to send out e-mail with tasks for helium and deadlines (colindixon, 19:55:31)
    2. ACTION: evanz_ to respond to the l2switch guys (colindixon, 19:56:00)
    3. to get the l2switch project just do this: https://git.opendaylight.org/gerrit/controller (colindixon, 19:58:07)
    4. to submit a patch you can commit, then go “git review" (colindixon, 19:58:19)
    5. https://wiki.opendaylight.org/view/Git-review_Workflow git review works really, really well (colindixon, 19:58:46)
    6. we need to start the discussion of what Java interfaces we will provide as services and start getting that working as well as filtering node connectors for attachment points (colindixon, 19:59:57)


Meeting ended at 20:00:20 UTC (full logs).

Action items

  1. evanz_ will refactor the mdhosttracker project appropriately and get it into l2switch
  2. colindixon to send out e-mail with tasks for helium and deadlines
  3. evanz_ to respond to the l2switch guys


Action items, by person

  1. colindixon
    1. colindixon to send out e-mail with tasks for helium and deadlines
  2. evanz_
    1. evanz_ will refactor the mdhosttracker project appropriately and get it into l2switch
    2. evanz_ to respond to the l2switch guys


People present (lines said)

  1. colindixon (73)
  2. evanz_ (28)
  3. djx (13)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.