#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:48:46 UTC (full logs).

Meeting summary

  1. karaf and splitting l2switch address tracker (colindixon, 20:49:04)
    1. we need a bundle which proves addresses but *does not* push rules (colindixon, 20:49:24)
    2. or depend on any bundles that automatically push rules (colindixon, 20:49:34)
    3. after that, we can make a karaf feature which just includes the bundles we need (colindixon, 20:50:10)

  2. AD-SAL APIs (colindixon, 20:50:25)
    1. colindixon sent mail listing the four APIs and who uses them (colindixon, 20:50:56)
    2. see the log for the list (colindixon, 20:51:37)
    3. ACTION: evanz_ will go through VTN, controller, toolkit, sdninterfaceapp and see what subsets of the API they’re using (colindixon, 20:52:26)
    4. one thing you could do would be to edit the interface to remove the functions you don’t want to implement, then build the other project with -nsu and see if you get compile errors (colindixon, 20:53:15)
    5. toolkit might be a pain in the ass because it’s embedded in an archetype (colindixon, 20:54:38)
    6. djx points out to also trust/use grep to start your search (colindixon, 20:55:06)
    7. we’re planning to ignore affinity because they’re not participating in helium (colindixon, 20:55:25)
    8. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html (colindixon, 20:56:40)
    9. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/hostAware/IHostFinder.html (colindixon, 20:56:58)
    10. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfHostListener.html (colindixon, 20:57:14)
    11. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfNewHostNotify.html (colindixon, 21:02:14)
    12. IHostFinder is to send probes actively into the network, we should probably not implement that (colindixon, 21:02:20)
    13. IfHostListener was implemented by HostTracker and called by ArpHanlder (this is analogous to the address tracker today, skip it) (colindixon, 21:02:27)
    14. IfNewHostNotify is the interface apps can implement to be notified when host show up or go away (we want to implement this) (colindixon, 21:03:08)
    15. to implement it right, we need to figure out who implements that, but I don’t know how to do that from a bundle that doesn’t have the AD-SAL style activator (colindixon, 21:08:42)
    16. ACTION: colindixon to ask devinavery about getting services from an MD-SAL app and connect you guys with him (colindixon, 21:09:13)

  3. keep working on the code we have (colindixon, 21:10:15)
    1. https://git.opendaylight.org/gerrit/#/c/9798/ (colindixon, 21:10:25)


Meeting ended at 21:47:50 UTC (full logs).

Action items

  1. evanz_ will go through VTN, controller, toolkit, sdninterfaceapp and see what subsets of the API they’re using
  2. colindixon to ask devinavery about getting services from an MD-SAL app and connect you guys with him


Action items, by person

  1. colindixon
    1. colindixon to ask devinavery about getting services from an MD-SAL app and connect you guys with him


People present (lines said)

  1. colindixon (45)
  2. odl_meetbot (6)
  3. djx (1)


Generated by MeetBot 0.1.4.