#opendaylight-intern: jQuery/Xpath for MD-SAL intern

Meeting started by colindixon at 13:46:58 UTC (full logs).

Meeting summary

    1. Neel_B has code that shows we didn’t quite understand what we needed to make things work (colindixon, 13:47:16)
    2. it appears as though ThrowExceptionNode should have extended Element instead of Node (colindixon, 13:48:30)
    3. also for whatever reason we’re still getting “#document” when we call getNodeName() on the root (colindixon, 13:53:07)
    4. ACTION: Neel_B to make ThrowExceptionNode extend Element (colindixon, 13:53:27)
    5. ACTION: Neel_B to also figure out what function on the root node actually returns “a” and change that test case to match reality (colindixon, 13:54:09)
    6. ACTION: Neel_B to make sure that all the new methods (from Element) in ThrowsExceptionNode (which should really now be ThrowsExceptionElement) actually throw exceptions so that we can quickly tell which ones we need to implement (colindixon, 14:19:20)
    7. Neel_B says he has to also implement getTextContent() (colindixon, 14:19:35)


Meeting ended at 14:20:05 UTC (full logs).

Action items

  1. Neel_B to make ThrowExceptionNode extend Element
  2. Neel_B to also figure out what function on the root node actually returns “a” and change that test case to match reality
  3. Neel_B to make sure that all the new methods (from Element) in ThrowsExceptionNode (which should really now be ThrowsExceptionElement) actually throw exceptions so that we can quickly tell which ones we need to implement


Action items, by person

  1. Neel_B
    1. Neel_B to make ThrowExceptionNode extend Element
    2. Neel_B to also figure out what function on the root node actually returns “a” and change that test case to match reality
    3. Neel_B to make sure that all the new methods (from Element) in ThrowsExceptionNode (which should really now be ThrowsExceptionElement) actually throw exceptions so that we can quickly tell which ones we need to implement


People present (lines said)

  1. colindixon (42)
  2. Neel_B (36)
  3. odl_meetbot (3)
  4. devinavery (1)


Generated by MeetBot 0.1.4.