#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 15:39:29 UTC (full logs).

Meeting summary

  1. status update (colindixon, 15:39:34)
    1. Neel_B is fighting a connection refused issue (see mails) (colindixon, 15:39:46)
    2. it’s not clear exactly what’s causing it, but the current hypothesis is that it’s Neel_B’s prox service provider and he has a mail into the system admin (colindixon, 15:40:13)
    3. Neel_B did go through creating the MD-SAL archetype (colindixon, 15:44:29)

  2. next steps (colindixon, 15:47:54)
    1. devinavery is curious if we can get something with the toaster IT to work if we comment out everything in the @Test methods but a few System.out.println methods to see if things work (colindixon, 16:09:38)
    2. ACTION: colindixon to send e-mail to controller-dev asking about using pax-exam and why we might get these connection refused errors (colindixon, 16:12:31)
    3. Neel_B says that he’s getting the same connecton failure exception regardless of how much he tries to comment out in getting the toaster IT up (colindixon, 16:13:36)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Toaster_Step-By-Step this is a long (and good) walkthrough of the toaster from devinavery and others (colindixon, 16:18:10)
    5. I think that replacing the the make toast RPC with a call tests RPC and wiring that to the tests we’ve already written so far (colindixon, 16:19:25)
    6. would be a good exercise (colindixon, 16:19:32)
    7. ACTION: Neel_B to go through the toaster step-by-step and try to replace one of the RPCs with a call to the tests we wrote before, i.e., Testcases.java (colindixon, 16:20:14)

  3. next meeting (colindixon, 16:24:04)
    1. Neel_B will e-mail progress out before tomorrow evening (for him) so that we can decide if we need to meet or not (colindixon, 16:24:27)


Meeting ended at 16:25:06 UTC (full logs).

Action items

  1. colindixon to send e-mail to controller-dev asking about using pax-exam and why we might get these connection refused errors
  2. Neel_B to go through the toaster step-by-step and try to replace one of the RPCs with a call to the tests we wrote before, i.e., Testcases.java


Action items, by person

  1. colindixon
    1. colindixon to send e-mail to controller-dev asking about using pax-exam and why we might get these connection refused errors
  2. Neel_B
    1. Neel_B to go through the toaster step-by-step and try to replace one of the RPCs with a call to the tests we wrote before, i.e., Testcases.java


People present (lines said)

  1. colindixon (48)
  2. Neel_B (24)
  3. devinavery (13)
  4. regXboi (12)
  5. odl_meetbot (3)


Generated by MeetBot 0.1.4.