#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 16:02:46 UTC (full logs).

Meeting summary

  1. status update (colindixon, 16:02:55)
    1. Neel_B says he’s fixed his pax-exam proxy issues :-) (colindixon, 16:03:23)
    2. the issue seems to have been that some of the maven plugins don’t use the maven proxy settings as you’d like them to (colindixon, 16:13:51)
    3. http://stackoverflow.com/questions/1251192/how-do-i-use-maven-through-a-proxy last answer (Neel_B, 16:14:08)
    4. http://stackoverflow.com/questions/1251192/how-do-i-use-maven-through-a-proxy the last answer here was what fixed it for Neel_B (colindixon, 16:14:35)

  2. next steps (colindixon, 16:15:30)
    1. ACTION: colindixon to reply to his own thread on the controller-dev list aobut using maven through a proxy with that link (colindixon, 16:16:36)
    2. https://meetings.opendaylight.org/opendaylight-intern/2014/jquery_xpath_for_md_sal_intern/opendaylight-intern-jquery_xpath_for_md_sal_intern.2014-07-10-15.10.html the next steps from this earlier meeting should now be things we can get moving (colindixon, 16:16:59)
    3. Neel_B has the toaster-it running, has commented all the testToaster methods out and added a simple print statement so he knows things are running with his modified code (colindixon, 16:21:30)
    4. the next two actions are verbatim copied from the 2014-07-10 meeting above (colindixon, 16:22:18)
    5. ACTION: Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in). (colindixon, 16:22:32)
    6. ACTION: Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL (colindixon, 16:22:41)
    7. ACTION: Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.) (colindixon, 16:22:49)
    8. when we start writing tests, it might be useful compare XPath with our special nodes to XPath on the actual MD-SAL nodes that are converted to a Document (colindixon, 16:23:41)
    9. https://git.opendaylight.org/gerrit/#/c/8975/6/ttp-model/model/src/test/java/org/opendaylight/ttp/model/test/TTPYangModelTest.java line 124 of this file shows how to get a Document from a DataObject (Toaster should be a DataObject if we’re using the binding interfaces) (colindixon, 16:25:52)
    10. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/md/sal/common/api/data/AsyncDataBroker.html this is the better documented way to get data into and out of the MD-SAL (colindixon, 16:30:03)
    11. ahead of this note in the full log are code snippets which should hopefully allow Neel_B to get his hands on a toaster from the MD-SAL (colindixon, 16:47:45)

  3. next meeting time and following up (colindixon, 16:48:05)
    1. we’ll plan the next meeting through mail (colindixon, 16:48:48)
    2. lets plan to touch base for at least a few minutes in this time slot tomorrow though (11a–12p central/9:30–10:30p India) (colindixon, 16:50:10)


Meeting ended at 16:51:02 UTC (full logs).

Action items

  1. colindixon to reply to his own thread on the controller-dev list aobut using maven through a proxy with that link
  2. Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in).
  3. Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL
  4. Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.)


Action items, by person

  1. colindixon
    1. colindixon to reply to his own thread on the controller-dev list aobut using maven through a proxy with that link
  2. Neel_B
    1. Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in).
    2. Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL
    3. Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.)


People present (lines said)

  1. colindixon (74)
  2. Neel_B (22)
  3. regXboi (13)
  4. odl_meetbot (3)
  5. djx (2)


Generated by MeetBot 0.1.4.