#opendaylight-intern: jQuery/Xpath for MD-SAL intern

Meeting started by colindixon at 14:11:26 UTC (full logs).

Meeting summary

    1. Neel_B is getting a toaster from the pax-exam toaster-it by injecting the DataBroker (colindixon, 14:11:43)
    2. Neel_B is trying to use DOMDataBroker in the same way, but the DOMDataBroker is null (colindixon, 14:11:47)

  1. brainstorming (colindixon, 14:11:52)
    1. so, data in the MD-SAL is stored two ways: (i) as DataObjects which are actually java Objects that have normal methods and stuff and (ii) as things called CompositeNodes which are basically like DOM Nodes (colindixon, 14:12:00)
    2. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/md/sal/dom/api/DOMDataBroker.html the DOMDataBroker API (colindixon, 14:12:26)
    3. as a stopgap, you can convert from DataObject which is what you’re getting to a CompositeNode by either injecting a BindingIndependentMappingService or creating a local RuntimeGeneratedMappingServiceImpl and then using it’s toDataDom() method on the Toaster you get out (colindixon, 14:19:40)
    4. https://git.opendaylight.org/gerrit/gitweb?p=ttp.git;a=blob;f=ttp-model/model/src/test/java/org/opendaylight/ttp/model/test/TTPYangModelTest.java;hb=47f6704b0c4ba1742b68d6c37bd1402f4918fb82 you can see an example here (colindixon, 14:22:16)
    5. https://meetings.opendaylight.org/opendaylight-intern/2014/jquery_xpath_for_md_sal_intern/opendaylight-intern-jquery_xpath_for_md_sal_intern.2014-07-31-14.11.log.txt (colindixon, 15:08:25)
    6. http://pastebin.com/me1tqDtr (Neel_B_, 15:14:27)
    7. https://github.com/neel1438/Opendaylight (Neel_B_, 15:21:46)
    8. https://github.com/neel1438/Opendaylight (regXboi, 15:27:54)
    9. https://github.com/neel1438/Opendaylight (regXboi, 15:28:00)
    10. http://pastebin.com/me1tqDtr the code with the link above is failing with this error :-/ (colindixon, 15:53:11)
    11. I *think* the issue is that you can’t use BindingReflections.loadModuleInfos() from an OSGi environment (colindixon, 16:10:37)
    12. you have get the BindingIndependentMappingService from as an OSGi service (colindixon, 16:11:02)
    13. Neel_B_: did you try putting the “@Inject” and “@Filter(timeout=60*1000)” as annotations above the other lines, e.g., “DOMDataBroker domDataBroker;”, “BindingIndependentMappingService mappingService;”, and “SchemaContext context;” to see if that worked? (colindixon, 16:13:45)
    14. I tried that and it worked (colindixon, 16:15:27)
    15. https://github.com/nilok/Opendaylight/commit/608a6fb2fcb6785bd4effa6a19d3cf416d2b7955 the code is here, I’ll issue a pull request (colindixon, 16:21:07)
    16. just look for the ToasterTest.java file in that mess (colindixon, 16:22:00)
    17. regXboi confirms that works (regXboi, 16:27:13)
    18. ACTION: to ping Neel_B and make sure he's made the changes colindixon has suggested (regXboi, 16:59:10)


Meeting ended at 16:59:14 UTC (full logs).

Action items

  1. to ping Neel_B and make sure he's made the changes colindixon has suggested


Action items, by person

  1. colindixon
    1. to ping Neel_B and make sure he's made the changes colindixon has suggested
  2. Neel_B
    1. to ping Neel_B and make sure he's made the changes colindixon has suggested


People present (lines said)

  1. colindixon (73)
  2. regXboi (25)
  3. Neel_B_ (19)
  4. Neel_B (17)
  5. devinavery (5)
  6. odl_meetbot (4)


Generated by MeetBot 0.1.4.