#opendaylight-intern: dependency tracking

Meeting started by colindixon at 12:03:57 UTC (full logs).

Meeting summary

  1. demo (colindixon, 12:04:00)
    1. http://54.148.146.38/dnvtools/sidemenu/ the demo from abhi (colindixon, 12:04:17)

  2. design ideas (colindixon, 12:07:34)
    1. we want to track bundles by their unique ID, which is artifactId, groupId, and version (colindixon, 12:07:53)
    2. after that, for bundles that are from opendaylight, we want to bin them by project (colindixon, 12:08:07)
    3. that means, if the groupId starts with org.opendaylight, we want to pull out the next segment in it’s groupId as the project (colindixon, 12:08:33)
    4. for example, if we have a bundle with groupId org.opendaylight.yangtools.models, we’ll put in the yangtools project, but we *still* want to track the bundle with it’s full unique ID (colindixon, 12:09:07)

  3. demo continued (colindixon, 12:11:02)
    1. abhi shows his parsar.py (colindixon, 12:11:48)
    2. it parses pom files and shows the versions, but in many cases it’s still using variables because help effective-pom is slow (colindixon, 12:15:20)
    3. it’s taking a while to run mvn help effective-pom because abhi’s internet access is slow (colindixon, 12:16:11)
    4. colindixon suggests running the script via jenkins in the sandbox for now (colindixon, 12:16:42)
    5. https://wiki.opendaylight.org/view/RelEng/Builder/Jenkins#Jenkins_Sandbox instructions on getting a job to run in the jenins sandbox (colindixon, 12:18:00)
    6. to get this to work in jenkins we would just create a new JJB job that’s just a shell script that then runs this python (colindixon, 12:19:58)
    7. another option would be to curl the file down from github and then run it (colindixon, 12:20:23)
    8. the output will have to be declared as an artifact, there’s a post-build action where you need to basically say “archive artifact” and list the output file (colindixon, 12:22:17)
    9. zxiiro strongly suggests using jenkins job builder so you have an external backup of the job, probably also check that into github (colindixon, 12:22:55)
    10. eventually, we’ll want to move the python script into some project and the JJB job into releng/builder (colindixon, 12:23:47)
    11. colindixon says that when we’re tracking the versions of a given dependency, we also want to track where that version number came from, e.g., what pom file (colindixon, 12:29:01)

  4. including this in ODL (colindixon, 12:31:01)
    1. it might be worth pushign this as a change to gerrit in autorelease, so that we could clone it using it’s ref from gerrit (colindixon, 12:31:40)
    2. let’s look into that next week (colindixon, 12:32:18)

  5. questions about parsing pom files (colindixon, 12:34:52)
    1. don’t look for dependency information in dependencyManagement, just in dependencies (colindixon, 12:35:20)
    2. colindixon notes that in the future we might actually need to also track dependencies inside plugin sections (colindixon, 12:39:24)
    3. for now, you could just look at the project/dependencies section (colindixon, 12:40:09)
    4. in the logn run, you’ll want to ignore dependencyManagement and look at everything else, e.g., also include dependencies from plugins (colindixon, 12:41:16)

  6. for next week (colindixon, 12:41:20)
    1. colindixon would like to see this python script running in jenkins via jenkins job builder and also using the maven effective-pom to generate thigns with valid versions everywhere (colindixon, 12:41:59)
    2. if that’s easy, then we could start to produce reports, e.g., places where we have the same artifact with multiple version (colindixon, 12:42:30)
    3. also, we want to make sure we track the pom file where the versions came from so we can know where to go look when there’s version skew (colindixon, 12:43:19)
    4. ACTION: colindixon will set up a trello board for this project (colindixon, 12:43:50)


Meeting ended at 12:45:20 UTC (full logs).

Action items

  1. colindixon will set up a trello board for this project


Action items, by person

  1. colindixon
    1. colindixon will set up a trello board for this project


People present (lines said)

  1. colindixon (35)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.