#opendaylight-intern: dependency tracking

Meeting started by colindixon at 12:10:35 UTC (full logs).

Meeting summary

  1. review from last week (colindixon, 12:10:47)
    1. https://trello.com/b/SIRfdRVV/odl-dependency-tracking abhi_ seems to have done a lot of stuff on the trello board (colindixon, 12:11:47)
    2. https://github.com/abhishekmittal09/dnvtools the code on github (colindixon, 12:11:59)
    3. abhi_ says he got a lot of good stuff done, but is struggling jenkins (colindixon, 12:14:39)

  2. jenkins (colindixon, 12:14:41)
    1. https://jenkins.opendaylight.org/releng/ this is where all of our jenkins jobs show (colindixon, 12:15:06)
    2. https://git.opendaylight.org/gerrit/gitweb?p=releng/builder.git;a=tree;f=jjb;hb=HEAD this is where all those jobs come from, there’s one directory for each project (colindixon, 12:16:06)
    3. https://git.opendaylight.org/gerrit/gitweb?p=releng/builder.git;a=tree;f=jjb/autorelease;h=9c743218b49a96db5a45e3c40a73908ed74c8019;hb=HEAD (colindixon, 12:16:26)
    4. https://jenkins.opendaylight.org/sandbox/ this is our sandbox which is a test jenkins server to avoid messing with our production stuff (colindixon, 12:17:57)
    5. https://wiki.opendaylight.org/view/RelEng:Jenkins#Jenkins_Sandbox here are the instructions for using the sandbox (colindixon, 12:18:24)
    6. importantly, note that you don’t need to install jenkins at all, just jenkins-job-builder, which is a tiny python script (colindixon, 12:18:54)
    7. ACTION: abhi_ to send e-mail to helpdesk@opendaylight.org ot open a sandbox account (colindixon, 12:19:11)
    8. the last part (about using docker) is only if you want to be able to run it in on your computer (colindixon, 12:20:07)
    9. zxiiro also says that we have docker images that have jenkins-job-builder installed if you can’t install it on your machine, but it’s better if you can (colindixon, 12:20:32)

  3. can somebody explain how to run a jenkins/JJB job (colindixon, 12:24:06)
    1. https://github.com/opendaylight/releng-builder/blob/master/jjb/autorelease/autorelease-lithium.yaml this is the JJB YAML file for the lithium autorelease jenkins job (colindixon, 12:24:21)
    2. note that this is from our github mirror because color highlighting is nice, it’s actually hosted in git.opendaylight.org (colindixon, 12:24:58)
    3. https://github.com/opendaylight/releng-builder/blob/master/jjb/autorelease/autorelease-lithium.yaml#L71 (colindixon, 12:25:29)
    4. abhi_ asks how do you know what directory you’re in, e.g., how do you know that line 71 works and ./script/list-project-dependencies will actually be in the right place? (colindixon, 12:27:33)
    5. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/configure (zxiiro, 12:27:37)
    6. that link is the jenkins job that is generated when you compile the above linked yaml file (colindixon, 12:28:13)
    7. in essence, the working directory in which your scripts of any script you run will be the root of the git repository you clone (colindixon, 12:30:34)
    8. that’s only if you clone *one* git repository, which would mean forking autorelease and putting your script in your fork on github (colindixon, 12:32:00)
    9. reach out to us in #opendaylight-releng for sandbox related help (colindixon, 12:34:56)
    10. https://github.com/opendaylight/releng-autorelease/ in the short-run, you probably want fork this on your github page and then clone it using your own JJB yaml file (colindixon, 12:38:29)

  4. next steps for jenkins (colindixon, 12:39:48)
    1. first, fork the releng-autorelease project on github (colindixon, 12:40:07)
    2. second, put your scripts in the scripts directory there (colindixon, 12:40:12)
    3. third, copy the autorelease-lithium.yaml file from releng-buider on github and use it as your template for a jenkis job that you’ll play with in the sandbox (colindixon, 12:40:44)
    4. fourth, change the name and jobs section to dependecny-tracking or something (colindixon, 12:41:08)
    5. fifth, use the instructions on the releng/builder wiki page to make sure you can push that job to the sandbox (colindixon, 12:41:29)
    6. if you have issues with this step, reach out to people in #opendaylight-releng on IRC (colindixon, 12:42:56)
    7. sixth, change the scm section of the yaml file to point to your repo on github instead of the local autorelease repo (colindixon, 12:43:25)
    8. seventh, change the node type on line 18 to dynamic_verify (this will give you only 4GB insead 8GB) (colindixon, 12:44:19)
    9. eighth, change the project-type to freestyle insead of maven, this will stop it from building all of autorelease which will take forever (colindixon, 12:45:25)
    10. ninth, delete the maven block since it no longer applies (colindixon, 12:45:57)
    11. tenth, you want to rename prebuilders: to builders: (colindixon, 12:46:58)
    12. eleventh, you want to copy the shell syntax from postbuilers: into builders: and change it to use your script (colindixon, 12:47:30)
    13. twelfth, you want to delte the postbuilders block (colindixon, 12:47:45)
    14. thirteenth, delete the triggers block since we don’t want it to trigger based on time yet (colindixon, 12:48:19)
    15. fourteenth, under jobs: at the top, just leave one entry, e.g., depenency-tracking-lithium (colindixon, 12:49:07)
    16. zeroth (DO THIS BEFORE EVERYTHING ELSE) remove the other two complete copies of the job-template: section (colindixon, 12:50:09)
    17. fifteenth add whatever output file you have in the archive-artifacts: in publishers: (colindixon, 12:54:40)

  5. next week (colindixon, 12:55:13)
    1. colindixon will be out of the country next thursday, and I likely won’t make the meeting (colindixon, 12:55:29)
    2. zxiiro and abhi_will meet anyway to go over progress here (colindixon, 12:55:54)
    3. after getting this stuff working in jenkns, the next step is figuring out how to fold it’s output into the web-UI that abhi_ has been working on (colindixon, 12:57:39)


Meeting ended at 12:58:58 UTC (full logs).

Action items

  1. abhi_ to send e-mail to helpdesk@opendaylight.org ot open a sandbox account


People present (lines said)

  1. colindixon (52)
  2. odl_meetbot (6)
  3. zxiiro (3)


Generated by MeetBot 0.1.4.