#opendaylight-intern: dependency tracking
Meeting started by colindixon at 12:02:39 UTC
(full logs).
Meeting summary
- what happened last week (colindixon, 12:02:44)
  - http://54.148.146.38/dnvtools/sidemenu/
    (colindixon,
    12:03:37)
 
  - if you go to version skew tab, you see a list
    of modules with more than one version (colindixon,
    12:05:07)
 
  - right now, it’s the groupId and artifactId, the
    project which the dependencies were found in, and the
    versions (colindixon,
    12:06:00)
 
  - it would be easier if we had pom file instead
    of project (colindixon,
    12:06:24)
 
  - e.g., it would be nice to see the left column
    stay the same: the groupId and artifactId (colindixon,
    12:08:08)
 
  - the second column should be the version # and
    should list all of the unique version #s for that artifactId and
    groudId (colindixon,
    12:08:38)
 
  - the third colum would be a list of all the pom
    files that reference the given triple artifactId, groupId and
    version (colindixon,
    12:09:00)
 
  - ideally, across all projects, so the pom file
    will tell you what project you’re in (colindixon,
    12:09:21)
 
  - if you have to, you would prepent the project
    name e.g., pom.xml would become controller/pom.xml (colindixon,
    12:09:53)
 
  - darkdragon says that some of the pom files
    aren’t being generate properly with an outofmemory issue or
    something like that (colindixon,
    12:13:08)
 
  - ACTION: darkdragon to
    send out the error he gets when generating effective pom
    flles (colindixon,
    12:13:48)
 
  - https://wiki.opendaylight.org/view/OpenDaylight_Controller:Installation#1._Out_of_memory_error_-_java.lang.OutOfMemoryError:_PermGen_space
    usualy setting -Xmx to 1G or 2G and setting MaxPermSize to 512m or
    1G, will help (colindixon,
    12:14:39)
 
 
- next steps (colindixon, 12:17:56)
  - colindixon notes that the current dependency
    graph looks wrong, e.g., packetcable, nic, topoprocessing,
    reservatin, ttp, vpnservice, lispflowmapping and tsdr, all have no
    dependenices (colindixon,
    12:18:39)
 
  - https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/4/console
    (darkdragon,
    12:19:29)
 
  - he was able to get a jenkins job, but it was
    throwing an error that it couldn’t find maven (colindixon,
    12:20:12)
 
  - https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/4/console
    the error is here (colindixon,
    12:20:20)
 
  - zxiiro says that you have to declare a
    “top-level maven target” (colindixon,
    12:20:32)
 
  - zxiiro says the simplest thing to do is to
    decare a maven action with the goal of clean, to set the maven
    version (colindixon,
    12:21:06)
 
  - ACTION: darkdragon
    will try to get the jenkins script so that before the “execute
    shell” build action, it does a “invoke top-level Maven targets” with
    a goal fo clean and Maven version of Maven 3.3.3 (colindixon,
    12:23:13)
 
 
- fixing the jenkins job (colindixon, 12:44:10)
  - one idea is to make this a maven job instead of
    a freestyle job, which might give us a valid maven for the whole
    time (colindixon,
    12:44:58)
 
  - another idea is to actually do the maven
    help:effective-pom as part of the mavne top-level project, but we
    need it to run on every project (colindixon,
    12:45:30)
 
  - the last option would be to instead use the
    maven exec to run things, but that’s actually not likely to work
    either (colindixon,
    12:47:57)
 
  - for now, let’s just use this path:
    /opt/jenkins/tools/hudson.tasks.Maven_MavenInstallation/Maven_3.3.3/bin/mvn
    (colindixon,
    12:48:12)
 
  - that will change whenever the version of maven
    changes, but for now, it’s probably fine (colindixon,
    12:48:34)
 
  - ACTION: abhi wil
    change line 39 of his parsar.py script to use that path
    instead (colindixon,
    12:51:20)
 
 
- actions for this week (colindixon, 12:53:23)
  - ACTION: abhi to
    modifiy the jjb file he has to first call maven clean with a maven
    goal and use maven 3.3.3 so that we get a maven executable to
    use (colindixon,
    12:53:53)
 
  - ACTION: abhi to
    modify parsar.py and the web scripts to give the new table
    structure, i.e., (groupId, artifactId) => list ( versions =>
    list of pom files) (colindixon,
    12:54:51)
 
  - ACTION: abhi to work
    with zxiiro to figure what’s going on with help:effective-pom
    failing sometimes (colindixon,
    12:55:17)
 
  - after we can do those things, we can figure out
    if we belive the results (colindixon,
    12:55:31)
 
  - for what it’s worth, hard coding the maven
    executable path seems to be working (colindixon,
    12:57:02)
 
  - http://pastebin.com/xRckS4K9
    the yaml file he’s using to generate the jenkins job (colindixon,
    12:57:22)
 
  - https://github.com/opendaylight/releng-builder/blob/master/jjb/ttp/ttp.yaml#L101
    if you copy that maven-target: section into the yaml file you have
    just before the shell builder, it shoudl work (colindixon,
    12:58:51)
 
  - obviously change the goals to just clean
    (colindixon,
    12:59:51)
 
  - you should be able to ignore the settings and
    global settings (colindixon,
    13:00:23)
 
  - we’ll meet on Thursday as usual (colindixon,
    13:00:48)
 
 
Meeting ended at 13:03:27 UTC
(full logs).
Action items
  - darkdragon to send out the error he gets when generating effective pom flles
 
  - darkdragon will try to get the jenkins script so that before the “execute shell” build action, it does a “invoke top-level Maven targets” with a goal fo clean and Maven version of Maven 3.3.3
 
  - abhi wil change line 39 of his parsar.py script to use that path instead
 
  - abhi to modifiy the jjb file he has to first call maven clean with a maven goal and use maven 3.3.3 so that we get a maven executable to use
 
  - abhi to modify parsar.py and the web scripts to give the new table structure, i.e., (groupId, artifactId) => list ( versions => list of pom files)
 
  - abhi to work with zxiiro to figure what’s going on with help:effective-pom failing sometimes
 
Action items, by person
  -  darkdragon 
    - darkdragon to send out the error he gets when generating effective pom flles
 
    - darkdragon will try to get the jenkins script so that before the “execute shell” build action, it does a “invoke top-level Maven targets” with a goal fo clean and Maven version of Maven 3.3.3
 
  
 
  -  zxiiro 
    - abhi to work with zxiiro to figure what’s going on with help:effective-pom failing sometimes
 
  
 
  - UNASSIGNED
    - abhi wil change line 39 of his parsar.py script to use that path instead
 
    - abhi to modifiy the jjb file he has to first call maven clean with a maven goal and use maven 3.3.3 so that we get a maven executable to use
 
    - abhi to modify parsar.py and the web scripts to give the new table structure, i.e., (groupId, artifactId) => list ( versions => list of pom files)
 
  
 
People present (lines said)
  - colindixon (42)
 
  - odl_meetbot (4)
 
  - darkdragon (1)
 
  - zxiiro (1)
 
  - abhi_ (0)
 
Generated by MeetBot 0.1.4.