#opendaylight-intern: dependency tracking

Meeting started by colindixon at 12:01:33 UTC (full logs).

Meeting summary

  1. review of last week (colindixon, 12:01:41)
    1. https://meetings.opendaylight.org/opendaylight-intern/2015/dependency_tracking/opendaylight-intern-dependency_tracking.2015-07-20-12.02.html last week’s meeting minutes (colindixon, 12:01:49)
    2. https://trello.com/b/SIRfdRVV/odl-dependency-tracking trello board (colindixon, 12:02:05)
    3. abhishek was able to get the jenkins job from last time running with tolerable errors (colindixon, 12:02:59)
    4. http://54.148.146.38/dnvtools/sidemenu/#version_skew new version skew table (colindixon, 12:03:15)
    5. ACTION: abhi to make it easier to read the table by grouping the common versions (colindixon, 12:04:03)
    6. colindixon notes that we could account for ranges when they include the other people’s version, but that could still be bad because it’s possible version skew in the future (colindixon, 12:05:24)
    7. colindixon asks if we are getting all the effective poms now (colindixon, 12:05:40)
    8. abhi says that he things so now with zxiiro’s help (colindixon, 12:05:54)
    9. we provide a settings.xml file as a variable, and the memory issue was resolved by running in jenkins (colindixon, 12:06:21)
    10. abhi says that he things he’s resolved the issues with projects not depending on odlparent, the only ones left are toaster, reservation, packetcable and docs (colindixon, 12:11:17)
    11. colindixon looks into it: docs does not depent on odlparent, reservation appears to have a parent dependency on odlparent in it’s root pom.xml, packetcable has a dependency on odlparent in features-packetcable/pom.xml and features-packetcable-policy/pom.xml (colindixon, 12:12:59)
    12. tutorial is a made up project in coretutorials, which likely needs to have it’s groupId changed (colindixon, 12:13:41)
    13. ACTION: abhi to look into why packetcable and reservation don’t depend on odlparent in the diagram (colindixon, 12:14:46)
    14. colindixon asks if the Jenkins job is compiled from the YAML file or if it’s locally edited on the sandbox, e.g., will it get blown away on Sunday (colindixon, 12:16:45)
    15. abhi says no, it’s all in the YAML file (colindixon, 12:16:51)
    16. https://gist.github.com/anonymous/38fc0972d6c39de231c0 colindixon asks if we’re avoiding parsing unincluded pom files (colindixon, 12:22:57)
    17. abhi says yes (colindixon, 12:23:03)

  2. future work (colindixon, 12:29:55)
    1. colindixon creates some new action items in the trello board (colindixon, 12:30:41)
    2. colindixon sorts them into the backlog and must have (colindixon, 12:38:11)
    3. ACTION: colindixon to find time on the TWS call to have abhi present his stuff (colindixon, 12:38:24)
    4. ACTION: colindixon to find a place for the web interface stuff to live (colindixon, 12:38:36)
    5. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main the TWS call info is here and it’s at 10a pacific/10:30p india on Mondays (colindixon, 12:39:00)

  3. odlsummit (colindixon, 12:51:32)
    1. it will be good to see everyone on Monday! (colindixon, 12:51:37)


Meeting ended at 12:51:41 UTC (full logs).

Action items

  1. abhi to make it easier to read the table by grouping the common versions
  2. abhi to look into why packetcable and reservation don’t depend on odlparent in the diagram
  3. colindixon to find time on the TWS call to have abhi present his stuff
  4. colindixon to find a place for the web interface stuff to live


Action items, by person

  1. colindixon
    1. colindixon to find time on the TWS call to have abhi present his stuff
    2. colindixon to find a place for the web interface stuff to live
  2. UNASSIGNED
    1. abhi to make it easier to read the table by grouping the common versions
    2. abhi to look into why packetcable and reservation don’t depend on odlparent in the diagram


People present (lines said)

  1. colindixon (28)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.