#opendaylight-intern: dependency tracking

Meeting started by colindixon at 17:01:10 UTC (full logs).

Meeting summary

  1. review of last week’s progress (colindixon, 17:01:22)
    1. https://git.opendaylight.org/gerrit/#/c/25265/ the script under review in github (colindixon, 17:01:55)
    2. https://trello.com/b/SIRfdRVV/odl-dependency-tracking the trello board (colindixon, 17:02:28)
    3. http://54.148.146.38/dnvtools/sidemenu/#version_skew (colindixon, 17:03:44)
    4. abhi_ says that the new code now groups by versions, but it isn’t updated in the hosted place (colindixon, 17:04:15)
    5. https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/10/console abhi_ says that he’s having issues with the maven deploy-file goal (colindixon, 17:05:17)
    6. https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/autorelease/dependencyInfo.json/1.0.0/dependencyInfo.json-1.0.0.json. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1] (colindixon, 17:06:07)
    7. [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy-file (default-cli) on project autorelease-root: Failed to deploy artifacts: Could not transfer artifact org.opendaylight.autorelease:dependencyInfo.json:json:1.0.0 from/to opendaylight-snapshot (https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/): Failed to transfer file: (colindixon, 17:06:31)
    8. https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/autorelease/dependencyInfo.json/1.0.0/dependencyInfo.json-1.0.0.json. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1] (colindixon, 17:06:32)
    9. ACTION: abhi_ to ask zxiiro and/or tykeal about why this would give 401 unauthorized (colindixon, 17:07:00)
    10. maven site deploy is working for abhi_ in his local system, he needs to talk to zxiiro about how to deploy to the LF’s CI maven sites (colindixon, 17:07:41)

  2. planning the next week (colindixon, 17:15:22)
    1. colindixon rearranges things on the trello board, there are 6 tasks that need to be done (colindixon, 17:19:05)
    2. ACTION: abhi_ will create a gerrit patch to merge the HTML/JS into the autorelease project (colindixon, 17:19:35)
    3. ACTION: abhi_ will work with zxiiro to figure out how to deploy the HTML/JS to a maven site in ODL infra (colindixon, 17:20:04)
    4. ACTION: abhi_ will grey out a project when it’s pom file isn’t being parsed (but it’s still in other project’s as a dependency) (colindixon, 17:21:02)
    5. ACTION: abhi_ and zxiiro will get the python script gerrit merged into autorelease (colindixon, 17:21:24)
    6. the above 5 #actions are the critical things (colindixon, 17:21:47)
    7. if we have time, we can also look at the backlog, colindixon will order in terms of his priroties (colindixon, 17:22:11)

  3. demo of mave site (colindixon, 17:27:29)
    1. abhi_ shows that if you look at the last link (timeline) on the maven site it will take you to the version skew page (colindixon, 17:27:58)
    2. for now the resources are coming from abhi_ manually pulling it in (colindixon, 17:28:29)
    3. abhi_ will committ the HTML as part of his gerrit patch(es) (colindixon, 17:30:20)


Meeting ended at 17:30:23 UTC (full logs).

Action items

  1. abhi_ to ask zxiiro and/or tykeal about why this would give 401 unauthorized
  2. abhi_ will create a gerrit patch to merge the HTML/JS into the autorelease project
  3. abhi_ will work with zxiiro to figure out how to deploy the HTML/JS to a maven site in ODL infra
  4. abhi_ will grey out a project when it’s pom file isn’t being parsed (but it’s still in other project’s as a dependency)
  5. abhi_ and zxiiro will get the python script gerrit merged into autorelease


People present (lines said)

  1. colindixon (26)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.