#opendaylight-intern: dependency tracking

Meeting started by colindixon at 17:02:12 UTC (full logs).

Meeting summary

  1. wrap up (colindixon, 17:02:15)
    1. https://git.opendaylight.org/gerrit/#/c/25265/4 we’d like to converget on getting this merged (colindixon, 17:02:33)
    2. we’d like to get the HTML code into git somewhere even if it’s not being deployed by maven sites (colindixon, 17:03:22)
    3. we’d like to see it deployed as a mavent (colindixon, 17:03:24)

  2. getting the parser merged (colindixon, 17:03:32)
    1. zxiiro says he’s willing to just merge it and move to using the xpath APIs (if possible) as an enhancement (colindixon, 17:03:53)
    2. ACTION: zxiiro to merge the patch (colindixon, 17:04:07)

  3. getting the HTML into gerrit (colindixon, 17:04:27)
    1. zxiiro says that right now we should just check the HTML/js into some place with instructions on how to bring it up (colindixon, 17:07:02)
    2. https://github.com/abhishekmittal09/dnvtools/tree/master/sidemenu the current HTML i shere (colindixon, 17:07:26)
    3. colindixon asks where actually loads the data.json (colindixon, 17:08:07)
    4. ACTION: abhi to clean up the js folder ot only have the live code in it (colindixon, 17:08:23)
    5. https://github.com/abhishekmittal09/dnvtools/blob/master/sidemenu/index.html#L20 shows how it’s loading the data.json (colindixon, 17:10:26)
    6. colindixon says we have two options: (1) dynamically generate the HTML so it hard links to the most recent data.json, (2) look for the most recent data.json in nexus so that the HTML is truly static (colindixon, 17:11:06)
    7. ACTION: abhi to submit exactly what he has working with maven sites along with instructions to for zxiiro to get it working (colindixon, 17:11:43)
    8. zxiiro says he’s mildly worried about third party libraries and licensing (colindixon, 17:12:01)
    9. ACTION: abhi to get zxiiro a list of libaries he’s using so that zxiiro can make sure they’re EPL compatible (colindixon, 17:12:26)

  4. (colindixon, 17:14:04)
  5. trello board (colindixon, 17:14:17)
    1. https://trello.com/b/SIRfdRVV/odl-dependency-tracking the trello board (colindixon, 17:14:23)
    2. ACTION: colindixon to update the trello board with the output of this meeting (colindixon, 17:14:37)

  6. style guide for HTML and js/ (colindixon, 17:14:50)
    1. abhi asks if we have a style guide, zxiiro says we don’t but he Drupal’s style guide (colindixon, 17:15:08)
    2. also js should go in a separate js file in a spearate js folder (colindixon, 17:15:25)

  7. TWS presentation (colindixon, 17:16:12)
    1. colindixon asks if zxiiro will be there, he will be (colindixon, 17:16:19)
    2. colindixon will not be there, zxiiro will act as abhi’s wingman if needed (colindixon, 17:17:46)


Meeting ended at 17:17:48 UTC (full logs).

Action items

  1. zxiiro to merge the patch
  2. abhi to clean up the js folder ot only have the live code in it
  3. abhi to submit exactly what he has working with maven sites along with instructions to for zxiiro to get it working
  4. abhi to get zxiiro a list of libaries he’s using so that zxiiro can make sure they’re EPL compatible
  5. colindixon to update the trello board with the output of this meeting


Action items, by person

  1. colindixon
    1. colindixon to update the trello board with the output of this meeting
  2. UNASSIGNED
    1. zxiiro to merge the patch
    2. abhi to clean up the js folder ot only have the live code in it
    3. abhi to submit exactly what he has working with maven sites along with instructions to for zxiiro to get it working
    4. abhi to get zxiiro a list of libaries he’s using so that zxiiro can make sure they’re EPL compatible


People present (lines said)

  1. colindixon (29)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.