#opendaylight-intern: dependency tracking

Meeting started by colindixon at 17:02:06 UTC (full logs).

Meeting summary

  1. status update (colindixon, 17:02:14)
    1. https://git.opendaylight.org/gerrit/#/c/26631/ the web front end for dependency tracking is a patch (colindixon, 17:02:46)
    2. ACTION: abhi to provide the JJB file he was using (colindixon, 17:02:59)

  2. the HTML/js patch (colindixon, 17:07:00)
    1. colindixon asks if there’s a best practice for important third-party javascript (colindixon, 17:07:04)
    2. zxiiro and abhi say that normally you import from the CDN URL so that you don’t replicate the code in your repo (colindixon, 17:07:08)
    3. another trick which zxiiro uses for projects that don’t have a CDN is to load them as a git submodule from their git repo (colindixon, 17:07:12)

  3. the JJB file (colindixon, 17:07:21)
    1. right now master is broken, but it works a stable/lithium (colindixon, 17:07:37)
    2. zxiiro says to submit it to either one (but only one) for now and it will be cherry-picked after merging (colindixon, 17:09:02)

  4. maven site files (colindixon, 17:09:33)
    1. zxiiro says that once he gets through the maven site stuff, he’ll probably have to change the maven site file here, but for now it’s fine (colindixon, 17:09:49)

  5. back to the JJB file (colindixon, 17:11:05)
    1. it should be sumbitted to releng/builder in the jjb/autorelease folder (colindixon, 17:11:37)
    2. abhi asks about where the variables in JJB jobs come from (colindixon, 17:12:08)
    3. zxiiro says they come from a few different places, the maven settings (and version) come from the jjb/releng-defaults.yaml file in releng/builder (colindixon, 17:13:51)
    4. https://github.com/opendaylight/releng-builder/blob/74518c806171a73a6a9282cb9dea37c6c2cff252/jjb/releng-defaults.yaml here’s that file (colindixon, 17:13:58)
    5. for other things like project and branch they come from how the jobs are triggered and or the templates including stream (colindixon, 17:14:12)
    6. https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-macros.yaml the global macros are here which are used to help with things (colindixon, 17:16:24)

  6. review of progress (colindixon, 18:03:18)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Controller-Cluster_Deployment radhika did some edits here (colindixon, 18:04:15)
    2. radhika says that the chose to leave in OpenFlow because that’s what people care (colindixon, 18:10:48)
    3. ACTION: radhika to find a guinea pig to use these instructions (colindixon, 18:11:18)
    4. colindixon notes that coverign openflow is fine, but it doesn’t work right now, so we just need to figure out what the audience is: Lithium users, Beryllium users, or something else (colindixon, 18:12:25)
    5. https://wiki.opendaylight.org/view/OpenDaylight_Controller radhika has listed understanding MD-SAL thin things you need to read (colindixon, 18:13:22)

  7. action items (colindixon, 18:23:01)
    1. reviewing action items from Radhika’s e-mail (colindixon, 18:23:36)
    2. she feels like he clustering deployment wiki is pretty much done (colindixon, 18:23:58)
    3. she feels like all the MD-SAL arch and clustering docs are aggregated on the clustering main page (colindixon, 18:24:15)
    4. ACTION: radhika to provide links to the applciation tutotials as well on the clustering main page (colindixon, 18:24:35)
    5. ACTION: wiki gardening for clustering related documents (colindixon, 18:25:17)
    6. ACTION: covert clustering wiki documentats to asciidoc (colindixon, 18:25:27)
    7. https://meetings.opendaylight.org/opendaylight-intern/ (colindixon, 18:26:53)


Meeting ended at 18:06:25 UTC (full logs).

Action items

  1. abhi to provide the JJB file he was using
  2. radhika to find a guinea pig to use these instructions
  3. radhika to provide links to the applciation tutotials as well on the clustering main page
  4. wiki gardening for clustering related documents
  5. covert clustering wiki documentats to asciidoc


People present (lines said)

  1. colindixon (43)
  2. odl_meetbot (8)


Generated by MeetBot 0.1.4.