#opendaylight-meeting: 6/26/2014 TSC

Meeting started by regXboi at 16:57:25 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:57:39)

  1. TSC members please #info in (regXboi, 16:58:01)
    1. regXboi (regXboi, 16:58:08)
    2. https://wiki.opendaylight.org/view/TSC:Main (dmm, 17:00:28)
    3. https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB - webex link (edwarnicke, 17:01:14)
    4. Kent Watsen (kw_, 17:02:26)
    5. Ed Warnicke (edwarnicke, 17:03:06)
    6. Chris Price Joined (ChrisPriceAB, 17:03:34)
    7. no phil today - recording started (regXboi, 17:03:40)

  2. creation review : TCP-MD5 (regXboi, 17:05:11)
    1. delaying this to next week to ensure the two week period (regXboi, 17:05:40)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2014-June/000145.html (regXboi, 17:05:53)
    3. Rob Dolin proxy for Rajeev Nagar (MSFT) (RobDolin, 17:06:04)
    4. above link is TCP-MD5 email to project-proposals list (regXboi, 17:06:17)

  3. scala discussion (regXboi, 17:06:37)
    1. https://lists.opendaylight.org/pipermail/project-proposals/2014-June/000145.html (regXboi, 17:06:45)
    2. https://lists.opendaylight.org/pipermail/discuss/2014-June/002695.html (regXboi, 17:07:07)
    3. https://lists.opendaylight.org/pipermail/discuss/2014-June/002880.html (regXboi, 17:07:14)
    4. links are start of use of scala discussion (regXboi, 17:07:45)
    5. the people looking to use Akka to build clustering originally wanted to use Scala to provide the clustering (as Akka is written in Scala) and they asked if that would be OK (colindixon, 17:08:29)
    6. https://lists.opendaylight.org/pipermail/discuss/2014-June/002880.html - comprimise (edwarnicke, 17:08:46)
    7. question about how to capture a community decision (regXboi, 17:11:52)
    8. that is ... the scala discussion comes to a question about how to capture a community decision (regXboi, 17:12:31)
    9. other examples of recording policy include: (a) checkstyle policy, e.g., trailing whitespace and (b) branching policy (colindixon, 17:12:57)
    10. colindixon thinks it is a good idea to have some way of recording decisions (regXboi, 17:13:09)
    11. edwarnicke talks about a possibility of using branching (regXboi, 17:13:27)
    12. kwatsen suggests a current project status wiki page (regXboi, 17:14:19)
    13. dlenrow points out that some projects are updating the project proposal page and that should be discouraged (regXboi, 17:14:42)
    14. edwarnicke agrees that updating the project proposal page isn't a good thing (regXboi, 17:15:09)
    15. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group example of the facts sidebox (colindixon, 17:16:24)
    16. ACTION: colindixon to make the project "facts box" a wiki template (regXboi, 17:17:17)

  4. TSC Charter Update (regXboi, 17:20:59)
    1. there is some more discussion about how to keep the actual list of projects synchronized over the varioius places they are listed, e.g., the main page, the helium release page, etc. (colindixon, 17:21:23)
    2. there is hope that having a template would help automate this assuming we make sure people us the template (the last two lines belong in the previous topic) (colindixon, 17:21:59)
    3. https://lists.opendaylight.org/pipermail/tsc/2014-June/001309.html (regXboi, 17:26:20)
    4. 0 means abstain (edwarnicke, 17:27:56)
    5. 1 means option 1 (edwarnicke, 17:28:00)
    6. 2 means option 2 (edwarnicke, 17:28:04)
    7. dlenrow votes 1 (regXboi, 17:28:51)
    8. VOTE: Voted on "which charter language proposal to take to the board?" Results are, 1: 4, 2: 1 (regXboi, 17:28:56)
    9. RobDolin also voted 1 (regXboi, 17:29:08)
    10. total (due to #infos) were option 1: 6, option 2: 1 (regXboi, 17:29:25)
    11. AGREED: send proposal #1 to board (regXboi, 17:29:40)
    12. question: should both charter and bylaws be modified? (regXboi, 17:30:07)
    13. answer: the vote above only covers the charter (regXboi, 17:30:31)
    14. AGREED: to take the charter language modifications to the board with the recommendation that the by-laws be modified in accordance with the charter modifications and intent (regXboi, 17:35:16)
    15. ACTION: kwatsen to send dmm fully-updated charter/bylaw docs (kw_, 17:36:25)
    16. Lenrow (lenrow, 17:36:49)

  5. helium packaging (regXboi, 17:37:18)
    1. pen is turned over to sombody (edwarnicke, 17:37:44)
    2. return to topic of discussing ‘pure karaf’ (icbts, 17:41:44)
    3. unclear how much will be accomplished based on the "swiss cheese" of next week (regXboi, 17:43:22)
    4. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Upcoming_Meeting_Agendas future topics for TWS calls are listed here (colindixon, 17:43:26)
    5. this might be one such topic (colindixon, 17:43:33)

  6. helium status issues (regXboi, 17:43:40)
    1. proposal to have a mailling list other than discuss for release email so that projects don't have to sort through on discuss (regXboi, 17:47:10)
    2. I am favor of a single release list (edwarnicke, 17:49:25)
    3. no disagreement with a single release list (regXboi, 17:51:24)
    4. HP will present our OF1.3 plugin architecture/implementation and demo it running on ODL on Monday TWS Call (lenrow, 17:51:29)
    5. ACTION: tykeal to create a single release list (regXboi, 17:52:37)
    6. ACTION: correction, regXboi to send email for creation of single release list to helpdesk (regXboi, 17:53:17)

  7. it managed repository section in gerrit for holding sub-repositories (regXboi, 17:53:53)
    1. there have been requests for infrastructure pieces like Puppet, Jenkins Job builder, etc. (regXboi, 17:54:25)
    2. request for a repository for holding this information with andy and aric as primary contacts (regXboi, 17:55:56)
    3. proposal from edwarnicke to have this be a project (regXboi, 17:56:40)
    4. tykeal considered that approach, but his thinking was that the outputs of this effort wouldn't be released as other projects released (regXboi, 17:57:48)
    5. more discussion about licensing (regXboi, 17:59:44)
    6. recommendation to tykeal to bring the idea to the mailing list along with a minimal form as an example (regXboi, 18:02:40)
    7. last note: US 0-1 GER, POR 2-1 GHANA (regXboi, 18:03:10)


Meeting ended at 18:03:17 UTC (full logs).

Action items

  1. colindixon to make the project "facts box" a wiki template
  2. kwatsen to send dmm fully-updated charter/bylaw docs
  3. tykeal to create a single release list
  4. correction, regXboi to send email for creation of single release list to helpdesk


Action items, by person

  1. colindixon
    1. colindixon to make the project "facts box" a wiki template
  2. dmm
    1. kwatsen to send dmm fully-updated charter/bylaw docs
  3. regXboi
    1. correction, regXboi to send email for creation of single release list to helpdesk
  4. tykeal
    1. tykeal to create a single release list


People present (lines said)

  1. regXboi (61)
  2. colindixon (13)
  3. edwarnicke (11)
  4. odl_meetbot (10)
  5. tykeal (7)
  6. dbainbri (6)
  7. dmm (5)
  8. RobDolin (5)
  9. tbachman (3)
  10. kw_ (3)
  11. lenrow (2)
  12. icbts (2)
  13. ChrisPriceAB (2)


Generated by MeetBot 0.1.4.