#opendaylight-meeting: Helium M5 developer meeting

Meeting started by phrobb at 15:31:33 UTC (full logs).

Meeting summary

  1. Project Contacts please #info in (phrobb, 15:32:00)
    1. edwarnicke controller (edwarnicke, 15:32:06)
    2. tbachman for Group Based Policy (tbachman, 15:32:18)
    3. Hideyuki for VTN (hideyuki, 15:32:23)
    4. rafat ODL-SDNi App (rafat, 15:32:26)
    5. oflibMichal (oflibMichal1, 15:32:28)
    6. paulq for SFC (paulq, 15:32:34)
    7. oflibMichal for openflowjava (oflibMichal1, 15:32:44)
    8. Dana for bgpcep (dkutenic, 15:33:14)
    9. regXboi for nobody... so I can hold the pen if need be (I can't believe I just volunteered for that) (regXboi, 15:34:06)
    10. Madhu (Madhu, 15:34:13)
    11. George Zhao for release (gzhao, 15:34:14)
    12. goldavberg for lispflowmapping (goldavberg, 15:34:32)
    13. ttkacik for Yangtools (ttkacik, 15:35:11)
    14. CASP3R for Integration (CASP3R, 15:35:48)
    15. abhijitkumbhare for OpenFlow plugin (abhijitkumbhare, 15:36:46)
    16. liemmn for AAA (liemmn, 15:38:25)
    17. catohornet also for integration (catohornet, 15:38:32)
    18. mlemay for reservation (mlemay, 15:39:01)
    19. tbachman opflex (tbachman_, 15:40:21)

  2. Status (phrobb, 15:42:21)
    1. for southbound plugin to OpenContrail platform (priyanka, 15:42:22)
    2. appear to be missing defense4all, l2switch, pcmm, snb-i snmp4sdn, tabletypepatterns and toolkit (regXboi, 15:42:43)
    3. here from dlux project (harman_, 15:43:45)
    4. Let's start with the Code Freeze requirement of M5. This should mean that no new features should be allowed by the committers starting on Monday. Only errors/bugs that are also identified in bugzilla are allowed from Monday forward. Is this an agreeable definition to the group and are there any projects that do not feel they can meet that requirement? (phrobb, 15:44:39)
    5. rovarga for tcpmd5 (rovarga, 15:45:56)
    6. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide Please read this and follow it through to get your project features into integration (edwarnicke, 16:01:20)
    7. If you need help, Karaf Happy Hour is 7:30am PST every morning this week on #opendaylight-meeting (edwarnicke, 16:01:37)
    8. https://jenkins.opendaylight.org/integration/job/integration-master-csit-karaf-of13/4/robot/report/report.html (CASP3R, 16:03:25)
    9. https://git.opendaylight.org/gerrit/gitweb?p=integration.git;a=blob;f=features/src/main/resources/features.xml;h=e20c8dc750dfc53213ffcca4b003e9d3bdf225c9;hb=HEAD <- integration features file, with instructions :) (edwarnicke, 16:15:11)
    10. https://jenkins.opendaylight.org/integration/job/integration-master-csit-karaf-of13/4/robot/report/report.html (CASP3R, 16:17:14)
    11. Thomas Kee PacketCable PCMM (xsited, 16:19:59)
    12. https://wiki.opendaylight.org/view/Logging_Best_Practices <- Logging Best Practices (edwarnicke, 16:39:10)
    13. AGREED: Code Freeze means that no new features/functionality are to be allowed into the Helium code base.  Only errors/bugs identified in the bugzilla system should be allowed.  The exceptions to this include new tests, and documentation.  Packaging, ie Karaf packaging must be completed by M5.  Errors/bugs found post M5 are still bugs and they may be created and worked on post M5. This includes packaging bugs found as (phrobb, 16:41:08)
    14. https://git.opendaylight.org/gerrit/#/c/10345/ <- BGP features patch for integration (edwarnicke, 16:52:37)
    15. Docs are a very lagging activity… project contacts need to engage with the docs team on both transitioning existing wiki docs from hydrogen to helium asciidoc and also filling in all the new content.. and of course this is tied to the karaf features defined for each project… (phrobb, 16:56:50)


Meeting ended at 17:08:03 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. Madhu (165)
  2. edwarnicke (154)
  3. phrobb (68)
  4. tbachman (60)
  5. mlemay (48)
  6. regXboi (41)
  7. gzhao (25)
  8. abhijitkumbhare (19)
  9. CASP3R (14)
  10. tbachman_ (8)
  11. catohornet (5)
  12. odl_meetbot (4)
  13. hideyuki (4)
  14. paulq (4)
  15. xsited (2)
  16. liemmn (2)
  17. oflibMichal1 (2)
  18. dkutenic (2)
  19. rafat (1)
  20. dfarrell07 (1)
  21. evanz (1)
  22. ttkacik (1)
  23. rovarga (1)
  24. goldavberg (1)
  25. tykeal (1)
  26. amit_mandke (1)
  27. priyanka (1)
  28. harman_ (1)


Generated by MeetBot 0.1.4.