#opendaylight-meeting: Helium Pre-RC0 meeting

Meeting started by colindixon at 17:01:38 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:01:44)
    1. edwarnicke (edwarnicke, 17:02:00)
    2. tbachman for Group Based Policy (tbachman, 17:02:33)
    3. gzhao for release (gzhao, 17:02:36)
    4. colindixon for TTP (colindixon, 17:02:40)
    5. Hideyuki Tai for VTN (hideyuki, 17:03:02)
    6. sorry for the short notice on this meeting folks. I will send out another invitation for a pre RC0/RC1 meeting for this Wednesday at 8:30am PT shortly after we adjourn here… (phrobb, 17:04:21)
    7. abhijitkumbhare for OpenFlow plugin (looks like the meeting going to be on Wednesday) (abhijitkumbhare, 17:05:32)

  2. karaf/autorelease update (colindixon, 17:05:56)
    1. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1991333031 <- gzhao 's wonderful tracking spreadsheet for autorelease (edwarnicke, 17:06:08)
    2. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=638121282 <- gzhao 's wonderful tracking spreadsheet for karaf (edwarnicke, 17:06:30)
    3. Karaf last update 9/7/2014 6:00 pm PST (gzhao, 17:07:04)
    4. 16 project done and integrated, 3 WIP and 1 red (gzhao, 17:07:41)
    5. ACTION: gzhao will follow up snmp4sdn for Karaf (gzhao, 17:09:21)
    6. we have 5 projects that we need to follow up with about karaf: sdni, reservation, plugin2oc, defense4all, and smp4sdn (colindixon, 17:12:45)
    7. I think it would be worthwhile to define what we all mean by "Release Candidate" similar to how we defined "Code Freeze" as part of the M5 meeting. Does that sound like a worthwhile activity to those here? (phrobb, 17:14:00)

  3. defining RC0 (colindixon, 17:16:36)
    1. colindixon proposes that what defines an RC vs. the previous milestones is that it is the result of a run of the auto-release scripts that assigns a single version, e.g., helium-rc0, to all the artifacts so that a specific stable version can be built and tested across *all* the projects (colindixon, 17:18:00)
    2. gzhao and edwarnicke largely agree (colindixon, 17:18:07)
    3. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1991333031 <- current verified state of autorelease (edwarnicke, 17:18:59)
    4. Thomas for packetcable (xsited1, 17:20:10)
    5. phrobb asks how the RCs interact with code freeze (colindixon, 17:20:56)
    6. abhijitkumbhare asks about what should be accomplished for the different RCs (colindixon, 17:23:30)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Schedule this doens’t say anything specific about goals for each RC other than projects have to hold release reviews for RC2 (colindixon, 17:24:05)
    8. hideyuki mentioned there are artifacts out of Karaf distro. e.g VTN coordinator, opflex (gzhao, 17:30:16)
    9. phrobb says he’d been thinking of RCs in a more traditional sense, where it was really code that could be released, is then tested and the ship-blocking bugs are fixed resulting in the next RC (colindixon, 17:32:23)
    10. abhijitkumbhare proposes some ideas for goals around RCs: (colindixon, 17:33:40)
    11. RC0 is getting a full build of all (or at least the vast majority) of the artifacts by auto-release (colindixon, 17:33:44)
    12. RC1 is incorporating testing and bug fixing for all (or at leas the vast majority) of the projects which others depend on  (colindixon, 17:34:11)
    13. RC2 is a full testing and bug fixing patch before the release (colindixon, 17:34:58)
    14. the above is a proposal from abhijitkumbhare, not agreed upon (colindixon, 17:35:13)
    15. edwarnicke proposes to focus on RC0 for right now, once we cut artifacts we can decide how to move forward (colindixon, 17:36:34)

  4. getting RC0 out the door (colindixon, 17:38:00)
    1. as I understand it, this is really getting the auto-release to work for all participating projects (colindixon, 17:38:31)
    2. ToolKit is N/A for Karaf and code freeze. - Madhu (gzhao, 17:42:19)
    3. edwarnicke Madhu added Toolkit code freeze is not release perse (gzhao, 17:43:20)
    4. ACTION: colindixon and Madhu to follow up with Andrew Kim to make sure that we can actually remove toolkit from the helium release or figure out a better plan by the next pre-RC meeting (colindixon, 17:46:08)
    5. aside from helpdesk tickets which have been fixed and should get most of the currently blocked projects out, we are only missing toolkit and defense4all from auto-release (colindixon, 17:50:02)
    6. the current plan is for toolkit to not take part in auto-release (colindixon, 17:50:13)
    7. ACTION: gzhao Request Defense4All to check code in https://git.opendaylight.org/gerrit/ (gzhao, 17:50:33)
    8. gzhao is working with defense4all to get their code in so we can auto-release them (colindixon, 17:50:34)
    9. other than that, we have some projects listed as “not in karaf”: snmp4sdn, plugin2oc, reservation, and sdni (also def4a) (colindixon, 17:51:22)
    10. edwarnicke notes that he’s been making auto-release work mostly by using the build part of projects’ merge jobs (colindixon, 17:53:59)
    11. however, SNMP4SDN doesn’t run tests in their merge job (colindixon, 17:54:14)
    12. gzhao requested eadd old_meetbot for #opendaylight-release for release or future release purpose, wiki updated (gzhao, 17:55:12)

  5. wrapping up (colindixon, 17:59:25)
    1. we still need to work out getting all projects into the auto-release and whether/if we can include projects that should/will be using karaf, but aren’t yet (colindixon, 17:59:51)
    2. we need to work out what to do with projects that are still missign/unable to hit code freeze and/or karaf bundling and when we should do it (colindixon, 18:00:20)
    3. these and other topics will have to wait for the wednesday pre-RC meeting and/or the thursday TSC meeting (colindixon, 18:00:40)
    4. Phil: Putting together what we have, and testing it with whatever tests we have available now makes sense to me… regardless of what we call it. (gzhao, 18:00:43)
    5. ACTION: hideyuki to reach out to the defense4all people to help them with karaf (thanks a million) (colindixon, 18:01:11)


Meeting ended at 18:01:51 UTC (full logs).

Action items

  1. gzhao will follow up snmp4sdn for Karaf
  2. colindixon and Madhu to follow up with Andrew Kim to make sure that we can actually remove toolkit from the helium release or figure out a better plan by the next pre-RC meeting
  3. gzhao Request Defense4All to check code in https://git.opendaylight.org/gerrit/
  4. hideyuki to reach out to the defense4all people to help them with karaf (thanks a million)


Action items, by person

  1. colindixon
    1. colindixon and Madhu to follow up with Andrew Kim to make sure that we can actually remove toolkit from the helium release or figure out a better plan by the next pre-RC meeting
  2. gzhao
    1. gzhao will follow up snmp4sdn for Karaf
    2. gzhao Request Defense4All to check code in https://git.opendaylight.org/gerrit/
  3. hideyuki
    1. hideyuki to reach out to the defense4all people to help them with karaf (thanks a million)
  4. Madhu
    1. colindixon and Madhu to follow up with Andrew Kim to make sure that we can actually remove toolkit from the helium release or figure out a better plan by the next pre-RC meeting


People present (lines said)

  1. colindixon (122)
  2. edwarnicke (72)
  3. gzhao (43)
  4. phrobb (16)
  5. Madhu (13)
  6. abhijitkumbhare (11)
  7. odl_meetbot (8)
  8. frankieonuonga (7)
  9. tbachman (6)
  10. hideyuki (3)
  11. xsited1 (2)
  12. LuisGomez (2)
  13. repenno (1)


Generated by MeetBot 0.1.4.