#opendaylight-meeting: Helium Pre RC0/RC1

Meeting started by phrobb at 15:30:34 UTC (full logs).

Meeting summary

  1. Roll Call (phrobb, 15:30:52)
    1. davidg for lispflowmapping (goldavberg, 15:30:55)
    2. colindixon for TTP (and mischeif) (colindixon, 15:31:01)
    3. edwarnicke (edwarnicke, 15:31:01)
    4. tbachman for Group Based Policy (tbachman, 15:31:02)
    5. gzhao (gzhao, 15:31:06)
    6. abhijitkumbhare OpenFlow Plugin (abhijitkumbhare, 15:31:09)
    7. regXboi for nothing in particular (regXboi, 15:31:20)
    8. rafat for sdni (Rafat, 15:31:20)
    9. oflibMichal for openflowjava (oflibMichal, 15:31:21)
    10. ChristineH for SNMP4SDN (ChristineH, 15:31:24)
    11. Dana for bgpcep (dkutenic, 15:31:34)
    12. rovarga for tcpmd5 and yangtools (rovarga, 15:32:00)
    13. deepankar for plugin2oc (deepankar, 15:32:09)
    14. for reservation (mlemay, 15:32:57)
    15. mlemayfor reservation (mlemay, 15:33:03)
    16. LuisGomez for integration (LuisGomez, 15:34:43)
    17. madhu for OVSDB (Madhu, 15:36:44)
    18. ACTION: colindixon to add a row in the table for TCPMD5 and remove toolkit (colindixon, 15:37:05)
    19. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects (colindixon, 15:37:21)
    20. paulq for SFC (paulq, 15:38:42)
    21. : https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects wiki page describing helium status (tbachman, 15:38:57)

  2. Status update on RC0 creation (phrobb, 15:41:18)
    1. edwarnicke would you mind providing an update on RC0 creation? (phrobb, 15:41:41)
    2. https://lists.opendaylight.org/pipermail/release/2014-September/000352.html <- RC0 announcement (edwarnicke, 15:43:12)
    3. RC0 went out yesterday on time. We are now back on schedule. (edwarnicke, 15:43:26)
    4. http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC0/ (edwarnicke, 15:43:40)
    5. liemmn for AAA (liemmn, 15:45:28)
    6. Thomas packetcable (xsited1, 15:45:32)
    7. Hideyuki Tai for VTN (hideyuki, 15:45:50)
    8. Harman for dlux (harman_, 15:46:55)
    9. ACTION: colindixon to also note that opflex has withdrawn (colindixon, 15:47:27)
    10. ACTION: gzhao change RC build to every 4 hours (gzhao, 15:49:25)
    11. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Proposed_Release_Vehicles <-- This needs to be updated as well (gzhao, 15:56:21)
    12. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-07-31-16.59.log.html TSC minutes, where release vehicles are discussed (tbachman, 16:00:27)
    13. dmm says we should start a thread on discuss or TSC to drive this forward so that we can make a decision about helium packaging next week (tbachman, 16:01:49)
    14. phrobb notes that we have an RC0 drop (which isn’t what he and some others would call a release candidate as not all projects have code frozen or gotten karaf working) (colindixon, 16:01:54)
    15. phrobb says however, we have artifacts that can now start to be tested (colindixon, 16:02:07)
    16. MAJOR: it appears as though we agreed karaf should be the framework if at all possible, we did not agree on actual release vehicles and need to do that ASAP (colindixon, 16:02:55)
    17. ACTION: phrobb to add RV discussion to TSC meeting for tomorrow (9/11) (phrobb, 16:03:30)
    18. hideyuki's point about RC0 missing VTN components means there will be an RC1 (regXboi, 16:04:30)
    19. Please test with RC0 and make sure your karaf features work (edwarnicke, 16:06:13)
    20. edwarnicke RC steps; 1) build every 4 hour 2) publish nightly (gzhao, 16:06:30)

  3. next steps with RC0 (colindixon, 16:08:00)
    1. edwarnicke calls for people to please make use of the RC0 artifacts and test what they have (colindixon, 16:08:34)
    2. LuisGomez says 1) every project is responsible to test their indivdual features (phrobb, 16:09:19)
    3. http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC0/ the karaf RC0 distribution zip can be found here (colindixon, 16:10:01)
    4. LuisGomez says: 2) integration will put all features together and pass existing suites from hydrogen + new contributions for helium (phrobb, 16:10:26)
    5. you should be able to download the zip file, extract it and run it as you would any other karaf distribution (that is run target/assembly/bin/karaf) (colindixon, 16:10:55)
    6. from there load/test your features as normal (colindixon, 16:11:08)
    7. LuisGomez says 3) integration suites as of today: AD-SAL and MD-SAL NSF, openflow, vtn, l2switch, performance, ovsdb-neutron (in progress) (colindixon, 16:12:32)
    8. ACTION: gzhao to send out a request for an RC1 status update that should include at least “(i) have you tested yourself in the RC0 karaf distro (yes/no) (ii) did you find any bugs? if so, list them. if you have patches, list them.” (colindixon, 16:17:26)
    9. jmedved asks if we need to create a version in bugzilla for Helium-RC0 now that it exists as a release version (colindixon, 16:18:09)
    10. ACTION: colindixon to produce very short pointers about how a project should test their stuff in the RC0 karaf distribution (mostly pointing to the karaf step by step guide) (colindixon, 16:20:47)

  4. Preparation for RC1 - Monday Sept 15th (phrobb, 16:20:55)
    1. as noted above, all projects need to send out a status update e-mail (request and template to come from gzhao) by the RC1 date (colindixon, 16:21:31)
    2. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Guidance_for_testers_once_your_Feature_is_in_Integration (dkutenic, 16:22:09)
    3. We have some projects that have not code-frozen and other projects that have not finished their Karaf feature work and pushed it to Integration. Can we agree that for RC1 we need both of those tasks completed for all projects to have a valid RC1 candidate? (phrobb, 16:22:46)
    4. the goal for RC1 should also be for all projects that are in karaf in RC0 to identify and fix all blocking bugs (or all that they can) for RC1 (colindixon, 16:24:28)
    5. everyone who expressed an opinion (colindixon, abhijitkumbhare, and LuisGomez) agreed with phil’s request that everyone be code frozen and in karaf by RC1 and we will take that idea to the TSC where they can bless it and maybe establish what the consequences for missing are (colindixon, 16:27:32)
    6. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_RC0 <- Do these help in figuring out how to test RC0 ? (edwarnicke, 16:30:11)
    7. gzhao asks “will integration use rc0-timestamp to test? or will they just use RC0, until RC1 is cut?” (colindixon, 16:30:47)
    8. Another question in preparation for RC1: Given that everyone is testing RC0 and (hopefully) finding bugs, should we start a standing, daily irc meeting at 8:30am PDT to report issues, ask questions, etc. from now until we ship? (phrobb, 16:31:53)
    9. the plan is to have post-RC0, pre-RC1 versions to be either “-RC0-<minor>-YYYYMMDD-HHMM” or “RC0-YYYYMMDD-HHMM” if the first is hard (colindixon, 16:37:18)

  5. wrapping up (colindixon, 16:37:39)
    1. What other topics do we have for this morning? (phrobb, 16:37:44)
    2. phrobb proposed daily candence mtgs to allow projects to "check in" on IRC at 7:30am PDT daily starting 9/11 through Helium Final Release (phrobb, 16:40:21)


Meeting ended at 16:41:36 UTC (full logs).

Action items

  1. colindixon to add a row in the table for TCPMD5 and remove toolkit
  2. colindixon to also note that opflex has withdrawn
  3. gzhao change RC build to every 4 hours
  4. phrobb to add RV discussion to TSC meeting for tomorrow (9/11)
  5. gzhao to send out a request for an RC1 status update that should include at least “(i) have you tested yourself in the RC0 karaf distro (yes/no) (ii) did you find any bugs? if so, list them. if you have patches, list them.”
  6. colindixon to produce very short pointers about how a project should test their stuff in the RC0 karaf distribution (mostly pointing to the karaf step by step guide)


Action items, by person

  1. colindixon
    1. colindixon to add a row in the table for TCPMD5 and remove toolkit
    2. colindixon to also note that opflex has withdrawn
    3. colindixon to produce very short pointers about how a project should test their stuff in the RC0 karaf distribution (mostly pointing to the karaf step by step guide)
  2. gzhao
    1. gzhao change RC build to every 4 hours
    2. gzhao to send out a request for an RC1 status update that should include at least “(i) have you tested yourself in the RC0 karaf distro (yes/no) (ii) did you find any bugs? if so, list them. if you have patches, list them.”
  3. phrobb
    1. phrobb to add RV discussion to TSC meeting for tomorrow (9/11)


People present (lines said)

  1. colindixon (106)
  2. edwarnicke (80)
  3. phrobb (41)
  4. regXboi (32)
  5. tbachman (32)
  6. Madhu (29)
  7. gzhao (21)
  8. abhijitkumbhare (15)
  9. LuisGomez (14)
  10. mlemay (14)
  11. rovarga (9)
  12. lori (6)
  13. jmedved (6)
  14. odl_meetbot (4)
  15. dkutenic (4)
  16. deepankar (4)
  17. hideyuki (3)
  18. liemmn (3)
  19. harman_ (3)
  20. xsited1 (2)
  21. Rafat (2)
  22. alagalah (2)
  23. paulq (1)
  24. oflibMichal (1)
  25. kwatsen (1)
  26. goldavberg (1)
  27. PriyankaChopra (1)
  28. dmm (1)
  29. ChristineH (1)


Generated by MeetBot 0.1.4.