#opendaylight-meeting: Helium Release Review

Meeting started by gzhao at 14:31:38 UTC (full logs).

Meeting summary

  1. roll call (gzhao, 14:31:50)
    1. gzhao for release (gzhao, 14:32:05)
    2. Rafat and Radhika for SDNi (Rafat, 14:32:09)
    3. Hideyuki for VTN (hideyuki, 14:32:10)
    4. colindixon for, you know, things (colindixon, 14:32:23)
    5. edwarnicke for everything (edwarnicke, 14:32:32)
    6. tbachman for groupbasedpolicy (tbachman, 14:32:41)
    7. regXboi for mischief, gadflyness, and general mayhem (regXboi, 14:33:26)
    8. Phil Robb (phrobb, 14:33:34)
    9. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=972372068 the schedule for today (and yesterday) (colindixon, 14:34:51)

  2. SDNi (colindixon, 14:35:23)
    1. https://wiki.opendaylight.org/view/ODL-SDNiApp:Release_Review (colindixon, 14:35:30)
    2. https://wiki.opendaylight.org/view/ODL-SDNi_App:Helium_Release_Notes (colindixon, 14:35:36)
    3. while this isn't on the specific release agenda, can you all fix your Jenkin's merge job? (regXboi, 14:36:17)
    4. ACTION: Rafat to migrate SDNi docs from the wiki to asciidoc (or at least put a hyperlink from the asciidoc to the appropriate wiki pages) (colindixon, 14:37:04)
    5. https://git.opendaylight.org/gerrit/#/c/11560/ (colindixon, 14:38:06)
    6. question on the jenkins merge job (regXboi, 14:39:40)
    7. how is origin/$GERRIT_BRANCH getting resolved? (regXboi, 14:40:06)
    8. regXboi satisfied sdni has a valid verify job (regXboi, 14:47:19)
    9. https://jenkins.opendaylight.org/yangtools/job/yangtools-merge/configure works just fine and works correctly with multiple branches (just make sure you have your versions right) (rovarga, 14:47:20)
    10. regXboi satisfied sdni has a valid merge job (regXboi, 14:48:03)

  3. VTN (colindixon, 14:48:05)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Helium_Release_Notes (hideyuki, 14:48:33)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Helium_Release_Review (hideyuki, 14:48:37)
    3. VTN's merge job is hardcoded to origin/master - it's fine (regXboi, 14:49:06)
    4. ACTION: hideyuki to move VTN’s wiki docs to asciidoc (or at least put links to the right wiki pages in) (colindixon, 14:50:47)
    5. hideyuki notes that but 2074 is a show-stopper bug for him, it’s being worked on (colindixon, 14:57:51)
    6. ACTION: colindixon to add show stopping bugs after 2058 to the spreadsheet (colindixon, 14:59:18)

  4. TTP (colindixon, 15:00:20)
    1. https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Review (colindixon, 15:00:36)
    2. https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes (colindixon, 15:00:41)
    3. https://jenkins.opendaylight.org/ttp/job/ttp-merge/configure specifies origin/master under “Branches to build” (colindixon, 15:01:42)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches colindixon notes that the cutting stable branches instructions are what actually talks about doing this for the merge job (colindixon, 15:02:32)
    5. regXboi thanks TTP for the gerrit asciidoc commit :) (regXboi, 15:03:12)
    6. ACTION: colindixon to fix the jenkins merge instructions for new projects to only build origin/master (colindixon, 15:03:37)
    7. https://git.opendaylight.org/gerrit/#/c/11560/ gerrit for docs in asciidoc (colindixon, 15:03:55)

  5. dLux (colindixon, 15:04:59)
    1. here for dlux (harman_, 15:05:12)
    2. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Helium_Release_Review (harman_, 15:05:25)
    3. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Helium_Release_Review (colindixon, 15:05:30)
    4. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Release_Notes_Helium (harman_, 15:05:37)
    5. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Release_Notes_Helium (colindixon, 15:05:48)
    6. dlux-merge has origin/master - that's good (regXboi, 15:05:54)
    7. https://git.opendaylight.org/gerrit/#/c/11562/ dev ascii doc commit (regXboi, 15:06:49)
    8. ACTION: gzhao to move 2011 from to be verified to fixed (colindixon, 15:09:39)
    9. ACTION: harman_ to add some description of the requirements to run and develop for dlux to the rlease notes (I know it’s different than other projects) (colindixon, 15:10:36)
    10. quesiton: who maintains https://jenkins.opendaylight.org/? (regXboi, 15:12:14)

  6. docs (colindixon, 15:13:59)
    1. ACTION: regXboi to open help ticket with LF to update https://jenkins.opendaylight.org/ to list all ODL jenkins job there (after release) (regXboi, 15:14:05)
    2. docs uses parameterized merge job with parameter set to master - that's ok :) (regXboi, 15:14:34)
    3. it appear as though nobody is here for docs (colindixon, 15:15:55)
    4. ACTION: gzhao and phrobb to figure out if we can do a release review for docs at a different time (colindixon, 15:16:10)

  7. integration (colindixon, 15:18:32)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Helium_Release_Review (LuisGomez, 15:18:57)
    2. ACTION: : we should instruct folks to be on the channel 10 minutes early in case we run ahead... (regXboi, 15:19:25)
    3. colindixon notes that while the docs are all in the wiki, it seems like integration might be the *one* case where the docs don’t need to be in asciidoc (colindixon, 15:20:06)
    4. regXboi +1 colindixon's comment (regXboi, 15:20:32)
    5. colindixon notes that the hydrogen edition tests should probably be flagged as being EOLed unless we intend to turn them back on (colindixon, 15:20:45)
    6. Manny here. sorry i'm late. i didn't know which channel i needed join. (manny_, 15:22:35)
    7. regXboi notes that we should schedule integration and docs at the *END* of the review in the (colindixon, 15:23:28)

  8. docs (colindixon, 15:23:30)
    1. https://wiki.opendaylight.org/view/Docs:Helium_Release_Review (colindixon, 15:23:37)
    2. colindixon notes that the release review is sparse, but this probably makes sense for docs (colindixon, 15:24:20)
    3. docs-merge uses parameterized build with GERRIT_BRANCH set to master - that's ok (regXboi, 15:25:20)
    4. ACTION: manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents (colindixon, 15:26:35)
    5. colindixon notes that docs will need attention from now until the release (with no offense meant to the docs team or manny) (colindixon, 15:27:44)
    6. docs-merge job doesn't actually upload site information that regXboi can see - wasn't that the plan? (regXboi, 15:27:57)
    7. ACTION: manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website (colindixon, 15:29:23)

  9. plugin2oc (colindixon, 15:30:37)
    1. https://wiki.opendaylight.org/view/Southbound_Plugin_to_the_OpenContrail_Platform:Helium_Release_Review (PriyankaChopra, 15:31:01)
    2. https://wiki.opendaylight.org/view/Southbound_Plugin_to_the_OpenContrail_Platform:Helium_Release_Notes (PriyankaChopra, 15:31:13)
    3. ACTION: PriyankaChopra to migrate plugin2oc docs to asciidoc in the docs.git (or at least put in hyperlinks to the right wiki pages) (colindixon, 15:33:01)
    4. plugin2oc-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch (regXboi, 15:33:24)
    5. ACTION: colindixon and regXboi to powwow with mestery about ODL neutron L3 driver (regXboi, 15:35:27)
    6. colindixon notes PriyankaChopra says plugin2oc will be able to participate in stable releases (colindixon, 15:37:07)
    7. ACTION: gzhao to connect with projects to make sure they know stable releases are coming and what will be expected of them (probably do this after the He release) (colindixon, 15:37:53)

  10. SFC (colindixon, 15:38:12)
    1. https://wiki.opendaylight.org/view/Service_Function_Chaining:Helium_Release_Review (repenno, 15:39:04)
    2. https://wiki.opendaylight.org/view/Service_Function_Chaining:Helium_Release_Review (colindixon, 15:39:17)
    3. sfc-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch (regXboi, 15:39:42)
    4. ACTION: repenno to add a release notes page for SFC something like this: https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes (colindixon, 15:40:39)
    5. ACTION: repenno to migrate docs to asciidoc in docs.git (or at least put hyperlinks pointing to any wiki page documentation that is there) (colindixon, 15:41:06)
    6. phrobb notes that there appears to be no docs except a single git clone command (colindixon, 15:42:33)
    7. repenno asks about any information about getting sonar working, colindixon doesn’t know that we have it but there was a TWS from Madhu_offline and dave_tucker at some point (colindixon, 15:43:47)
    8. it was the august 11th TWS call (colindixon, 15:44:09)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2014/tws/opendaylight-meeting-tws.2014-08-11-17.00.html the meeting minutes from when Madhu_offline and dave_tucker presented stuff on sonar (colindixon, 15:45:24)
    10. https://meetings.webex.com/collabs/url/DoaLWeoQ9KV-38qIuh042PUxbmlCDAJMFlXkP6_aOl400000 webex recording of same place (colindixon, 15:45:39)
    11. https://jenkins.opendaylight.org/ovsdb/job/ovsdb-code-coverage/configure <== OVSDB teams code coverage jenkins job, which does SONAR reporting (tbachman, 15:47:19)
    12. colindixon notes that gzhao and regXboi would like to re-review SFC, but colindixon feels as though the issues they have are the same as other projects, e.g., get docs together and get release notes written (colindixon, 15:50:40)
    13. liemmn for AAA (liemmn, 15:51:03)

  11. AAA (colindixon, 15:51:06)
    1. ACTION: gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information (colindixon, 15:54:10)

  12. AAA (colindixon, 15:54:19)
    1. regXboi notes aaa-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch (colindixon, 15:54:34)
    2. https://wiki.opendaylight.org/view/AAA:Helium_Release_Review (liemmn, 15:54:57)
    3. https://wiki.opendaylight.org/view/AAA:Helium_Release_Review (colindixon, 15:54:59)
    4. https://git.opendaylight.org/gerrit/#/c/11515/ (liemmn, 15:56:00)
    5. ACTION: liemmn to add a link to the gerrit for the asciidoc dev guide to the AAA release review page (colindixon, 15:56:03)
    6. https://git.opendaylight.org/gerrit/#/c/11515/ is the link (colindixon, 15:56:23)
    7. colindixon notes that the patch has been -1ed awaiting revision (colindixon, 15:56:37)
    8. ACTION: liemmn will add a release notes page for AAA something like https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes (colindixon, 15:57:39)
    9. colindixon would love to see how the schedule slipped listed, but it’s fine (colindixon, 15:59:28)

  13. OVSDB (at 9:30 PST in ~30 minutes) (colindixon, 16:02:49)
  14. blocking issues (colindixon, 16:05:58)
  15. OVSDB (colindixon, 16:34:08)
    1. https://wiki.opendaylight.org/view/OVSDB_Integration:Helium_Release_Review (Madhu, 16:34:20)
    2. https://wiki.opendaylight.org/view/OVSDB_Integration:Helium_Release_Notes (Madhu, 16:34:35)
    3. colindixon notes that the asciidoc gerrit doesn’t build (colindixon, 16:37:35)
    4. flaviof is working with the docs team on more docs, including install and user guides (colindixon, 16:40:48)
    5. colindixon notes that ovsdb jenkins merge builds from origin/master (colindixon, 16:41:16)
    6. OVSDB project will switch to stable/helium shortly ;) (Madhu, 16:43:08)


Meeting ended at 16:44:01 UTC (full logs).

Action items

  1. Rafat to migrate SDNi docs from the wiki to asciidoc (or at least put a hyperlink from the asciidoc to the appropriate wiki pages)
  2. hideyuki to move VTN’s wiki docs to asciidoc (or at least put links to the right wiki pages in)
  3. colindixon to add show stopping bugs after 2058 to the spreadsheet
  4. colindixon to fix the jenkins merge instructions for new projects to only build origin/master
  5. gzhao to move 2011 from to be verified to fixed
  6. harman_ to add some description of the requirements to run and develop for dlux to the rlease notes (I know it’s different than other projects)
  7. regXboi to open help ticket with LF to update https://jenkins.opendaylight.org/ to list all ODL jenkins job there (after release)
  8. gzhao and phrobb to figure out if we can do a release review for docs at a different time
  9. : we should instruct folks to be on the channel 10 minutes early in case we run ahead...
  10. manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
  11. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
  12. PriyankaChopra to migrate plugin2oc docs to asciidoc in the docs.git (or at least put in hyperlinks to the right wiki pages)
  13. colindixon and regXboi to powwow with mestery about ODL neutron L3 driver
  14. gzhao to connect with projects to make sure they know stable releases are coming and what will be expected of them (probably do this after the He release)
  15. repenno to add a release notes page for SFC something like this: https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
  16. repenno to migrate docs to asciidoc in docs.git (or at least put hyperlinks pointing to any wiki page documentation that is there)
  17. gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information
  18. liemmn to add a link to the gerrit for the asciidoc dev guide to the AAA release review page
  19. liemmn will add a release notes page for AAA something like https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes


Action items, by person

  1. colindixon
    1. colindixon to add show stopping bugs after 2058 to the spreadsheet
    2. colindixon to fix the jenkins merge instructions for new projects to only build origin/master
    3. manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
    4. colindixon and regXboi to powwow with mestery about ODL neutron L3 driver
  2. edwarnicke
    1. manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
    2. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
  3. gzhao
    1. gzhao to move 2011 from to be verified to fixed
    2. gzhao and phrobb to figure out if we can do a release review for docs at a different time
    3. gzhao to connect with projects to make sure they know stable releases are coming and what will be expected of them (probably do this after the He release)
    4. gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information
  4. harman_
    1. harman_ to add some description of the requirements to run and develop for dlux to the rlease notes (I know it’s different than other projects)
  5. hideyuki
    1. hideyuki to move VTN’s wiki docs to asciidoc (or at least put links to the right wiki pages in)
  6. liemmn
    1. liemmn to add a link to the gerrit for the asciidoc dev guide to the AAA release review page
    2. liemmn will add a release notes page for AAA something like https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
  7. manny_
    1. manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
    2. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
  8. mlemay_away
    1. manny_ will work with edwarnicke, mlemay_away, and colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
    2. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
  9. phrobb
    1. gzhao and phrobb to figure out if we can do a release review for docs at a different time
    2. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
    3. gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information
  10. PriyankaChopra
    1. PriyankaChopra to migrate plugin2oc docs to asciidoc in the docs.git (or at least put in hyperlinks to the right wiki pages)
  11. Rafat
    1. Rafat to migrate SDNi docs from the wiki to asciidoc (or at least put a hyperlink from the asciidoc to the appropriate wiki pages)
  12. regXboi
    1. regXboi to open help ticket with LF to update https://jenkins.opendaylight.org/ to list all ODL jenkins job there (after release)
    2. manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
    3. colindixon and regXboi to powwow with mestery about ODL neutron L3 driver
  13. repenno
    1. repenno to add a release notes page for SFC something like this: https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
    2. repenno to migrate docs to asciidoc in docs.git (or at least put hyperlinks pointing to any wiki page documentation that is there)
    3. gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information


People present (lines said)

  1. colindixon (240)
  2. regXboi (97)
  3. gzhao (51)
  4. tbachman (29)
  5. harman_ (27)
  6. phrobb (26)
  7. Madhu (25)
  8. edwarnicke (25)
  9. odl_meetbot (15)
  10. LuisGomez (13)
  11. hideyuki (13)
  12. liemmn (12)
  13. repenno (11)
  14. manny_ (9)
  15. PriyankaChopra (9)
  16. Rafat_1 (7)
  17. Rafat (6)
  18. abhijitkumbhare (2)
  19. mlemay_away (1)
  20. rovarga (1)
  21. tykeal (1)
  22. dkutenic (1)


Generated by MeetBot 0.1.4.