#opendaylight-meeting: Helium Weekly

Meeting started by edwarnicke at 15:43:48 UTC (full logs).

Meeting summary

    1. edwarnicke (edwarnicke, 15:44:01)
    2. goldavberg for lispflowmapping (goldavberg, 15:44:02)
    3. dkehnx - opflex (dkehnx, 15:44:09)
    4. liemmn for aaa (liemmn, 15:44:11)
    5. oflibMichal for openflowjava (oflibMichal, 15:44:12)
    6. regXboi for <nothing> :) (regXboi, 15:44:13)
    7. paulz for docs (paulz, 15:44:17)
    8. Luis for integration (LuisGomez, 15:44:17)
    9. Rafat for ODl-SDNi App (rafat, 15:44:24)
    10. brockners for SNBI (brockners, 15:44:35)
    11. https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations (LuisGomez, 15:44:41)
    12. link for project expectations (LuisGomez, 15:44:56)

  1. Q&A on M4 deliverables (LuisGomez, 15:45:26)
    1. priyanka for southplugin for opencontrail (priyanka_, 15:45:28)
    2. so far we are asking projects to fill karaf features (LuisGomez, 15:46:02)
    3. abhijitkumbhare for Openflow plugin (abhijitkumbhare, 15:46:26)
    4. there will be also components to cover those parts cannot be defined in Karaf (LuisGomez, 15:46:44)
    5. George Zhao for RM (gzhao__, 15:47:05)
    6. ChristineH for snmp4sdn (ChristineH, 15:47:29)
    7. Madhu will explain more in detail thr java test documentation and report we expect projects to fulfill (LuisGomez, 15:48:56)
    8. basically we are asking for some Junit test coverage (LuisGomez, 15:49:33)
    9. there is no % expectation yet (LuisGomez, 15:50:03)
    10. there is wiki on Sonar coverage: (LuisGomez, 15:50:27)
    11. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Code_Coverage_using_Jacoco (LuisGomez, 15:50:53)
    12. unit test should work with this instruction (LuisGomez, 15:51:23)
    13. there are issues reporting PAX-EXAM test to Sonar but Madhu has workaround for that (LuisGomez, 15:51:57)
    14. ovsdb sonar reporting : https://sonar.opendaylight.org/dashboard/index/14975 (Madhu, 15:54:22)
    15. madhu says Sonar is now ready to handle UT and IT (PAX-EXAM) tests (LuisGomez, 15:54:37)
    16. https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests shows all the tests being run (Madhu, 15:55:11)
    17. https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests is an example from ovsdb project which shows all the tests including UT, IT and Pax (Madhu, 15:55:46)
    18. https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests&rids[]=15977 is an example of pax-exam tests for 3 subsystems in ovsdb logically grouped (Madhu, 15:56:34)
    19. https://git.opendaylight.org/gerrit/#/c/9482/ fix to enable pax-exam results in sonar (Madhu, 16:00:47)
    20. pax-exam and karaf features go really well together (Madhu, 16:01:58)
    21. pax-exam without karaf is a disaster :( and the following link will explain why (Madhu, 16:02:18)
    22. thats why we set PAX-EXAM IT in release check list (LuisGomez, 16:02:49)
    23. https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=integrationtest/src/test/java/org/opendaylight/ovsdb/integrationtest/ConfigurationBundles.java;h=f43dea7f331640a2f45f1505fe9efb2b1c2a5a5f;hb=master example of pax-exam without karaf definition (Madhu, 16:04:00)
    24. its literally a train wreck and it is very difficult to debug even a single missing dependency for the entire IT (Madhu, 16:04:22)
    25. Based on our "not-so-happy-experience" highly highly recommend Pax-exam with Karaf. (Madhu, 16:04:49)
    26. but ... highly recommend doing pax-exam testing. especially in a OSGi environment like ours (Madhu, 16:05:08)
    27. mere FailSafe UT & SureFire IT will not help (Madhu, 16:05:25)
    28. 6 projects don't participate PAX-EXAM based on M4 status out of 20 reported. (gzhao__, 16:06:25)
    29. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Integration_Tests wiki on using pax-exam (Madhu, 16:08:23)
    30. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Integration_Tests (LuisGomez, 16:08:24)
    31. PacketCable PCMM Thomas Kee (xsited, 16:17:28)
    32. on the Test documentation front, i will append to the existing wiki. (Madhu, 16:19:41)
    33. ACTION: Madhu to publish java test documentation recommendations (LuisGomez, 16:20:35)
    34. the test documentation recommendations are merely javadocs on the test cases (Madhu, 16:21:57)
    35. ACTION: mlemay,madhu and luis to clean up PAX-EXAM documentation in general (LuisGomez, 16:21:58)
    36. the recommendations on test documentations will include Test plan (logical grouping) organization and Test case (individual @Test test-cases) organization and Javadocs for them (Madhu, 16:22:53)
    37. sonar will be the single source of truth for Code coverage, Test execution and Test Documentation. (Madhu, 16:23:33)
    38. ACTION: gzhao__ HelenYChen to pick up autorelease (edwarnicke, 16:29:43)
    39. ACTION: gzhao__ to pursue projects with no status (LuisGomez, 16:57:32)


Meeting ended at 16:59:21 UTC (full logs).

Action items

  1. Madhu to publish java test documentation recommendations
  2. mlemay,madhu and luis to clean up PAX-EXAM documentation in general
  3. gzhao__ HelenYChen to pick up autorelease
  4. gzhao__ to pursue projects with no status


Action items, by person

  1. gzhao__
    1. gzhao__ HelenYChen to pick up autorelease
    2. gzhao__ to pursue projects with no status
  2. HelenYChen
    1. gzhao__ HelenYChen to pick up autorelease
  3. Madhu
    1. Madhu to publish java test documentation recommendations
    2. mlemay,madhu and luis to clean up PAX-EXAM documentation in general
  4. mlemay
    1. mlemay,madhu and luis to clean up PAX-EXAM documentation in general


People present (lines said)

  1. edwarnicke (121)
  2. Madhu (96)
  3. LuisGomez (59)
  4. gzhao__ (11)
  5. goldavberg (6)
  6. tbachman (5)
  7. odl_meetbot (4)
  8. ttkacik (3)
  9. liemmn (3)
  10. abhijitkumbhare (3)
  11. paulz (2)
  12. ChristineH (2)
  13. alagalah (2)
  14. rafat (1)
  15. regXboi (1)
  16. dkehnx (1)
  17. HelenYChen (1)
  18. xsited (1)
  19. priyanka_ (1)
  20. brockners (1)
  21. oflibMichal (1)
  22. mlemay (1)


Generated by MeetBot 0.1.4.