#opendaylight-meeting: MD-SAL call

Meeting started by edwarnicke at 16:05:49 UTC (full logs).

Meeting summary

  1. What was done last week (edwarnicke, 16:06:34)
    1. Big memory reductions (edwarnicke, 16:06:44)
    2. stability improvements (edwarnicke, 16:06:51)
    3. https://jenkins.opendaylight.org/integration/job/integration-csit-base-of13/ - all OF13 integration tests passing (edwarnicke, 16:07:33)
    4. https://docs.google.com/spreadsheets/d/1O5PxEM1eLszMuWf9M11AD5w7siT9vHOkzR85gjCB-6c/edit#gid=322436364 edwarnicke provided a spreadsheet to track these items (tbachman, 16:08:14)

  2. What will be don (what's planned) (tbachman, 16:08:42)
    1. bug 1010, Return from Restconf the errors as definied in the IETF draft (tbachman, 16:09:03)
    2. /modules and /streams failing, fix should be coming as well (tbachman, 16:09:25)
    3. Netconf connector - return the netconf errors back in the RPC result (allow the RPC errors to be passed through). waiting on a parent patch. (tbachman, 16:11:40)
    4. Ask question needs some focus: https://ask.opendaylight.org/question/99/how-does-request-routing-works/ (devinavery, 16:12:36)
    5. Tony - is writing down the explanation (devinavery, 16:12:55)
    6. https://ask.opendaylight.org/question/99/how-does-request-routing-works/ - question no how request routing works (edwarnicke, 16:13:36)
    7. bug 990 and one other, where union types aren't getting translated in binding independent and binding aware correctly (tbachman, 16:13:37)
    8. ACTION: Tony to answer https://ask.opendaylight.org/question/99/how-does-request-routing-works/ (edwarnicke, 16:13:42)
    9. ttkacik merged fix for 990 (tbachman, 16:15:52)
    10. rovarga has about 10 patches to address the data store (tbachman, 16:18:00)
    11. devinavery et. al. have stuff in the works to add mount points, etc. to all plugin of 3rd party protocols (tbachman, 16:18:31)

  3. Other Topics upcoming (tbachman, 16:21:21)
    1. clustering in the MD-SAL (tbachman, 16:21:32)
    2. there are discussions happening on the discuss list about this now (colindixon, 16:23:34)
    3. MD_SAL Status call minutes have been sent to the controller-dev and yangtools-dev mailing lists (tbachman, 16:25:20)
    4. edwarnicke recommends using balance of time to cover the email that tkacik was prreparing (tbachman, 16:27:11)
    5. clustered data store discussion moved to next week's MD-SAL meeting (tbachman, 16:27:28)
    6. tkacik covers How does request routing works (tbachman, 16:28:20)
    7. Question was how does request routing work on a per node/host basis (tbachman, 16:28:39)
    8. How does ODL invoke the right plugin for the right node? (tbachman, 16:30:02)
    9. Confusion comes from looking at AD-SAL vs. MD-SAL (tbachman, 16:30:27)
    10. MD-SAL doesn't have the notion of node type. (tbachman, 16:30:51)
    11. MD-SAL instead allows you to register an RPC in the context of a node. (tbachman, 16:31:21)
    12. For example, the OpenFlow plugin registers RPCs for flow programming for a given node. (tbachman, 16:31:43)
    13. That causes flow programming for that node to be routed to the OpenFlow plugin (tbachman, 16:32:10)
    14. edwarnicke asks what is the problem that is being solved (tbachman, 16:34:16)
    15. Solaris doesn't support OVS, so they want to provide their own plugin so that it handles Solaris nodes differently (tbachman, 16:34:53)
    16. Using the example of configuring a VLAN, edwarnicke recommends creating a set-vlan RPC in the NB model, and the solaris plugin would register itself to create VLAN RPCs for nodes discovered by the solaris plugin. (tbachman, 16:36:42)
    17. Can mutliple SB plugins register for the same property change on the same node? (tbachman, 16:39:26)
    18. Only one SB can register for the implementation per RPC. (tbachman, 16:39:55)
    19. devinavery notes that this is exactly what they're putting together in their example. (tbachman, 16:40:25)
    20. New example we are working on is tracked with bug 1050 (devinavery, 16:44:06)
    21. rovargo notes that there needs to be a unified view of the topology. (tbachman, 16:46:20)


Meeting ended at 16:58:02 UTC (full logs).

Action items

  1. Tony to answer https://ask.opendaylight.org/question/99/how-does-request-routing-works/


People present (lines said)

  1. tbachman (37)
  2. edwarnicke (14)
  3. odl_meetbot (5)
  4. devinavery (3)
  5. colindixon (3)
  6. icbts (2)
  7. Madhu (1)
  8. alagalah (1)
  9. CASP3R (0)


Generated by MeetBot 0.1.4.