#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 15:05:18 UTC (full logs).

Meeting summary

    1. devinavery asks if anyone has looked at/considered the ping example when generating the pain points list (tbachman, 15:06:05)
    2. alagalah_ says he put the ping example up on the wiki but that’s as far as he’s gotten (tbachman, 15:06:22)
    3. devinavery says he wanted to make it evident that the ping example uses the AD-SAL, and uses the abstractbindingaware classes (tbachman, 15:06:57)
    4. devinavery asks if we’re going to continue supporting the abstractbindingaware classes (tbachman, 15:07:36)
    5. rovarga says that we either deprecated or meant to deprecate those classes, with the reason being that they rely on OSGI for activation, which we’re trying to free ourselves from being dependent on (tbachman, 15:08:49)
    6. devinavery says they’re not yet deprecated, and these classes are currently activated “out of band” from the MD-SAL (tbachman, 15:09:40)
    7. ttkacik says these classes don’t allow for custom broker injections, and takes the first broker they find in the OSGI registry (tbachman, 15:10:25)
    8. ttkacik recommends deprecating these APIs and helping folks migrate off of them (tbachman, 15:10:44)
    9. devinavery says there may still be simple use cases woth keeping these classes around for (tbachman, 15:11:46)

  1. MD-SAL pain points (tbachman, 15:11:59)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2014-10-20-15.07.html Last week’s MD-SAL hackers call minutes (tbachman, 15:12:57)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review alagalah_’s WIP for helping folks with the MD-SAL (tbachman, 15:14:26)
    3. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem alagalah_’s WIP for the config subsystem (tbachman, 15:15:10)
    4. alagalah_ says that folks can add things to these, such as links to outside tutorials, youtube videos, etc. (tbachman, 15:16:31)
    5. jmedved and rovarga say that alagalah_’s template is good (tbachman, 15:18:27)
    6. jmedved says we could add the component map, which maps out all the components (tbachman, 15:19:31)
    7. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Component_Map Config subsystem component map (tbachman, 15:20:10)
    8. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Component_Map BGP-PCEP component map (tbachman, 15:21:11)
    9. https://wiki.opendaylight.org/view/YANG_Tools:Component_Map YANG tools component map (tbachman, 15:21:20)
    10. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Component_Map OpenFlow plugin component map (tbachman, 15:21:46)
    11. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Netconf:Component_Map Controller component map (tbachman, 15:22:04)
    12. ACTION: alagalah to update sub-project wiki with component map links and recommend this be part of all projects as per jmedved suggestion either in Docs project or as part of Li RP (alagalah_, 15:22:44)
    13. jmedved asks what the next steps are, and who are the owners? (tbachman, 15:23:13)
    14. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem (alagalah_, 15:27:20)
    15. rovarga will take on the config subsystem documentation (with help from maros) (tbachman, 15:27:45)
    16. ttkacik will take on the MD-SAL, and devinavery will help out, time permitting (tbachman, 15:29:00)
    17. tpatelis will also help out with the MD-SAL (tbachman, 15:29:15)
    18. alagalah_ says he wasn’t sure if YANG should be it’s own subproject (tbachman, 15:30:16)
    19. jmedved and rovarga will take on the overall architecture (tbachman, 15:30:33)
    20. ACTION: rovarga will take on the config subsystem documentation (with help from maros) (tbachman, 15:30:52)
    21. ACTION: tkacik will take on the MD-SAL, and devinavery will help out, time permitting, and tpatelis (tbachman, 15:31:05)
    22. ACTION: jmedved and rovarga will take on the overall architecture (tbachman, 15:31:16)
    23. devinavery says we may want to make YANG and clustering sub-items of the MD-SAL template (tbachman, 15:31:39)
    24. devinavery recommends statting with config subsystem and MD-SAL, and then look to the other pieces later (tbachman, 15:33:05)
    25. alagalah_ agrees that we should start with MD-SAL and config subsystem for this week (tbachman, 15:33:34)
    26. alagalah_ asks if there’s anything major missing here (tbachman, 15:34:26)
    27. jmedved says he’d like to see several others added — BGP/PCEP, Group Based Policy, OpenFlow Plugin, etc. (tbachman, 15:34:58)
    28. alagalah_ agrees - but wants to start with these. (tbachman, 15:35:19)
    29. uchau says she would help review any of the documentation/write-ups (tbachman, 15:36:13)

  2. Uyen Chau’s Pain Points List (tbachman, 15:40:12)
    1. uchau says that this list is the feedback from their engineers (tbachman, 15:41:02)
    2. the examples were helpful (tbachman, 15:41:07)
    3. The documentation describes how to do things, but not why (tbachman, 15:41:16)
    4. this makes it tough to understand how to do anything but the example at hand (tbachman, 15:41:34)
    5. The config subsystem has been particularly challenging to understand what it does (e.g. how does it relate to bundle dependencies in OSGI) (tbachman, 15:42:11)
    6. There are also questions on how the config .xml’s work - what are the relationships between them (tbachman, 15:42:51)
    7. uchau says that the other sections asks things like “why are we using the config subsystem”, and “what alternatives are out there and what did we consider?” (tbachman, 15:45:30)
    8. Lots of questions about what types of functionality we’re providing, where we’re providing it (e.g. config subsystem, karaf) (tbachman, 15:47:58)
    9. uchau asks if they can use the MD-SAL without YANG? (tbachman, 15:49:17)
    10. For example, can MD-SAL be used for infrastructure (e.g. pub/sub), without having to use YANG (tbachman, 15:49:49)
    11. ACTION: uchau to take her list and add it to the pain points wiki page (tbachman, 15:50:44)
    12. jmedved asks if there are any other things we should add to alagalah_’s list (e.g. logging, RESTCONF, etc.) that needs explaining/adjusting? (tbachman, 15:52:19)
    13. devinavery says RESTCONF for sure, but those may be sub-elements of other things. (tbachman, 15:52:41)
    14. uchau asks about security (tbachman, 15:53:30)
    15. alagalah_ says that could be addressed as part of the architecture (tbachman, 15:53:40)
    16. jmedved says that security is a lot more in flux than the other subsystems (tbachman, 15:53:59)
    17. we may want to treat security slightly different because of this (tbachman, 15:54:51)
    18. devinavery says he took the action item for seaching the MD-SAL, and has sent an email to the community to solicit feedback on this topic (tbachman, 15:55:33)
    19. devinavery asks if others on the call could provide feedback on searching the MD-SAL (tbachman, 15:56:07)
    20. uchau says to have a look at the services platform that HP presented at the dev summit (tbachman, 15:56:28)
    21. jmedved asks devinavery to involve sharon, as he’s doing work in this area too (tbachman, 15:57:05)
    22. https://wiki.opendaylight.org/view/File:ODL_Net_Svcs_APIs_v1.pptx (uchau, 15:57:34)
    23. https://wiki.opendaylight.org/view/File:ODL_Net_Svcs_APIs_v1.pptx HP’s presentation on Network Services (tbachman, 15:58:18)
    24. devinavery asks if we want to move this call to the Tuesday time slot, or kill the Tuesday time slot? (tbachman, 15:59:06)
    25. alagalah_ says that we should keep that timeslot so we can do things like present our templates once their ready (tbachman, 16:00:13)
    26. devinavery says that the TWS might be the better place for this, and have the Tuesday call be available as an overflow for TWS topics (tbachman, 16:00:43)


Meeting ended at 16:01:50 UTC (full logs).

Action items

  1. alagalah to update sub-project wiki with component map links and recommend this be part of all projects as per jmedved suggestion either in Docs project or as part of Li RP
  2. rovarga will take on the config subsystem documentation (with help from maros)
  3. tkacik will take on the MD-SAL, and devinavery will help out, time permitting, and tpatelis
  4. jmedved and rovarga will take on the overall architecture
  5. uchau to take her list and add it to the pain points wiki page


Action items, by person

  1. uchau
    1. uchau to take her list and add it to the pain points wiki page
  2. UNASSIGNED
    1. alagalah to update sub-project wiki with component map links and recommend this be part of all projects as per jmedved suggestion either in Docs project or as part of Li RP
    2. rovarga will take on the config subsystem documentation (with help from maros)
    3. tkacik will take on the MD-SAL, and devinavery will help out, time permitting, and tpatelis
    4. jmedved and rovarga will take on the overall architecture


People present (lines said)

  1. tbachman (76)
  2. odl_meetbot (5)
  3. jmedved_ (4)
  4. alagalah_ (2)
  5. uchau (1)


Generated by MeetBot 0.1.4.