#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 16:02:59 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 16:04:41)
    1. jmedved asks if anyone’s reviewd the notifications API from ttkacik and rovarga (tbachman, 16:07:27)
    2. rovarga says there have been a few comments (tbachman, 16:07:42)
    3. jmedved asks if it makes sense to do anything with the documentation review (tbachman, 16:08:14)

  2. Documentation review (tbachman, 16:08:21)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:MD_SAL Link describing MD-SAL documentation review (tbachman, 16:13:49)
    2. ttkacik reviews the updates he’s provided on the MD-SAL documentation (see recording) (tbachman, 16:15:15)
    3. jmedved to remove specifics from the Architecture overview and reference specifics in MD-SAL (alagalah, 16:17:12)
    4. jmedved asks if the MD-SAL documentation satisfies alagalah’s criteria for documentation (tbachman, 16:18:10)
    5. alagalah says it’s a fantastic start, but he needs to go through it in detail, to make sure it provides the background context that allows folks to approach the examples, etc. (tbachman, 16:18:55)
    6. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Explained MD-SAL explained wiki page created by ttkacik (tbachman, 16:19:39)
    7. jmedved asks the rest of the participants on the call to review the documentation so we can comment it on next week’s call (and provide feedback using the “Discussion” tab on the wiki) (tbachman, 16:20:39)
    8. AGREED: participants on the call to review the documentation so we can comment it on next week’s call (and provide feedback using the “Discussion” tab on the wiki) (tbachman, 16:21:16)
    9. ttkacik says that relationship between YANG tools and the MD-SAL needs to be explained, and ttkacik is probably the best person to do that (tbachman, 16:22:08)
    10. ACTION: ttkacik to put this as a placeholder in the MD-SAL arch page (tbachman, 16:22:31)
    11. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem Wiki page documenting the config subsystem (tbachman, 16:24:11)
    12. jmedved says that the activity diagram would be really helpful (tbachman, 16:25:09)
    13. ACTION: rovarga to provide the activity diagram for the config subsystem (tbachman, 16:25:46)
    14. ACTION: rovarga to get Maros to put in Education/tuturial section for config subsystem (alagalah, 16:27:06)
    15. ACTION: rovarga to get Maros on IRC :) (alagalah, 16:27:14)
    16. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Architecture MD-SAL documentation architecture wiki page (tbachman, 16:28:14)
    17. jmedved added background on the decisions that are used in the architecture (tbachman, 16:29:27)
    18. the architecture needs to be expanded to include clustering or other components (i.e. living wiki page to be augmented by others) (tbachman, 16:29:58)
    19. The controller is both a platform and an SDN Application Development environment (tbachman, 16:31:12)
    20. alagalah says he sees the Architecture page as the “landing page”, and clustering being something that’s linked off of it (tbachman, 16:34:16)
    21. moiz says we should mention something about clustering on the Architecture page (tbachman, 16:34:51)
    22. alagalah asks if we should indicate that this page is in reference to the Helium release? (tbachman, 16:36:58)
    23. jmedved says yes, this should probably indicate that it’s covering the Helium and Lithium architecture (tbachman, 16:37:13)
    24. ACTION: moizer to write up a section on clustering and add it to the architecture wiki page (tbachman, 16:37:51)
    25. ACTION: ttkacik to add a parts on YANG Tools to the architecture wiki page (tbachman, 16:38:28)
    26. jmedved asks if there’s anything else that’s needed in the architecture page (tbachman, 16:38:40)
    27. colindixon says we should summarrize that the MD-SAL is: 1) RPC, 2) Notifications, and 3) a Data Store (tbachman, 16:39:26)
    28. edwarnicke_ agrees, and says we’ve made the mistake in the past of introducing folks to all the more helpful and complex features of the MD-SAL before understanding the simpler aspects first (tbachman, 16:40:36)
    29. alagalah says he’d like to understand how the config subsystem, MD-SAL, OSGI, and Karaf all relate to each other (tbachman, 16:42:00)
    30. jmedved agrees (tbachman, 16:42:18)
    31. ACTION: colindixon to write the 10k ft view of the config subsystem (tbachman, 16:43:14)
    32. edwarnicke_ offers his help to colindixon if he has any q’s (tbachman, 16:44:04)
    33. rovarga says that edwarnicke_ is probably the only person who understands the relationship between the config subsystem and the karaf runtime (tbachman, 16:45:34)
    34. ACTION: edwarnicke_ to write up the interaction between the config subsystem and karaf (tbachman, 16:46:17)
    35. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:KARAF_OSGI (alagalah, 16:47:11)
    36. ACTION: alagalah to try writing up the karaf and OSGI interaction (tbachman, 16:50:59)
    37. maros requests feedback on the config subsystem wiki page (tbachman, 16:53:14)
    38. alagalah says that the education/tutorial section was removed (tbachman, 16:54:41)
    39. maros says he took it out by accident (tbachman, 16:54:51)
    40. jmedved requests to make the figures smaller in the wiki (tbachman, 16:55:02)
    41. uchau asks when we expect this to be done (tbachman, 16:56:16)
    42. maros says he thinks he can get the first version done in a couple of days, and will send an email when it’s ready (tbachman, 16:56:45)
    43. jmedved says the one big one we don’t have covered is the RESTCONF/NETCONF section (tbachman, 16:58:09)
    44. alagalah says he wasn’t sure there was agreement that this did have it’s own section (tbachman, 16:58:20)
    45. ttkacik says he’d go with it as a subsection, since it is the northbound of the controller (tbachman, 16:58:45)
    46. ACTION: josef will provide the RESTCONF documentation (tbachman, 16:59:24)
    47. ACTION: team to identify non-Slovakian speaker to review the docs (non-English speaking reviewers) (tbachman, 17:02:06)


Meeting ended at 17:02:09 UTC (full logs).

Action items

  1. ttkacik to put this as a placeholder in the MD-SAL arch page
  2. rovarga to provide the activity diagram for the config subsystem
  3. rovarga to get Maros to put in Education/tuturial section for config subsystem
  4. rovarga to get Maros on IRC :)
  5. moizer to write up a section on clustering and add it to the architecture wiki page
  6. ttkacik to add a parts on YANG Tools to the architecture wiki page
  7. colindixon to write the 10k ft view of the config subsystem
  8. edwarnicke_ to write up the interaction between the config subsystem and karaf
  9. alagalah to try writing up the karaf and OSGI interaction
  10. josef will provide the RESTCONF documentation
  11. team to identify non-Slovakian speaker to review the docs (non-English speaking reviewers)


Action items, by person

  1. alagalah
    1. alagalah to try writing up the karaf and OSGI interaction
  2. edwarnicke_
    1. edwarnicke_ to write up the interaction between the config subsystem and karaf
  3. UNASSIGNED
    1. ttkacik to put this as a placeholder in the MD-SAL arch page
    2. rovarga to provide the activity diagram for the config subsystem
    3. rovarga to get Maros to put in Education/tuturial section for config subsystem
    4. rovarga to get Maros on IRC :)
    5. moizer to write up a section on clustering and add it to the architecture wiki page
    6. ttkacik to add a parts on YANG Tools to the architecture wiki page
    7. colindixon to write the 10k ft view of the config subsystem
    8. josef will provide the RESTCONF documentation
    9. team to identify non-Slovakian speaker to review the docs (non-English speaking reviewers)


People present (lines said)

  1. tbachman (60)
  2. odl_meetbot (5)
  3. alagalah (4)
  4. edwarnicke_ (0)


Generated by MeetBot 0.1.4.