#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 16:00:33 UTC (full logs).

Meeting summary

    1. ACTION: colindixon to update architecture wiki page for MD-SAL by next week (tbachman, 16:05:35)

  1. agenda bashing (tbachman, 16:06:33)
    1. Topic: archetype vs. template (tbachman, 16:06:53)
    2. Config Subsystem Documentation (alagalah, 16:07:03)
    3. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem (alagalah, 16:07:49)
    4. alagalah says he recommends folks look at the config subsystem wiki page, says it’s very very good (tbachman, 16:08:21)
    5. alagalah minor nits include missing how it fits into the controller (diagram) (tbachman, 16:08:52)
    6. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Sample_Project Sample Project for config subsystem wiki page (tbachman, 16:10:39)
    7. alagalah would like to change this to include where the dependency elements should be added (tbachman, 16:11:26)
    8. https://wiki.opendaylight.org/view/Talk:OpenDaylight_Controller:Config:Examples:Sample_Project comments on the Sample Project for config subssystem (tbachman, 16:12:09)
    9. ttkacik says for any examples, we should never use the parent poms of the controller project (tbachman, 16:12:38)
    10. edwarnicke agrees in a huge way (colindixon, 16:12:51)
    11. this is the job of odlparent, please do that (colindixon, 16:13:17)
    12. ACTION: alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (tbachman, 16:14:29)
    13. ACTION: alagalah tosend email to rovarga to initiate going through the proposal step-by-step (tbachman, 16:15:10)
    14. jmedved says that hte MD-SAL archetype works but can’t be loaded by karaf (tbachman, 16:15:26)
    15. ttkacik says that rovarga’s proposal makes it easy to start a new application (tbachman, 16:16:02)
    16. jmedved says we need to have a ready-made application that people can download and run (tbachman, 16:16:20)
    17. mlemay asks if this is related to the features-parent (tbachman, 16:17:00)
    18. ttkacik says partly (tbachman, 16:17:03)
    19. alagalah says we should put deprecated in big red letters on the existing config exmamples wiki pages (tbachman, 16:18:12)
    20. pantelis asks if the toaster is sufficient? (tbachman, 16:18:39)
    21. ttkacik says it can’t be part of the controller project, which is one of the most confusing things to new folks (tbachman, 16:19:03)
    22. ttkacik says that the snapshots archetype doesn’t work with all systems (tbachman, 16:19:52)
    23. pantelis asks if it makes sense to make the toaster example the way we want it (e.g. outside the controller) (tbachman, 16:20:16)
    24. jmedved says he’d love to see that, in addition to other examples (tbachman, 16:20:26)
    25. edwarnicke says the toaster should also be changed to just wire in a broker, which is simpler to understand, rather than wire it in service by service (tbachman, 16:21:15)
    26. jmedved says maybe we can start that way (simple), then add to it (tbachman, 16:21:49)
    27. alagalah says that’s valuable, but we need to start with the simple step which builds from scratch, and then add to it step by step (tbachman, 16:23:22)
    28. alagalah says that whatever we use as the example, we need to decide on the call what the next steps are (tbachman, 16:24:16)
    29. alagalah would like to walk through the example with the author, in order to have direct assistance to understand what needs to be changed/improved (tbachman, 16:24:49)
    30. jmedved feels whatever we do should be based on rovarga’s proposal (tbachman, 16:25:33)
    31. jmedved says the first example could be just a provider, with the next one adding a consumer, the next adding the configuration, the next one extending the model (tbachman, 16:26:30)
    32. edwarnicke says that the things that are missing is that the intermediate steps aren’t there for download, isn’t based on rovarga’s proposal, and doesn’t include edwarnicke’s requirement for simple config subsystem (tbachman, 16:27:42)
    33. ACTION: jmedved to email invites for working on this example (tbachman, 16:28:35)
    34. plan is for a 7am PST invite (tbachman, 16:28:53)
    35. ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references) (tbachman, 16:29:55)
    36. ACTION: colindixon to bring up removing hydrogen artifacts from main download page (tbachman, 16:30:37)
    37. ACTION: colindixon to follow up on " ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references)" (alagalah, 16:30:39)
    38. phrobb says that he’s been talking with the web site people to try to get the design changed to address this issue (tbachman, 16:31:18)

  2. example vs. archetype (tbachman, 16:31:44)
    1. jmedved asks if we need an archetype or a bunch of downloadable examples (tbachman, 16:32:08)
    2. moizr and edwarnicke say we need an archetype (tbachman, 16:32:22)
    3. jmedved says he had to clone a bunch of projects to see what they did in their features; isn’t very useful to complete n00bies (tbachman, 16:33:33)
    4. colindixon says we need the Julia Child effect, where you have the completed product available (“right out of the oven") (tbachman, 16:33:56)
    5. moizr asks where these tutorials will live (tbachman, 16:35:44)
    6. ttkacik recommends having asciidoc/markdown in the same dir (tbachman, 16:36:02)
    7. jmedved asks if we should have a new “samples” project with its own maintainer? Or us ODL Forge? (tbachman, 16:37:16)
    8. edwarnicke says we tried the samples with toolkit, as we had to chase down committers, and strongly urges to keep them in controller but not have them in the pom parent hierarchy of the controller (tbachman, 16:37:55)
    9. moizr says he’d like to see it in a separate repo so that folks can’t mess things up (tbachman, 16:38:12)
    10. mlemay says there example of how to do the tasks and the sample project itself (how to structure your repo) (tbachman, 16:38:52)
    11. colindixon says the only way he’s seen stuff maintained if it’s kept in the project that’s most likely to break it (tbachman, 16:40:38)
    12. There also needs to be a test associated with it to check that it’s broken (tbachman, 16:40:54)
    13. colindixon says the archetype should include both the step-by-step and the resulting artifact (tbachman, 16:41:16)
    14. colindixon notes that (as a committer on toolkit) he’s willing to try to help re-invent that project if people wanted to (colindixon, 16:43:16)
    15. ttkacik says there is a step-by-step tutorial starting from scratch, which can start with the wiki, and later migrate to asciidoc; there is also a set of tutorials which after each major step you have a working product, where the user can check out the code for the next step; (tbachman, 16:43:26)
    16. ttkacik says there can also be a step-by-step, commit-by-commit in the repo (tbachman, 16:44:04)
    17. This allows you to clone the repo and are ready to go (tbachman, 16:44:15)
    18. moizr says each step could have a separate folder (tbachman, 16:45:18)
    19. ttkacik says you could also do this commit-by-commit (tbachman, 16:45:29)
    20. jmedved says he feels separate folders is better (tbachman, 16:45:38)
    21. decision is to create step-by-step using folder-by-folder (tbachman, 16:46:27)
    22. AGREED: decision is to create step-by-step using folder-by-folder (tbachman, 16:46:55)
    23. ttkacik says we are addressing the samples and tutorials for the controller project — we should be more specific (tbachman, 16:49:09)
    24. alagalah recommends either controller_tutorials or controller_education (tbachman, 16:49:57)
    25. uchau asks if the tutorials are focused on the controller or MD-SAL? (tbachman, 16:50:07)
    26. jmedved says that’s a good question, but maybe that’s a “step 2” thing (tbachman, 16:51:53)
    27. jmedved says we need to put this on the list of things to do (i.e. to develop the other tutorials as well) (tbachman, 16:53:23)
    28. edwarnicke says do we want things like openflowplugin tutorials considered as well (tbachman, 16:54:03)
    29. jmedved would like to see these as individually loadable features in karaf (tbachman, 16:54:21)
    30. alagalah says we need to define the project scope, and recommends starting with tutorials for the controller, namely things that are offset 0 projects (tbachman, 16:54:58)
    31. offset 0 projects are odlparent, yangtools, and controller project (tbachman, 16:55:41)
    32. ACTION: alagalah to come up with a project proposal for this effort (tbachman, 16:56:39)
    33. ACTION: jmedved to include uchau in the 7am PST calls (tbachman, 16:58:10)


Meeting ended at 16:59:01 UTC (full logs).

Action items

  1. colindixon to update architecture wiki page for MD-SAL by next week
  2. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step
  3. alagalah tosend email to rovarga to initiate going through the proposal step-by-step
  4. jmedved to email invites for working on this example
  5. colindixon to bring up removing hydrogen artifacts from main download page
  6. colindixon to follow up on " ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references)"
  7. alagalah to come up with a project proposal for this effort
  8. jmedved to include uchau in the 7am PST calls


Action items, by person

  1. alagalah
    1. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step
    2. alagalah tosend email to rovarga to initiate going through the proposal step-by-step
    3. alagalah to come up with a project proposal for this effort
  2. colindixon
    1. colindixon to update architecture wiki page for MD-SAL by next week
    2. colindixon to bring up removing hydrogen artifacts from main download page
    3. colindixon to follow up on " ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references)"
  3. jmedved
    1. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step
    2. jmedved to email invites for working on this example
    3. jmedved to include uchau in the 7am PST calls


People present (lines said)

  1. tbachman (92)
  2. colindixon (12)
  3. odl_meetbot (8)
  4. alagalah (7)
  5. jmedved (4)
  6. alagalah_ (0)


Generated by MeetBot 0.1.4.