#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 16:00:23 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 16:00:33)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers_meeting/opendaylight-meeting-md_sal_hackers_meeting.2014-10-13-15.08.html minutes from previous week (tbachman, 16:06:44)

  2. Action Items from last week (tbachman, 16:07:32)
    1. alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input: done (tbachman, 16:07:42)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2014-11-17-16.00.html correct link to last week’s meeting (tbachman, 16:12:06)

  3. action items (revisited) (tbachman, 16:12:56)
    1. ACTION: colindixon to update arch wiki page by the end of the day (tbachman, 16:13:36)
    2. ACTION: alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (continued from last week) (tbachman, 16:13:55)
    3. alagalah tosend email to rovarga to initiate going through the proposal step-by-step:DONE (tbachman, 16:14:21)
    4. https://github.com/alagalah/odl-tutorial-toaster alagalah’s github account that’s tracking proposed documentation of pom architecture, etc. (tbachman, 16:17:07)
    5. jmedved says we’re achieving 2 things with one activity: correct directory and pom structure, and a tutorial for new projects to follow. (tbachman, 16:17:57)
    6. origin https://github.com/alagalah/odl-tutorial-toaster.git (fetch) --- tutorial link WIP (alagalah, 16:18:23)
    7. edwarnicke says it would be even better if we can tie the tutorial to a maven generated site (tbachman, 16:19:08)
    8. ttkacik says that the Lithium release plan requires things to be in asciidoc format, and recommends moving all documentation to a maven site for all offset 0 projects (tbachman, 16:20:58)
    9. jmedved to email invites for working on this example: DONE (tbachman, 16:21:56)
    10. ACTION: colindixon to bring up removing hydrogen artifacts from main download page (continued from last week) (tbachman, 16:23:17)
    11. for the project proposal, alagalah asks if we want this to be a separate project, or if it should live in documentation (tbachman, 16:25:28)
    12. colindixon says ODL forge may help here (tbachman, 16:26:28)
    13. ttkacik suggests having this as part of the release, as once you release, you’d have all the tutorials attached to the release (tbachman, 16:26:48)
    14. colindixon says it would be good to bring up how to have things tied to the release but not part of it (tbachman, 16:27:17)
    15. edwarnicke asks what offset we’d want it to be in (tbachman, 16:27:47)
    16. ttkacik says that since it usese the controller, it’s at least offset 1 (tbachman, 16:29:00)
    17. colindixon says that without clear ownership of the cross-project efforts, they turn into dumping grounds (tbachman, 16:30:35)
    18. alagalah says that for the scope for the project proposal, he can list the things he wants to document over time, and would reach out to contacts who would provide that input. (tbachman, 16:31:40)
    19. ACTION: alagalah to come up with a project proposal for a “documentation and tutorial for new projects” project (tbachman, 16:35:31)
    20. jmedved to include uchau in the 7am PST calls: DONE (tbachman, 16:35:58)

  4. release plan for M1 (tbachman, 16:39:26)
    1. ttkacik says they’ve started looking into automation of the release process (tbachman, 16:40:50)
    2. ttkacik says the controller project is using bugzilla to help with release planning (tbachman, 16:41:45)
    3. ttkacik every enhancement is prefixed with a milestone in bugzilla (tbachman, 16:42:19)
    4. this allows bugzilla to provide structured information about the individual milestones (tbachman, 16:44:25)
    5. ttkacik says there are overarching themes that aren’t tied to milestones, but are part of the overall release. These get tied to topics (tbachman, 16:44:54)
    6. There is an issues-maven plugin which can create release notes, link it to the bugs and issues that are fixed, based on the data exported by bugzilla (tbachman, 16:47:51)
    7. The same plugin can be used to export the release plan (tbachman, 16:48:11)
    8. edwarnicke asks when we can get to the point where we can publish a maven site (tbachman, 16:51:52)
    9. ttkacik says to fully replace the release plan wiki pages, it will be a few months effort (tbachman, 16:54:03)
    10. edwarnicke asks what can we do to document this style of approach so that projects could adopt it (tbachman, 16:55:33)
    11. ttkacik says he’d need help from a native english speaker to help (tbachman, 16:55:52)
    12. edwarnicke to help with the effort (tbachman, 16:56:24)
    13. edwarnicke asks if this would be a good thing to present on the TWS (tbachman, 16:56:53)
    14. ACTION: ttkacik to send an email with a concrete/specific example of how bugzilla can be set up to use for automation of release planning and tracking (tbachman, 16:58:29)
    15. jmedved would like to see a review of the notifications and associated documentation on the wiki (tbachman, 17:03:36)
    16. jmedved asks what we should focus on next week (tbachman, 17:04:08)
    17. ACTION: jmedved to send email to the mailing list to let folks know that next week’s meeting will be review on the notifications API (tbachman, 17:07:24)


Meeting ended at 17:07:32 UTC (full logs).

Action items

  1. colindixon to update arch wiki page by the end of the day
  2. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (continued from last week)
  3. colindixon to bring up removing hydrogen artifacts from main download page (continued from last week)
  4. alagalah to come up with a project proposal for a “documentation and tutorial for new projects” project
  5. ttkacik to send an email with a concrete/specific example of how bugzilla can be set up to use for automation of release planning and tracking
  6. jmedved to send email to the mailing list to let folks know that next week’s meeting will be review on the notifications API


Action items, by person

  1. alagalah
    1. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (continued from last week)
    2. alagalah to come up with a project proposal for a “documentation and tutorial for new projects” project
  2. jmedved
    1. alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (continued from last week)
    2. jmedved to send email to the mailing list to let folks know that next week’s meeting will be review on the notifications API
  3. ttkacik
    1. ttkacik to send an email with a concrete/specific example of how bugzilla can be set up to use for automation of release planning and tracking
  4. UNASSIGNED
    1. colindixon to update arch wiki page by the end of the day
    2. colindixon to bring up removing hydrogen artifacts from main download page (continued from last week)


People present (lines said)

  1. tbachman (59)
  2. odl_meetbot (7)
  3. alagalah (6)
  4. ttkacik (1)
  5. jmedved (0)


Generated by MeetBot 0.1.4.